LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-19-2013, 08:21 AM   #1
jodymaick
LQ Newbie
 
Registered: Feb 2013
Posts: 4

Rep: Reputation: Disabled
The "Page Up" key does not work properly


Hi.

I've installed the Slackware 14 with KDE a few months ago but, since the first day the "Page Up" key does not work properly. Whatever the application (Crome, Firefox, Kwrite, Writer, Kile, Okular, ...), when this key is pressed, instead of a single page up, the whole document or web page goes to the start and the key stop working. What is intersting is that the "Page Up" of numeric keypad works fine.

With hopes of being a keymap problem, I tried the "xmodmap" to remap Page Up to the keypad Page Up, but it does not solve the problem.

I use the "xev" to watch the keyboard events. Unlike other keys, when the "Page Up" is pressed once, the keycode is shown repeatedly, as if the key still pressed.

I don't beleave this is a hardware problem, because I used Windows when I bought my notebook and the key also works fine. My first linux experience was with a Opensuse dual boot and that was the moment when the problem started: it works on Windows, but don't on Suse. I was hoping to solve this by changing distro, but the problem persists.

Anyone have any idea?
 
Old 02-19-2013, 09:14 AM   #2
GazL
Senior Member
 
Registered: May 2008
Posts: 3,503

Rep: Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026
You can individually turn off repeat on keys using the xset -r <keycode> command, or use xset r off to turn them all off (probably not a good idea). At a guess I'd expect the defaults for which keys should repeat are somewhere within the XKB definitions, but I don't have enough of an understanding of that to comment.

P.S. Virtually all my keys generate repeated keypress/keyrelease events when held down including both PGUPs. I don't use a Desktop Environment so this must be the default behaviour for the XServer.

Last edited by GazL; 02-19-2013 at 09:19 AM.
 
1 members found this post helpful.
Old 02-19-2013, 10:04 AM   #3
jodymaick
LQ Newbie
 
Registered: Feb 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by GazL View Post
You can individually turn off repeat on keys using the xset -r <keycode> command, or use xset r off to turn them all off (probably not a good idea). At a guess I'd expect the defaults for which keys should repeat are somewhere within the XKB definitions, but I don't have enough of an understanding of that to comment.

P.S. Virtually all my keys generate repeated keypress/keyrelease events when held down including both PGUPs. I don't use a Desktop Environment so this must be the default behaviour for the XServer.
Hi, GazL. Thanks for replying.

I have just try the xset command, but it just solved the problem partially.
Now, the document goes up just a single page (as it should do), but it works once only.

Analysing the keyboard events with the new configuration, this is what happens:
  • when the Page Down key is pressed, the xev shows the keypress and keyrelease events.
  • but when the Page Up key is pressed, just the keypress event is shown and only the first time it is pressed.
 
Old 02-19-2013, 11:03 AM   #4
GazL
Senior Member
 
Registered: May 2008
Posts: 3,503

Rep: Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026
Quote:
Originally Posted by jodymaick View Post
Hi, GazL. Thanks for replying.
but when the Page Up key is pressed, just the keypress event is shown and only the first time it is pressed.
Hmm, even with autorepeat set off you should still be seeing a keyrelease event. Most odd.
Have you tried the other environments XFCE/Fluxbox etc? Do you see the same problem with those?
 
Old 02-20-2013, 01:49 PM   #5
jodymaick
LQ Newbie
 
Registered: Feb 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hi, GazL. Thanks again.

No, I've not tested yet other environments. I thought this would not solve the problem.
I'll do tests and tell you the results soon.
 
  


Reply

Tags
keyboard xmodmap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Quatation mark / comma key in the keyboard is not working properly...!" raheesc Linux - Desktop 3 05-12-2011 12:48 PM
[SOLVED] "Insert" & "Delete" key returns "~" in a terminal. sharky Linux - General 15 04-26-2011 09:36 AM
"Enter Key" not working, how to map "Enter Key" functionality to "F9" Key srinihi Linux - Newbie 1 04-03-2009 03:46 PM
firefox / kde: "open with"-menu does not work properly pit1516 Linux - Software 2 07-21-2005 05:01 PM
The program Screen, "delete" key doesn't work TroelsSmit Linux - Newbie 0 10-13-2004 08:55 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration