LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   The "Page Up" key does not work properly (http://www.linuxquestions.org/questions/slackware-14/the-page-up-key-does-not-work-properly-4175450784/)

jodymaick 02-19-2013 08:21 AM

The "Page Up" key does not work properly
 
Hi.

I've installed the Slackware 14 with KDE a few months ago but, since the first day the "Page Up" key does not work properly. Whatever the application (Crome, Firefox, Kwrite, Writer, Kile, Okular, ...), when this key is pressed, instead of a single page up, the whole document or web page goes to the start and the key stop working. What is intersting is that the "Page Up" of numeric keypad works fine.

With hopes of being a keymap problem, I tried the "xmodmap" to remap Page Up to the keypad Page Up, but it does not solve the problem.

I use the "xev" to watch the keyboard events. Unlike other keys, when the "Page Up" is pressed once, the keycode is shown repeatedly, as if the key still pressed.

I don't beleave this is a hardware problem, because I used Windows when I bought my notebook and the key also works fine. My first linux experience was with a Opensuse dual boot and that was the moment when the problem started: it works on Windows, but don't on Suse. I was hoping to solve this by changing distro, but the problem persists.

Anyone have any idea?

GazL 02-19-2013 09:14 AM

You can individually turn off repeat on keys using the xset -r <keycode> command, or use xset r off to turn them all off (probably not a good idea). At a guess I'd expect the defaults for which keys should repeat are somewhere within the XKB definitions, but I don't have enough of an understanding of that to comment.

P.S. Virtually all my keys generate repeated keypress/keyrelease events when held down including both PGUPs. I don't use a Desktop Environment so this must be the default behaviour for the XServer.

jodymaick 02-19-2013 10:04 AM

Quote:

Originally Posted by GazL (Post 4895110)
You can individually turn off repeat on keys using the xset -r <keycode> command, or use xset r off to turn them all off (probably not a good idea). At a guess I'd expect the defaults for which keys should repeat are somewhere within the XKB definitions, but I don't have enough of an understanding of that to comment.

P.S. Virtually all my keys generate repeated keypress/keyrelease events when held down including both PGUPs. I don't use a Desktop Environment so this must be the default behaviour for the XServer.

Hi, GazL. Thanks for replying.

I have just try the xset command, but it just solved the problem partially.
Now, the document goes up just a single page (as it should do), but it works once only.

Analysing the keyboard events with the new configuration, this is what happens:
  • when the Page Down key is pressed, the xev shows the keypress and keyrelease events.
  • but when the Page Up key is pressed, just the keypress event is shown and only the first time it is pressed.

GazL 02-19-2013 11:03 AM

Quote:

Originally Posted by jodymaick (Post 4895150)
Hi, GazL. Thanks for replying.
but when the Page Up key is pressed, just the keypress event is shown and only the first time it is pressed.

Hmm, even with autorepeat set off you should still be seeing a keyrelease event. Most odd.
Have you tried the other environments XFCE/Fluxbox etc? Do you see the same problem with those?

jodymaick 02-20-2013 01:49 PM

Hi, GazL. Thanks again.

No, I've not tested yet other environments. I thought this would not solve the problem.
I'll do tests and tell you the results soon.


All times are GMT -5. The time now is 05:55 PM.