LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Terminal and Komsole auto complete(TAB) error on Slackware 14.0 (http://www.linuxquestions.org/questions/slackware-14/terminal-and-komsole-auto-complete-tab-error-on-slackware-14-0-a-4175429849/)

raphaeldavidf 10-01-2012 05:28 AM

Terminal and Komsole auto complete(TAB) error on Slackware 14.0
 
1 Attachment(s)
Hey guys,

The problem is when my shell string is big and the command is big as well, when I hit TAB to auto complete the name of the file, the shell continues above itself. I don't know how to explain further and because of that I attached a printscreen when this happen(the green area is the shell command going above the shell). I never had this problem before, only now on slack 14.0.

Thanks!

bormant 10-01-2012 05:58 AM

If you
1) start terminal emulator,
2) start something another in it, for ex. mc,
3) increase terminal window and
4) exit another program,
5) then bash in terminal emulator from step (1) doesn't know about new window width.

You can change size of window, i.e. maximize and restore it, then try again. Does it help?

raphaeldavidf 10-01-2012 08:55 AM

Quote:

Originally Posted by bormant (Post 4793863)
If you
1) start terminal emulator,
2) start something another in it, for ex. mc,
3) increase terminal window and
4) exit another program,
5) then bash in terminal emulator from step (1) doesn't know about new window width.

You can change size of window, i.e. maximize and restore it, then try again. Does it help?

I didn't understand the 4 and 5 steps. You said to open a terminal run something (like mc) and with mc running change the dimensions of the screen, but in "exit another program" which program are you talking about? the exemple program(mc) ?

raphaeldavidf 10-01-2012 08:38 PM

someone? this is quite annoying...=(

bnguyen 10-01-2012 09:08 PM

First you should disable your personal PS1 variable and use the default to see if the problem persists. I used to encounter some weird issues in the past with customized PS1.

raphaeldavidf 10-01-2012 10:43 PM

Quote:

Originally Posted by bnguyen (Post 4794487)
First you should disable your personal PS1 variable and use the default to see if the problem persists. I used to encounter some weird issues in the past with customized PS1.

Thanks a lot, was exactly that:hattip:. My PS1 had an error(one "\" was missind) in the definition of a color.


All times are GMT -5. The time now is 06:56 PM.