LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-04-2005, 03:33 AM   #1
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
"Tempoarily out of resourse, please try again later." Error Message in Web Browser


Hi!

I have a Slackware machine which I configured so that NAT works on it.

It is Slackware-current with 2.6.12.3 compiled using gcc4.0 which is compiled on the machine itself.

Now, I have been getting the following message on my browsers regardless of operating system (Linux, Mac Os X, or Windows): (Note the spelling mistakes are not my work, am quoting verbatim.)
Code:
Tempoarily out of resourse, please try again later.

Intermittently I get the message while browsing the Internet, a simple click of reload will bring me to the web page I intended to go.

I notice this started happening lately after a tcpip, iptables, etc upgrades. But it has reduced (one time today) after peaking a few days ago.

What could be the problem?
 
Old 08-04-2005, 04:38 AM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
are you using the adblock extension?? if so, try disabling it to see if it's the culprit...
 
Old 08-05-2005, 02:26 AM   #3
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
But, I am getting that error even in Safari and Camino.

Yesterday, I tried browsing using Firefox on Slackware, I get that error message twice in very short period. And, with Slackware machine not running any progs, I have not been getting it.

Oh, another note, I did use bittorrent, could it be that the new iptables or tcpip is limitting the number of connections?

Note, I did not touch iptables rules.


Edit:
And, my camino, firefox, etc. Are set to use high maximum connections.
 
Old 08-05-2005, 02:34 AM   #4
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally posted by carboncopy
But, I am getting that error even in Safari and Camino.

Yesterday, I tried browsing using Firefox on Slackware, I get that error message twice in very short period. And, with Slackware machine not running any progs, I have not been getting it.

Oh, another note, I did use bittorrent, could it be that the new iptables or tcpip is limitting the number of connections?

Note, I did not touch iptables rules.


Edit:
And, my camino, firefox, etc. Are set to use high maximum connections.
hmmm... what's your current ephemeral port range??
Code:
cat /proc/sys/net/ipv4/ip_local_port_range
 
Old 08-05-2005, 02:34 AM   #5
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 32
Believe it or not, I think that is a server error 503, and the server has too many connections on it. When you hit refresh there is a connection available and it lets you in.

I'd bet it's coincidental to your upgrades.
 
Old 08-05-2005, 03:13 AM   #6
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Code:
root@carboncopy:~# cat /proc/sys/net/ipv4/ip_local_port_range
32768   61000
What does those figure means?
 
Old 08-05-2005, 03:18 AM   #7
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by n0xvb
Believe it or not, I think that is a server error 503, and the server has too many connections on it. When you hit refresh there is a connection available and it lets you in.

I'd bet it's coincidental to your upgrades.
The thing is, it is purely random. And it happens even with almost omni-potent sites, such as IBM, BBC etc.

And if it is error 503, the browser will catch it its own error message.

It is still happening today. Even without bittorrent running, single client connected to Slackware (NAT machine).

Strange.
 
Old 08-05-2005, 03:27 AM   #8
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally posted by carboncopy
Code:
root@carboncopy:~# cat /proc/sys/net/ipv4/ip_local_port_range
32768   61000
What does those figure means?
look here: http://www.ncftp.com/ncftpd/doc/misc...ral_ports.html

basically, it's the range of (source) ports your box will use when making connections to remote boxes... try increasing the range a little to see if it helps, although you have a pretty wide range set already:
Code:
echo "32768 64000" > /proc/sys/net/ipv4/ip_local_port_range
what's your tcp fin timeout set to?? you can check with:
Code:
cat /proc/sys/net/ipv4/tcp_fin_timeout
if it's set to something like 180 bring it down to 30:
Code:
echo "30" > /proc/sys/net/ipv4/tcp_fin_timeout
then see if the problem continues...

on a side note, i had a similar problem for the past couple weeks, i was suspecting it was my squid proxy server but it ended up being my ISP's DNS servers that were messed-up... if you wanna look at the thread it's this one:

http://www.linuxquestions.org/questi...hreadid=346094

of course i'm not saying the issues are related or anything like that...


Last edited by win32sux; 08-05-2005 at 03:30 AM.
 
Old 08-05-2005, 03:35 AM   #9
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Ah, cool. Thanks a great deal win32sux!

Code:
root@carboncopy:~# cat /proc/sys/net/ipv4/tcp_fin_timeout
60
I brought it down to 30 as suggested.

Will this setting stays this way? Or do I have to include it into rc.local? Or is there some config file somewhere?

Edited:
Oh, it still happens Just happens as I click edit this post.

Anyhow, I changed the port range as well.

So, guess those are not the prob.

Last edited by carboncopy; 08-05-2005 at 03:38 AM.
 
Old 08-05-2005, 03:41 AM   #10
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
I will download iptables and tcpip source and search for

"Tempoarily out of resourse, please try again later."

And maybe a search through the kernel?

First, I need to find the bash command to do that. Any fast help?
 
Old 08-05-2005, 03:45 AM   #11
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,535

Rep: Reputation: 117Reputation: 117
Go into your source dir then try :
Code:
grep -rlni 'Tempoarily out of resourse, please try again later.' .
Or maybe just grep for "Tempoarily", that should be efficient

Last edited by keefaz; 08-05-2005 at 03:48 AM.
 
Old 08-05-2005, 04:04 AM   #12
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
check this out: http://forum.mydefcon.org/viewtopic.php?t=463

what on earth is Streamyx??
 
Old 08-05-2005, 04:05 AM   #13
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Thanks keefaz!

With first class help and pointers from LQ-Slackware. One can really be lazy Or spoilted.
 
Old 08-05-2005, 04:06 AM   #14
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally posted by carboncopy
Will this setting stays this way? Or do I have to include it into rc.local? Or is there some config file somewhere?
yeah, it'll be gone upon reboot, so you need to put the echoes in rc.local or similar... BTW, if you're on slackware it's common to instead use the rc.firewall script for this...
 
Old 08-05-2005, 04:09 AM   #15
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by win32sux
check this out: http://forum.mydefcon.org/viewtopic.php?t=463

what on earth is Streamyx??
Streamyx is what MY (idiotic) ISP called it's ADSL service.

http://www.tm.net.my/html/pstreamyx.cfm

Great. Thanks for the info. Now I can call and bug them.

Case is close for Slackware being the suspect.

Thanks everybody!

At least I learn something more about networking parameters in Linux.

Last edited by carboncopy; 08-05-2005 at 04:20 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 12:49 PM
Any web browser with "multi-select"? IsaacKuo Linux - Software 6 01-06-2005 05:56 AM
konqueror 'web browser" load error joeyindy Suse/Novell 7 12-14-2004 02:26 PM
error message when pressing "Next" "BIOS Problems" , help ! HeRCuLeSX Fedora 3 07-21-2004 02:37 PM
Uploading web pages; get "access forbidden" when I load them in browser! Thermodynamic Linux - Software 1 04-03-2004 05:52 PM


All times are GMT -5. The time now is 02:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration