LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-16-2003, 02:44 PM   #1
csDraco_
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora / CentOS
Posts: 93

Rep: Reputation: 15
Question telnet and special chars


Hi there!

Perhaps someone came over this ... when using telnet, and typing the backspace key, instead of erasing a char, it actually prints the special character (if I remember corectlly) it's the "^M" char ... and this leads to a mess, and really quick too

Is there a parameter for telenet that would fix this, or is it the server's problem? I read through the "man telnet" but could not find anything hinting at such behaviour of telent. BTW when I use putty.exe instead of Slack9's telnet, the backspace is processed correctly by that server.
 
Old 05-16-2003, 02:47 PM   #2
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
This usually has something to do with the terminal type of the server.

Try using Ctrl+Backspace.
 
Old 05-16-2003, 04:08 PM   #3
csDraco_
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora / CentOS
Posts: 93

Original Poster
Rep: Reputation: 15
Thanks ... but that didn't seem to work.
 
Old 05-16-2003, 04:53 PM   #4
csDraco_
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora / CentOS
Posts: 93

Original Poster
Rep: Reputation: 15
I was also told to try runing telnet from a different shell ... but that made no difference too.
 
Old 05-17-2003, 07:41 AM   #5
csDraco_
Member
 
Registered: Feb 2002
Location: Canada
Distribution: Fedora / CentOS
Posts: 93

Original Poster
Rep: Reputation: 15
Perhaps if I was to enable the line mode in telnet?
But I'm not sure how ... ie:
"telnet>mode line" => "?Need to be connected first."
but when I connect, the mode command is no longer recognised by telnet, but by the server instead
 
Old 05-21-2003, 10:12 AM   #6
luciji
LQ Newbie
 
Registered: May 2003
Posts: 5

Rep: Reputation: 0
Sounds like the telnet client you are using isn't sending what your Linux telnet server expects.

Try setting your client for a different type of terminal, as previously suggested. VT100 usually works well. You will probably want to closely match what your Linux server is set for. You should be able to see what TERM your server is expecting by typing "env". If the TERM variable is set, it tells you what keymap has been loaded on the linux side. Then it is a matter of setting your client software to the same thing (or a variant thereof).

If you still have problems, there are ways to map your keys. It isn't simple, but by reading the man pages you should be able to figure it out.

You may want to consider a different term program, like Tera Term. It's free, and highly configurable. It supports SSH. Also, it has a special config just for the backspace key.

Good luck!
 
Old 05-21-2003, 10:36 AM   #7
phishman3579
Member
 
Registered: May 2003
Posts: 161

Rep: Reputation: 32
If I were to guess I would try adding this line to your .tcshrc/.bashrc or whatever shell you are using.

stty erase ^h
 
Old 05-21-2003, 10:57 AM   #8
phishman3579
Member
 
Registered: May 2003
Posts: 161

Rep: Reputation: 32
Quote:
Originally posted by phishman3579
If I were to guess I would try adding this line to your .tcshrc/.bashrc or whatever shell you are using.

stty erase ^h
Backspace might not be ^h on your terminal... just type:

stty erase (then hit CTRL-V and then the backspace button) ENTER.

That should set the correct special char into the terminal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
block special and character special files s_shenbaga Linux - Newbie 1 04-20-2005 04:49 PM
Problem with special chars in general smokylux Linux - General 6 05-26-2004 05:46 AM
chars } and $ won't work.. among others.. apax Linux - Newbie 8 11-26-2003 10:20 AM
German umlaute (special chars) in file system steltner Linux - General 5 10-27-2003 03:07 PM
Ximian crashes when I enter "special chars" into message borbjo Linux - Software 0 01-28-2003 08:31 AM


All times are GMT -5. The time now is 01:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration