LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   telnet and special chars (http://www.linuxquestions.org/questions/slackware-14/telnet-and-special-chars-60156/)

csDraco_ 05-16-2003 02:44 PM

telnet and special chars
 
Hi there!

Perhaps someone came over this ... when using telnet, and typing the backspace key, instead of erasing a char, it actually prints the special character (if I remember corectlly) it's the "^M" char ... and this leads to a mess, and really quick too :)

Is there a parameter for telenet that would fix this, or is it the server's problem? I read through the "man telnet" but could not find anything hinting at such behaviour of telent. BTW when I use putty.exe instead of Slack9's telnet, the backspace is processed correctly by that server.

bentz 05-16-2003 02:47 PM

This usually has something to do with the terminal type of the server.

Try using Ctrl+Backspace.

csDraco_ 05-16-2003 04:08 PM

Thanks ... but that didn't seem to work.

csDraco_ 05-16-2003 04:53 PM

I was also told to try runing telnet from a different shell ... but that made no difference too.

csDraco_ 05-17-2003 07:41 AM

Perhaps if I was to enable the line mode in telnet?
But I'm not sure how ... ie:
"telnet>mode line" => "?Need to be connected first."
but when I connect, the mode command is no longer recognised by telnet, but by the server instead :(

luciji 05-21-2003 10:12 AM

Sounds like the telnet client you are using isn't sending what your Linux telnet server expects.

Try setting your client for a different type of terminal, as previously suggested. VT100 usually works well. You will probably want to closely match what your Linux server is set for. You should be able to see what TERM your server is expecting by typing "env". If the TERM variable is set, it tells you what keymap has been loaded on the linux side. Then it is a matter of setting your client software to the same thing (or a variant thereof).

If you still have problems, there are ways to map your keys. It isn't simple, but by reading the man pages you should be able to figure it out.

You may want to consider a different term program, like Tera Term. It's free, and highly configurable. It supports SSH. Also, it has a special config just for the backspace key.

Good luck!:)

phishman3579 05-21-2003 10:36 AM

If I were to guess I would try adding this line to your .tcshrc/.bashrc or whatever shell you are using.

stty erase ^h

phishman3579 05-21-2003 10:57 AM

Quote:

Originally posted by phishman3579
If I were to guess I would try adding this line to your .tcshrc/.bashrc or whatever shell you are using.

stty erase ^h

Backspace might not be ^h on your terminal... just type:

stty erase (then hit CTRL-V and then the backspace button) ENTER.

That should set the correct special char into the terminal.


All times are GMT -5. The time now is 06:05 AM.