LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   tar.gz vs tgz (http://www.linuxquestions.org/questions/slackware-14/tar-gz-vs-tgz-4175467025/)

waddles 06-22-2013 04:00 PM

tar.gz vs tgz
 
I was preparing to install my linux printer drivers for this XP200 but noticed they are all .tar.gz.
pkgtool did not stipulate in the man page if it accepted .tar.gz and the installpkg specifically does not include .tar.gz but allows for .tgz.
What recourse do I have now that I have downloaded the drivers?
Are .tar.gz equivalent to .tgz??

minty33 06-22-2013 04:13 PM

on the slackware site there is a part about installing packages and in one part it explains how to convert rpm redhat pkg to slackware compatable package and it say's tar.gz and .tgz are the exact same file just different extensions so you should be fine.
this is from that page:
"NOTE: Running rpm2targz will create a .tar.gz file, while running rpm2tgz will create a .tgz file. The files are exactly the same, the only difference is the extension format (some people prefer one over the other)."
here is the link:
http://slackware.com/config/packages.php

***BTW are you sure it is not to be installed by un-tarring with "tar zxf file.tar.gz" then from the directory run "./configure" then either "make" and or "make install". there should be a readme text file in the tarball explaining the installation of the driver

ljb643 06-22-2013 04:37 PM

Do not try to use Slackware package tools (pkgtool, installpkg) to install non-Slackware packages. The Epson drivers are not distributed as Slackware packages. You unpack them into a temporary empty directory, then follow the instructions inside - usually in a README file.

minty33 06-22-2013 04:51 PM

yea that is exactly what i thought. i said the same thing at the end of my post how to unpack and install the drive as well as to look for the readme

waddles 06-22-2013 05:22 PM

Thanks guys, that saved me a bunch of useless effort; will follow UR advise.

ljb643 06-22-2013 08:45 PM

If you decide to try the ESC/P-R driver first, it turns out to be the exact same driver for all supported Epson printers, including mine. So here are the steps I used to install this on Slackware 14. Download the source (src.tar.gz) package into somewhere like /tmp. Working in an empty directory:
Code:

$ tar -xvzf /tmp/epson-inkjet-printer-escpr-1.2.3-1lsb3.2.tar.gz
$ cd epson-inkjet-printer-escpr-1.2.3
$  ./configure --prefix=/opt/epson
$  make
$  su
#  make install
#  cd /usr/lib/cups/filter
#  ln -s /opt/epson/lib/cups/filter/epson-* .

That last step - linking to the filters - is only needed (I think) if you install to a different place (--prefix), but I like to keep things like this in their own directories rather than scattered throughout /usr/local.

Now point your browser to CUPS at localhost:631 and use Administration, Add Printer. When you get to the printer make/model, use the browse button after "Provide a PPD File", and go to /opt/epson/share/cups/model/epson-inkjet-printer-escpr where you can pick your model (PPD) file.

That's it. You do not need to make that ld-lsb.so.3 link (from the other thread) when you build the ESC/P-R driver from source as above.

(To repeat from the other thread, though: this driver works for me for some things, but I use the other one - ESC/P driver, which is specific to each printer, because I had problems with photo scaling using the ESC/P-R driver.)

waddles 06-23-2013 04:19 PM

Thanks again, ljb643. But could U stipulate further as to what other "some things" besides photo scaling did not work for U with ESC/P-R?

ljb643 06-23-2013 08:53 PM

I don't want to discourage you from trying the ESC/P-R driver first. I think I tried it once from Gimp, it didn't work (picture was scaled about 4x too large), so I went back to the driver I was using before. But I didn't test it or try to see if maybe it was my mistake. Some day I'll probably take a closer look, since it seems to be newer.

I want to add that the downside of these Epson printer drivers is that there is no support available at all, anywhere, as far as I can tell. No contact info, no discussion forum, no bug tracker. It either works, or we are out of luck. (Well, one could try to debug it, but good luck with that - about 30K lines of code there.)

waddles 06-25-2013 05:53 PM

Just checking but I presume U are running "make install" from the directory "epson-inkjet-printer-escpr-1.2.3" where U cd'd to 4 steps earlier. Is that correct?
BTW I believe there are epson chat rooms on freenode, undernet, PTnet, and irc. Haven't tried to use them (yet).
Aware that most major hardware vendors do not want to touch Linux especially now with LSB vs nonLSB and BSD vs SVR4, etc ad naseum. Sides they paid good money to be approved by M$.

ljb643 06-25-2013 07:42 PM

Yes, run 'make install' from the same directory as 'make', but as the root user.

HP seems to do much better in the Linux support area - developing, supporting, and releasing drivers for many products. I had an HP PhotoSmart printer before, and when it died I wanted to replace it with another HP. But I found that HP had stopped making dedicated photo printers, and now sold just 4-ink all-in-ones. Not what I wanted, so I went with Epson. But you are correct, many hardware vendors are still Linux unfriendly.

waddles 06-26-2013 01:12 AM

OK, thanks I thought so but wanted to cross t's and dot i's.
BTW re HP. DON"T BE FOOLED. My experience with their support was they downright lied to me. Telling me to put all cables/ink/documents back in the box with the HP deskjet 1000 printer. I checked that with 3 different support people. When I got back the printer the only cable I got was the power cable. AND the problem reoccurred. Their promise to send the USB cable never happened.
I was using the correct HPLIP driver and the best I could get was the first page of a multipage document and successive pages would overprint to near total blackness.
I ended up writing a script to format my multipage docs to n-number of 1 page docs.
I finally tried HP's ijs or something driver and that worked but after a while there were backend errors and it failed.
Corrected that by removing and re-creating the printers in CUPS. That worked for a while until these last errors didn't respond to that correction so I gave up.
Now I buy the store guarantee where U bring it in and get another.

waddles 06-27-2013 01:57 AM

When I built the printer driver(s) I put 'em in /opt/EPSON/PRNTDRVR
via the ./configure --prefix=/opt/EPSON/PRNTDRVR.
but when I did:
cd /usr/lib/cups/filter
ln -s /opt/EPSON/PRNTDRVR/lib/cups/filter/epson-* .
I got the following:
ln: replace `./epson-escpr'? Y
ln: replace `./epson-escpr-wrapper'? Y
Was it correct to respond yes?

ljb643 06-27-2013 07:41 PM

Quote:

Originally Posted by waddles (Post 4979419)
...
Was it correct to respond yes?

Yes - I assume you previously installed or tried to install the driver, and those links or files were left over from then. (If you hadn't already replaced them, you could have checked to see if they are links or files, and what their date-stamp was.)

I think that if you use ./configure without --prefix, the driver is built and installed in /usr/local/... except that those 2 CUPS filter programs get installed directly into the CUPS filter directory /usr/lib/cups/filter. If you use --prefix to install it somewhere, it puts the filters there, and CUPS cannot find them. Hence the links. Also, you apparently have an alias for 'ln' which includes -i (prompt to replace existing file or link).


All times are GMT -5. The time now is 07:25 AM.