LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-22-2006, 04:23 AM   #1
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 632

Rep: Reputation: 36
system reboots when i shutdown -h now. any ideas why?


hello everyone,
my first problem as a newbie in linux and thus my first thread.

the story is abit longer than stated in the title:
i installed recently slackware 10.2 with kernel version 2.4.31.
yesterday i decided to update the kernel in 2.6.16.9. seems like i did everything right and my system reboots nicely again etc. but i ended up not being able to shutdown the pc. so now when i shutdown -h now, i get the full (proper) halting process, but the pc never switches off, it really reboots!

searching through the forums here i tried the following:
1) if i type in bash 'apm' i get the response: no APM support in kernel - looks pretty obvious to me whats going on here.. however i felt i went thoroughly through the menuconfig steps, reading the help in almost all options available to me prior to choosing whether to install, or not, or make them modular.
2) it was suggested in the forums to do mobprobe apm but when i do that i get the response
FATAL : module apm not found
3) so i cd /etc/rc.d/rc.modules and i uncommented the apm support line '/sbin/modprobe apm'. i restarted but no luck.

so i need to know if it is i didn't enable some option in menuconfig. to make things a little easier i copy-pasted all of the power management section of .config here. hope this will help.
Thanks in advance everyone!
nass


# Power management options (ACPI, APM)
#
CONFIG_PM=y
CONFIG_PM_LEGACY=y
# CONFIG_PM_DEBUG is not set
# CONFIG_SOFTWARE_SUSPEND is not set

#
# ACPI (Advanced Configuration and Power Interface) Support
#
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
CONFIG_ACPI_SLEEP_PROC_SLEEP=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=y
# CONFIG_ACPI_HOTKEY is not set
CONFIG_ACPI_FAN=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
# CONFIG_ACPI_CONTAINER is not set

#
# APM (Advanced Power Management) BIOS Support
#
CONFIG_APM=y
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
CONFIG_APM_DO_ENABLE=y
# CONFIG_APM_CPU_IDLE is not set
# CONFIG_APM_DISPLAY_BLANK is not set
CONFIG_APM_RTC_IS_GMT=y
# CONFIG_APM_ALLOW_INTS is not set
# CONFIG_APM_REAL_MODE_POWER_OFF is not set
 
Old 04-22-2006, 05:18 AM   #2
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Run halt and check if it works.
 
Old 04-22-2006, 06:56 AM   #3
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 632

Original Poster
Rep: Reputation: 36
well it doesn't but i didnt expect it would..
i mean shutdown -h is really halt just in a more 'gentle' for the processes way... no?
 
Old 04-22-2006, 11:25 AM   #4
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 632

Original Poster
Rep: Reputation: 36
haha this is hilarious
if i press the power button on the pc tower then i get a proper shutdown that also halts and powers off the pc completely on its own.
still however by trying "shutdown -h now" or "halt" i get a reboot!!!
please help.

in fact i went through all the process of recompiling all the kernel adding all the acpi and apm features i left out b4! but again, no luck.
 
Old 04-22-2006, 12:17 PM   #5
the.madjack
Member
 
Registered: Apr 2006
Distribution: Slackware 10.2
Posts: 52

Rep: Reputation: 15
do u have other OS(windows xp or etc) in the same PC? If they managed to halt down completely, it could be your slackware probs. I had an experience where both my OSes were unable to shutdown completely. It turned out to be that nasty power supply :/.
 
Old 04-22-2006, 04:01 PM   #6
slackamp
Member
 
Registered: Dec 2005
Distribution: slackware-current
Posts: 86

Rep: Reputation: 16
it looks like you have both APM and ACPI configured for your kernel. i always just turn off APM completely. ACPI is preferred for newer hardware anyway. Try turning off APM and re-compile then see if that helps.
 
Old 04-23-2006, 02:41 AM   #7
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Check /bin/shutdown script:
Code:
#!/bin/sh
# Try to do the right thing for programs that rely on "/usr/bin/shutdown -r now"
# to shut down the machine.
prog=/sbin/shutdown
now=
for flag in $* ; do
	if test ${flag} = "-h" ; then
		prog=/usr/bin/halt
	elif test ${flag} = "-r" ; then
		prog=/usr/bin/reboot
	elif test ${flag} = "now" ; then
		now=$flag
	else
		args="$args $flag"
	fi
done
if [ -z "$args" -a $prog != /sbin/shutdown ] ; then
	exec $prog $args
else
	exec /sbin/shutdown $args $now
fi
 
Old 04-23-2006, 08:50 PM   #8
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 632

Original Poster
Rep: Reputation: 36
slackamp, the fact is this pc is a PII running at 350MHz.. so no new machine at all. its also a fact that when i type 'apm' in bash i get the response "no apm in kernel".. so it seems only acpi is installed in kernel... yet again i did make sure i recompiled checking that all apm options are selected to make sure i have then in kernel... should i recompile -deselecting acpi support? i mean u ask me to recompile without apm i understand that but isnt it so i dont have apm even now?

the thing is with kernel 2.4.31 and the default tweaks (ie the ones inside the installation cd) the pc shutdown properly... so its not a hardware problem
the prob arose now..

another thing i just tried is to do a brutal halt -f -p and again it didnt do the poweroff but instead rebooted the system...
if u have any little details u want to elaborate on please do so, im up for tryig anything now with this system.

Alien_Hominid, i dont seem to have the specific script ur refering me to, but i did take a thorough look at the /etc/rc.d/rc.0 shutdown script.. the problem is the script seems to run fine... smth in the 'halt' process is not done properly..

thanks for ur help
nass
 
Old 04-24-2006, 10:38 PM   #9
slackamp
Member
 
Registered: Dec 2005
Distribution: slackware-current
Posts: 86

Rep: Reputation: 16
yes do that, recompile kernel with only apm selected (remove acpi). i just recompiled mine to use apm actually. also make sure you have "/sbin/modprobe apm" uncommented in the /etc/rc.d/rc.modules file. and make sure your apmd entries in /etc/rc.d/rc.M are NOT commented. oh and since you are using the latest kernel, make sure your udev is also installed and working properly. i suggest downloading the source for the udev in slacware-current and run the udev.Slackbuild.

FILE: /etc/rc.d/rc.modules
#### APM support ###
# APM is a BIOS specification for saving power using several different
# techniques. This is mostly useful for battery powered laptops.
/sbin/modprobe apm


FILE: /etc/rc.d/rc.M
# Start APM or ACPI daemon.
# If APM is enabled in the kernel, start apmd:
if [ -e /proc/apm ]; then
if [ -x /usr/sbin/apmd ]; then
echo "Starting APM daemon: /usr/sbin/apmd"
/usr/sbin/apmd
fi
elif [ -x /etc/rc.d/rc.acpid ]; then # otherwise, start acpid:
. /etc/rc.d/rc.acpid start
fi
 
Old 04-26-2006, 11:33 AM   #10
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 632

Original Poster
Rep: Reputation: 36
well i recompiled without acpi support and it seems to work properly again.. but at boot up i get the following msg
FATAL: module apm not found.

and i ask you, why not?
the problem im asking is of course to get to understand this better, but also because i also get
FATAL: module agpgart not found
FATAL: module emu10k1 not found

and also later on

FATAL: module snd_pcm_oss not found
FATAL: module snd_mixer_oss not found

so im hoping that by understand the 1st ill get to solve these other probs as well..

Thanks alot for the help!
 
Old 04-27-2006, 06:36 AM   #11
koloth
Member
 
Registered: Jun 2004
Location: Athens, Greece
Distribution: Slackware 13.1
Posts: 98

Rep: Reputation: 17
Have you compiled APM as module? it seems to me from your config that it is compiled built in. In that case you don't need to load the apm modules, they are already in the kernel
 
Old 04-27-2006, 09:14 AM   #12
slackamp
Member
 
Registered: Dec 2005
Distribution: slackware-current
Posts: 86

Rep: Reputation: 16
yep like koloth says, make sure you compile them as modules (M) not in the kernel (*). if you do, then don't try to modprobe them because you don't need to.

Here is my APM config

# Power management options (ACPI, APM)
# APM (Advanced Power Management) BIOS Support
CONFIG_APM=m
CONFIG_APM_IGNORE_USER_SUSPEND=y
CONFIG_APM_DO_ENABLE=y
CONFIG_APM_CPU_IDLE=y
CONFIG_APM_DISPLAY_BLANK=y
CONFIG_APM_RTC_IS_GMT=y
CONFIG_APM_ALLOW_INTS=y
CONFIG_APM_REAL_MODE_POWER_OFF=y


You have CONFIG_APM=y.

I suggest compiling most things as a module, it will make your kernel smaller, less memory consumption. the only thing you really need to compile in the kernel is if you need them at boot time or use initrd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any Ideas? PC reboots and gives syscall errors & overheats kazuya1977 Linux - Hardware 1 04-03-2006 10:02 AM
System reboots after shutdown after some time cccc828 Slackware 4 05-15-2005 05:16 AM
Shutdown reboots my laptop!! SpiderIRE Fedora - Installation 5 02-08-2005 01:26 PM
System reboots on giving shutdown prabhatsoni Linux - Laptop and Netbook 5 12-31-2004 06:33 AM
System reboots when shutdown is selected Freakazoid Linux - General 1 01-04-2003 04:05 AM


All times are GMT -5. The time now is 08:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration