LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-30-2009, 03:39 AM   #1
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
System lock when closing laptop lid on 12.2


I recently installed 12.2 on my Lenovo n500 laptop, replacing 12.1.

There's one thing that's been causing me headaches though. Whenever I close the lid, the system freezes and I have to do a hard reboot.

I'd be happy if closing the lid did nothing. With 12.1 I changed nothing except the klaptop "button actions" to "off", but this has no effect in 12.2.

My /etc/acpi are the defaults (ie doing nothing) and I haven't changed any BIOS settings between the two installs.

Any suggestions as to what might be the problem?

Thanks...
 
Old 03-30-2009, 04:26 AM   #2
Feinom
Member
 
Registered: Mar 2004
Location: Norway
Distribution: Slackware 12.2
Posts: 40

Rep: Reputation: 17
Have you checked that "acpi_handler.sh" doesn't contain any 'LID' entry? I know it isn't there by default, but maybe it got added by something else.
 
Old 03-30-2009, 04:52 AM   #3
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 4,018

Rep: Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962
You could just blacklist the button module.

Probably you will loose software-controlled power-off too then (it's the same driver).

Anyway first try "rmmod button", close the lid and see what happens.
 
Old 03-30-2009, 08:45 AM   #4
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
@feinom
I checked everything in /etc/acpi and there's nothing there.

@didier
I guess that would be temporary solution but I'd rather be able to control what happens with the lid and to retain software controlled power-off.

Thanks for the answers.
 
Old 03-30-2009, 08:51 AM   #5
Feinom
Member
 
Registered: Mar 2004
Location: Norway
Distribution: Slackware 12.2
Posts: 40

Rep: Reputation: 17
Is the /etc/acpi directory emtpy? My default installation has the acpi_handler script and a directory called "events" which contains a file named "default".
 
Old 03-30-2009, 10:53 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 4,018

Rep: Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962
I agree with Feinom, you should have that an "events" directory and a "acpi_handler" file in /etc/acpi.

If no, get acpid-1.0.8-i486-2 package and (re)install it. as root:
Code:
upgradepkg --install-new --reinstall acpid

Last edited by Didier Spaier; 03-30-2009 at 12:08 PM.
 
Old 03-30-2009, 11:45 AM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
I have my laptop setup for suspend to ram when the lid is closed.

In /etc/ecpi/acpi_handler.sh I have a line
Quote:
case "$2" in
power) /sbin/init 0
;;
lid) /usr/sbin/pm-suspend
Using 'visudo' I have a line under User privilege specification
<username> ALL = NOPASSWD: /usr/sbin/pm-suspend

Also, the user has been made a member of the 'power' group.

In KDE, I have the power management set so that closing the lid does nothing.

Thanks to rworkman, Slackware now has pm-utils!

Last edited by allend; 03-30-2009 at 11:53 AM.
 
Old 03-30-2009, 02:17 PM   #8
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
Sorry, I meant to say there is nothing there except the default files (acpi_handler.sh and events/default).

Through trial and error I found that choosing "Off" as the action for "Lid Switch Closed" in Klaptop is causing the crash. If I choose something like "logout" then I do not get a lock up. Is this possibly a klaptop problem?

Last edited by brixtoncalling; 03-30-2009 at 04:03 PM.
 
Old 03-31-2009, 02:21 AM   #9
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
To update a bit, I can't seem to predictably prevent this locking up no matter how much I play with klaptop. Sometimes I can get it to log out on close but usually it is a crash. The same thing happens when I am logged in at the terminal (no X running).

Besides the files in /etc/acpi what should I be looking at? I can find nothing in /var/log/syslog except that acpi_helper.sh is correctly catching the lid close (I added a little logger message to test it).
 
Old 03-31-2009, 04:05 AM   #10
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 4,018

Rep: Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962
I would avoid using KDE settings for ACPI. Personally I don't use it at all.

Go to Control Center/Power Control/Laptop Battery and disable everything in the ACPI tab.

Other than that I tried "rmmod button". In fact I still can shutdown through software (e.g. "shutdown -r now" or "halt"); the only difference is that when I hit the ON/OFF button nothing happens (usually it triggers the "halt" command).
 
Old 03-31-2009, 06:51 AM   #11
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
Well I did not find the source of the problem per se, but an upgrade to kernel 2.6.29 has solved it. Things worked fine with the 12.1 default kernel but not with the one that shipped with 12.2.

At least I've learned to love pm-utils -- allend's setup works better than klaptop.

Thanks all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless after closing the lid watcher69b Fedora 2 01-14-2009 10:24 PM
How to suspend on lid closing? jerrybasham Linux - Laptop and Netbook 4 06-29-2007 12:03 PM
how to not go into power magement when closing lid? shinsplints Linux - Laptop and Netbook 5 08-19-2004 12:52 PM
closing lid freezes red hat 9 newborn1281 Linux - Laptop and Netbook 5 07-01-2004 06:39 PM
closing laptop lid causes display to go crazy disciple061 Linux - Laptop and Netbook 0 03-20-2004 12:48 AM


All times are GMT -5. The time now is 11:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration