LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-09-2013, 04:28 PM   #1
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 103

Rep: Reputation: 2
System Halted


I am not a Linux expert but I managed to install Slackware 14.1 (32-bit) on a 1999 desktop which has a Pentium III 1.1 GHz.

Things seem to go well, except for this little annoyance: When I power the system off it gets to the point where it says "System halted" and never actually powers off automatically. I think it has something to do with my system BIOS still supporting APM whereas Slackware 14.1 does not support that.

Anyhow, I am stuck. Somebody suggested that I need to build a custom kernel to get this APM module back but I do not have the faintest idea of how this is done, or even if that would solve my problem.

Anyone willing to help me solve this?
 
Old 11-09-2013, 05:07 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,558
Blog Entries: 54

Rep: Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927
Quote:
Originally Posted by tb75252 View Post
I think it has something to do with my system BIOS still supporting APM whereas Slackware 14.1 does not support that.
To be pedantic about it this isn't about a distro "supporting" it or not but about the kernel and what options its compiled with.


Quote:
Originally Posted by tb75252 View Post
Somebody suggested that I need to build a custom kernel to get this APM module back but I do not have the faintest idea of how this is done, or even if that would solve my problem.
http://wiki.linuxquestions.org/wiki/Slackware-Links > http://blog.tpa.me.uk/slackware-kernel-compile-guide/
 
Old 11-09-2013, 05:21 PM   #3
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,657
Blog Entries: 15

Rep: Reputation: 1126Reputation: 1126Reputation: 1126Reputation: 1126Reputation: 1126Reputation: 1126Reputation: 1126Reputation: 1126Reputation: 1126
Check your BIOS power options to see if it allows for ACPI/APM shutdown mode usually branded as "Allow Software Power Off".
 
Old 11-09-2013, 06:04 PM   #4
ljb643
Member
 
Registered: Nov 2003
Posts: 282

Rep: Reputation: Disabled
I don't know if this still works or applies, but back a few years ago we needed to put a line in /etc/lilo.conf in order to get the system to power off if the BIOS was older than 2001 (which yours obviously is). The line was:
Code:
append = "apci=force"
Does anyone know if this still applies? (I've got some old stuff, but nothing that old.)
 
Old 11-09-2013, 07:17 PM   #5
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 103

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by ReaperX7 View Post
Check your BIOS power options to see if it allows for ACPI/APM shutdown mode usually branded as "Allow Software Power Off".
The BIOS has an entry called "PM Control by APM" and it is set to YES. Unfortunately it does not help turning the desktop off when I leave Slackware. I cannot find any entry that allows software to power off.
 
Old 11-09-2013, 07:23 PM   #6
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 103

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by ljb643 View Post
I don't know if this still works or applies, but back a few years ago we needed to put a line in /etc/lilo.conf in order to get the system to power off if the BIOS was older than 2001 (which yours obviously is). The line was:
Code:
append = "apci=force"
Does anyone know if this still applies? (I've got some old stuff, but nothing that old.)
I added that line to /etc/lilo.conf but unfortunately no change.

I am guessing that I really need to recompile the kernel by adding the APM module but in order to do that I need a detailed guide as I am way too inexperienced with there things. Does anyone know of a detailed guide that specifically shows how to compile a kernel with the APM module?
 
Old 11-09-2013, 08:02 PM   #7
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,380

Rep: Reputation: 180Reputation: 180
There's a typo in that line - it should read:

Code:
append = "acpi=force"
 
Old 11-09-2013, 08:10 PM   #8
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
It is indeed not set in the 32bit kernel but it can be turned on.

First copy your current running kernel config
Code:
zcat /proc/config.gz > /usr/src/linux/config
Then use
Code:
make menuconfig
to get a nice kernel config menu.

Use the cursor keys to go down to the option Power management and ACPI options ---> and hit "Enter"
Now cursor down to < > APM (Advanced Power Management) BIOS support ---> and hit "Space" twice
The < > should now be <*> which means it will be built into the kernel

Now hit ESC twice in quick succession and then do it again (4 times in total) and you should have a dialog asking you to save changes
The default is Yes so you can just hit "Enter" here.

Now you need to kick off the build by typing "make" and hit Enter.

At this point given the specs of the machine you gave you might want to find something else to do for a while and this will take some time ..............

Once it does finish you'll find you nice new kernel as arch/x86/boot/bzImage copy that file over to /boot
Create yourself a new entry in /etc/lilo.conf to boot it (just copy your current kernel section over and change the "image" and "label" sections to suit
Now run lilo
Then reboot and select the new kernel and see how it goes, if it works ok you can then set lilo to boot in by default (lilo boots the first kernel as the default)
 
1 members found this post helpful.
Old 11-09-2013, 08:17 PM   #9
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 103

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by mlangdn View Post
There's a typo in that line - it should read:

Code:
append = "acpi=force"
Unfortunately it does not make any difference.

This command line can be inserted anywhere in /etc/lilo.conf, right? I inserted it at the end of the file.
 
Old 11-10-2013, 12:49 AM   #10
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 887

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Pat had to remove APM support from Slackware 14.0 and up. You're better off with installing Slackware 13.37 on such an old non-ACPI machine, especially if it's a laptop, which requires APM for more than just powering off.
 
Old 11-10-2013, 02:09 AM   #11
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,771

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Try modprobing the apm module:
modprobe apm
before shutting down. If that works, then you can uncomment the line for the module in /etc/rc.d/rc.modules so that it gets loaded at boot time.
 
Old 11-10-2013, 02:10 AM   #12
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 887

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
As said above, the apm module is not part of Slackware 14+
 
Old 11-10-2013, 10:34 AM   #13
the3dfxdude
Member
 
Registered: May 2007
Posts: 329

Rep: Reputation: 100Reputation: 100
apmd is still in slackware 14.1. The kernel was built without it. It's theoretically possible to still work. I'm not sure the reason that it was pulled out. Maybe since we went to SMP by default, and that most machines were likely newer than 2000?

I agree with the suggestion of acpi=force. It's rare in '99, but I did have ACPI on my new '99 motherboard and preferred that to APM.

Quote:
This command line can be inserted anywhere in /etc/lilo.conf, right? I inserted it at the end of the file.
Possibly not. Please post your config to explain if you can. Or try manually typing it in at boot.
 
Old 11-10-2013, 11:12 AM   #14
guzzi
Member
 
Registered: Jun 2004
Location: Lawrence, KS
Distribution: Slackware
Posts: 294

Rep: Reputation: 32
What has worked for me is an edit of lilo.conf is this.

append" vt.default_utf8=0 video=1024x768 acpi=force"

This is from a box used as a file backup for a lot of years.

Good Luck
 
Old 11-11-2013, 07:04 PM   #15
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 103

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by wildwizard View Post
It is indeed not set in the 32bit kernel but it can be turned on.

First copy your current running kernel config
Code:
zcat /proc/config.gz > /usr/src/linux/config
Then use
Code:
make menuconfig
to get a nice kernel config menu.

Use the cursor keys to go down to the option Power management and ACPI options ---> and hit "Enter"
Now cursor down to < > APM (Advanced Power Management) BIOS support ---> and hit "Space" twice
The < > should now be <*> which means it will be built into the kernel

Now hit ESC twice in quick succession and then do it again (4 times in total) and you should have a dialog asking you to save changes
The default is Yes so you can just hit "Enter" here.

Now you need to kick off the build by typing "make" and hit Enter.

At this point given the specs of the machine you gave you might want to find something else to do for a while and this will take some time ..............

Once it does finish you'll find you nice new kernel as arch/x86/boot/bzImage copy that file over to /boot
Create yourself a new entry in /etc/lilo.conf to boot it (just copy your current kernel section over and change the "image" and "label" sections to suit
Now run lilo
Then reboot and select the new kernel and see how it goes, if it works ok you can then set lilo to boot in by default (lilo boots the first kernel as the default)
I am going to try your suggestion this coming weekend.
In the meantime, I have done some more research on the Internet about this topic. From what little I understand, it seems that some people recommend this command:
Code:
zcat /proc/config.gz > /usr/src/linux/.config
instead of:
Code:
zcat /proc/config.gz > /usr/src/linux/config
What do you think?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
crc error system halted prabush5 Linux - Newbie 7 02-27-2009 10:33 AM
Less than 4MB of memory --system halted seriesx4 Fedora - Installation 4 03-15-2005 03:43 PM
crc error system halted some_person64 Linux - General 2 09-13-2004 10:59 PM
system really halted? jwhiz Linux - Newbie 2 12-27-2003 04:24 AM
redhat installation - system halted elizabetg Linux - Software 1 04-17-2001 12:59 PM


All times are GMT -5. The time now is 12:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration