LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   System Halted (http://www.linuxquestions.org/questions/slackware-14/system-halted-4175484040/)

tb75252 11-09-2013 03:28 PM

System Halted
 
I am not a Linux expert but I managed to install Slackware 14.1 (32-bit) on a 1999 desktop which has a Pentium III 1.1 GHz.

Things seem to go well, except for this little annoyance: When I power the system off it gets to the point where it says "System halted" and never actually powers off automatically. I think it has something to do with my system BIOS still supporting APM whereas Slackware 14.1 does not support that.

Anyhow, I am stuck. Somebody suggested that I need to build a custom kernel to get this APM module back but I do not have the faintest idea of how this is done, or even if that would solve my problem.

Anyone willing to help me solve this?

unSpawn 11-09-2013 04:07 PM

Quote:

Originally Posted by tb75252 (Post 5061504)
I think it has something to do with my system BIOS still supporting APM whereas Slackware 14.1 does not support that.

To be pedantic about it this isn't about a distro "supporting" it or not but about the kernel and what options its compiled with.


Quote:

Originally Posted by tb75252 (Post 5061504)
Somebody suggested that I need to build a custom kernel to get this APM module back but I do not have the faintest idea of how this is done, or even if that would solve my problem.

http://wiki.linuxquestions.org/wiki/Slackware-Links > http://blog.tpa.me.uk/slackware-kernel-compile-guide/

ReaperX7 11-09-2013 04:21 PM

Check your BIOS power options to see if it allows for ACPI/APM shutdown mode usually branded as "Allow Software Power Off".

ljb643 11-09-2013 05:04 PM

I don't know if this still works or applies, but back a few years ago we needed to put a line in /etc/lilo.conf in order to get the system to power off if the BIOS was older than 2001 (which yours obviously is). The line was:
Code:

append = "apci=force"
Does anyone know if this still applies? (I've got some old stuff, but nothing that old.)

tb75252 11-09-2013 06:17 PM

Quote:

Originally Posted by ReaperX7 (Post 5061535)
Check your BIOS power options to see if it allows for ACPI/APM shutdown mode usually branded as "Allow Software Power Off".

The BIOS has an entry called "PM Control by APM" and it is set to YES. Unfortunately it does not help turning the desktop off when I leave Slackware. I cannot find any entry that allows software to power off.

tb75252 11-09-2013 06:23 PM

Quote:

Originally Posted by ljb643 (Post 5061560)
I don't know if this still works or applies, but back a few years ago we needed to put a line in /etc/lilo.conf in order to get the system to power off if the BIOS was older than 2001 (which yours obviously is). The line was:
Code:

append = "apci=force"
Does anyone know if this still applies? (I've got some old stuff, but nothing that old.)

I added that line to /etc/lilo.conf but unfortunately no change.

I am guessing that I really need to recompile the kernel by adding the APM module but in order to do that I need a detailed guide as I am way too inexperienced with there things. Does anyone know of a detailed guide that specifically shows how to compile a kernel with the APM module?

mlangdn 11-09-2013 07:02 PM

There's a typo in that line - it should read:

Code:

append = "acpi=force"

wildwizard 11-09-2013 07:10 PM

It is indeed not set in the 32bit kernel but it can be turned on.

First copy your current running kernel config
Code:

zcat /proc/config.gz > /usr/src/linux/config
Then use
Code:

make menuconfig
to get a nice kernel config menu.

Use the cursor keys to go down to the option Power management and ACPI options ---> and hit "Enter"
Now cursor down to < > APM (Advanced Power Management) BIOS support ---> and hit "Space" twice
The < > should now be <*> which means it will be built into the kernel

Now hit ESC twice in quick succession and then do it again (4 times in total) and you should have a dialog asking you to save changes
The default is Yes so you can just hit "Enter" here.

Now you need to kick off the build by typing "make" and hit Enter.

At this point given the specs of the machine you gave you might want to find something else to do for a while and this will take some time ..............

Once it does finish you'll find you nice new kernel as arch/x86/boot/bzImage copy that file over to /boot
Create yourself a new entry in /etc/lilo.conf to boot it (just copy your current kernel section over and change the "image" and "label" sections to suit
Now run lilo
Then reboot and select the new kernel and see how it goes, if it works ok you can then set lilo to boot in by default (lilo boots the first kernel as the default)

tb75252 11-09-2013 07:17 PM

Quote:

Originally Posted by mlangdn (Post 5061604)
There's a typo in that line - it should read:

Code:

append = "acpi=force"

Unfortunately it does not make any difference.

This command line can be inserted anywhere in /etc/lilo.conf, right? I inserted it at the end of the file.

jtsn 11-09-2013 11:49 PM

Pat had to remove APM support from Slackware 14.0 and up. You're better off with installing Slackware 13.37 on such an old non-ACPI machine, especially if it's a laptop, which requires APM for more than just powering off.

gnashley 11-10-2013 01:09 AM

Try modprobing the apm module:
modprobe apm
before shutting down. If that works, then you can uncomment the line for the module in /etc/rc.d/rc.modules so that it gets loaded at boot time.

jtsn 11-10-2013 01:10 AM

As said above, the apm module is not part of Slackware 14+

the3dfxdude 11-10-2013 09:34 AM

apmd is still in slackware 14.1. The kernel was built without it. It's theoretically possible to still work. I'm not sure the reason that it was pulled out. Maybe since we went to SMP by default, and that most machines were likely newer than 2000?

I agree with the suggestion of acpi=force. It's rare in '99, but I did have ACPI on my new '99 motherboard and preferred that to APM.

Quote:

This command line can be inserted anywhere in /etc/lilo.conf, right? I inserted it at the end of the file.
Possibly not. Please post your config to explain if you can. Or try manually typing it in at boot.

guzzi 11-10-2013 10:12 AM

What has worked for me is an edit of lilo.conf is this.

append" vt.default_utf8=0 video=1024x768 acpi=force"

This is from a box used as a file backup for a lot of years.

Good Luck

tb75252 11-11-2013 06:04 PM

Quote:

Originally Posted by wildwizard (Post 5061605)
It is indeed not set in the 32bit kernel but it can be turned on.

First copy your current running kernel config
Code:

zcat /proc/config.gz > /usr/src/linux/config
Then use
Code:

make menuconfig
to get a nice kernel config menu.

Use the cursor keys to go down to the option Power management and ACPI options ---> and hit "Enter"
Now cursor down to < > APM (Advanced Power Management) BIOS support ---> and hit "Space" twice
The < > should now be <*> which means it will be built into the kernel

Now hit ESC twice in quick succession and then do it again (4 times in total) and you should have a dialog asking you to save changes
The default is Yes so you can just hit "Enter" here.

Now you need to kick off the build by typing "make" and hit Enter.

At this point given the specs of the machine you gave you might want to find something else to do for a while and this will take some time ..............

Once it does finish you'll find you nice new kernel as arch/x86/boot/bzImage copy that file over to /boot
Create yourself a new entry in /etc/lilo.conf to boot it (just copy your current kernel section over and change the "image" and "label" sections to suit
Now run lilo
Then reboot and select the new kernel and see how it goes, if it works ok you can then set lilo to boot in by default (lilo boots the first kernel as the default)

I am going to try your suggestion this coming weekend.
In the meantime, I have done some more research on the Internet about this topic. From what little I understand, it seems that some people recommend this command:
Code:

zcat /proc/config.gz > /usr/src/linux/.config
instead of:
Code:

zcat /proc/config.gz > /usr/src/linux/config
What do you think?


All times are GMT -5. The time now is 10:37 PM.