LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-03-2009, 08:40 AM   #1
robby_dobby
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware 13
Posts: 4

Rep: Reputation: 0
System freezes, disabling IRQ channel in Slackware 13


Hey folks,

I got an issue that got me stumped. The system simply freezes for a few minutes resulting in a complete disabling of IRQ #5. This happens regardless of whether I'm in X or working from the console.

Here's the stack trace from the syslog:

Quote:

Nov 3 19:16:27 localhost kernel: Pid: 2902, comm: mutt Not tainted 2.6.29.6-smp #2
Nov 3 19:16:27 localhost kernel: Call Trace:
Nov 3 19:16:27 localhost kernel: [<c0157604>] __report_bad_irq+0x24/0x90
Nov 3 19:16:27 localhost kernel: [<c01577c7>] note_interrupt+0x157/0x1a0
Nov 3 19:16:27 localhost kernel: [<c0157f6b>] handle_level_irq+0xab/0xd0
Nov 3 19:16:27 localhost kernel: [<c0105523>] do_IRQ+0x43/0x90
Nov 3 19:16:27 localhost kernel: [<c0103927>] common_interrupt+0x27/0x2c
Nov 3 19:16:27 localhost kernel: [<c0103927>] common_interrupt+0x27/0x2c
Nov 3 19:16:27 localhost kernel: [<c067cd08>] i8042_interrupt+0xc8/0x270
Nov 3 19:16:27 localhost kernel: [<c0147ba7>] tick_handle_periodic+0x17/0x90
Nov 3 19:16:27 localhost kernel: [<c0156938>] handle_IRQ_event+0x28/0x50
Nov 3 19:16:27 localhost kernel: [<c0157f24>] handle_level_irq+0x64/0xd0
Nov 3 19:16:27 localhost kernel: [<c0105523>] do_IRQ+0x43/0x90
Nov 3 19:16:27 localhost kernel: [<c0103927>] common_interrupt+0x27/0x2c
Nov 3 19:16:27 localhost kernel: [<c015694c>] handle_IRQ_event+0x3c/0x50
Nov 3 19:16:27 localhost kernel: [<c04b4380>] fcoe_watchdog+0x0/0x70
Nov 3 19:16:27 localhost kernel: [<c0157f24>] handle_level_irq+0x64/0xd0
Nov 3 19:16:27 localhost kernel: [<c0105523>] do_IRQ+0x43/0x90
Nov 3 19:16:27 localhost kernel: [<c0105528>] do_IRQ+0x48/0x90
Nov 3 19:16:27 localhost kernel: [<c0105528>] do_IRQ+0x48/0x90
Nov 3 19:16:27 localhost kernel: [<c0103927>] common_interrupt+0x27/0x2c
Nov 3 19:16:27 localhost kernel: [<c04b4380>] fcoe_watchdog+0x0/0x70
Nov 3 19:16:27 localhost kernel: [<c0133471>] __mod_timer+0x1/0xa0
Nov 3 19:16:27 localhost kernel: [<c04b4380>] fcoe_watchdog+0x0/0x70
Nov 3 19:16:27 localhost kernel: [<c0132f39>] run_timer_softirq+0xf9/0x1c0
Nov 3 19:16:27 localhost kernel: [<c012ecff>] __do_softirq+0x8f/0x130
Nov 3 19:16:27 localhost kernel: [<e4cdb0b0>] parport_irq_handler+0x20/0x50 [parport]
Nov 3 19:16:27 localhost kernel: [<c012eddd>] do_softirq+0x3d/0x50
Nov 3 19:16:27 localhost kernel: [<c0105528>] do_IRQ+0x48/0x90
Nov 3 19:16:27 localhost kernel: [<c0103927>] common_interrupt+0x27/0x2c
Nov 3 19:16:27 localhost kernel: handlers:
Nov 3 19:16:27 localhost kernel: [<e4ac2d20>] (rtl8139_interrupt+0x0/0x4f0 [8139too])
Nov 3 19:16:27 localhost kernel: Disabling IRQ #5

Here's my output from "lspci|grep Ethernet"
Quote:
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Here's the output of : dmesg|grep "IRQ 5"
Quote:

ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
8139too 0000:00:0a.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
eth0: RealTek RTL8139 at 0xd800, <xxxx>, IRQ 5
This had me scratching my head for a few days. Can someone help me out with the issue? Btw, I don't understand why the IRQ channel is shared between the ethernet controller and the ACPI controller?

Lastly, uname -a
Quote:

Linux localhost 2.6.29.6-smp #2 SMP Mon Aug 17 00:52:54 CDT 2009 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux
Let me know if you need more info.
 
Old 11-03-2009, 09:26 AM   #2
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
If this is a PCI NIC, move it to another slot. If it's onboard, you'll have to use the bios to reroute the IRQ numbers. There are options you can pass to the kernel from Lilo, but I'd try moving the NIC to another slot first.

--edit hit submit too soon--
You can try passing noacpi or pci=noapci. Check for a bios update as well.

Last edited by disturbed1; 11-03-2009 at 09:30 AM.
 
Old 11-05-2009, 09:17 AM   #3
robby_dobby
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware 13
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by disturbed1 View Post
If this is a PCI NIC, move it to another slot.
Awesome! That solved it! Many thanks!

Btw, can you provide some more info on what exactly went on here? It's not often that I get a call trace from syslog...

Last edited by robby_dobby; 11-05-2009 at 09:20 AM. Reason: Btw...
 
Old 11-05-2009, 10:30 AM   #4
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
The short of it -
IRQ sharing causes more than one device to be allocated the same resources. It is hit or miss if it works. Sometimes devices are happy sharing, other times they're like spoiled little kids. The motherboards BIOS maps resources out according to PCI slots. Usually AGP/PCIe is shared with PCI slot 1, slot2 and slot3 are shared, slot4 and slot5 are shared. Honestly, there is no rule of thumb, and varies manufacturer to manufacturer as far as the IRQ routing goes, the above seems to be pretty common though.

Keep an eye on this, especially if the same NIC has always been in the same PCI slot. If this crops up again, it's possibly another problem altogether. Though this too can vary, most likely it boils down to failing NIC, or bad driver. Next time your at the computer store, or make a purchase online, pick a spare NIC. It's always nice to have one handy.
 
Old 11-07-2009, 11:14 AM   #5
robby_dobby
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware 13
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks again. Now that the main issue is resolved, marking this thread as [SOLVED].
 
  


Reply

Tags
freezes, irq


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling irq #19 mengchun_khor Linux - Newbie 2 08-15-2008 10:10 AM
Disabling IRQ #17 okos Linux - Newbie 4 10-04-2007 07:54 PM
kernel: Disabling IRQ specman Mandriva 2 10-21-2005 07:35 AM
Disabling IRQ #11 keripukki Linux - Hardware 4 09-18-2004 05:54 PM
Disabling IRQ #7? rjerina Linux - Hardware 4 07-30-2004 12:47 AM


All times are GMT -5. The time now is 03:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration