LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-21-2005, 11:20 PM   #1
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Rep: Reputation: 30
System beeps at shutdown


OK I hate starting threads when I am pretty sure that my question has been answered somewhere else, but I wasn't able to find anything helpful on this one. I am running Slack 10 and everytime I do shutdown -r 0 or halt or shutdown -h 0 , I get this annoying system beep. I know it's fixable without removing the system speaker, because I have had this problem only in Slack and SuSe, furthermore I don't want to open my laptop. I found this solution for SuSe:

//------------------------
//this is exact copy from a SuSe thread on this forum

Edit the /etc/rc.d/halt script and remove or comment out (add a # in front of) the lines containing

echo -en "\033[<some things here>]\a"
and
echo -en "\a"

which are not in the case for $HALT_SOUND in "yes", "quint" or "octave" (line 138, 143 and 147 in my script).
//--------------------------------------------------

But I don't know how to implement it under Slack.

Anyone had this problem before? Thanks a lot.
 
Old 03-21-2005, 11:37 PM   #2
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
is it just one beep? or a continuos beep?
 
Old 03-22-2005, 12:55 AM   #3
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Original Poster
Rep: Reputation: 30
just a single beep
 
Old 03-22-2005, 01:14 AM   #4
eelriver
Member
 
Registered: May 2004
Location: san francisco
Distribution: Slackware 10.2 kernel 2.6.13, Gentoo amd64, Some mish-mash of programs that started with slack 9.0
Posts: 165

Rep: Reputation: 30
Is it a laptop with a pcmcia network card? Mine does that when it gets to pcmcia shutdown.
 
Old 03-22-2005, 01:28 AM   #5
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Original Poster
Rep: Reputation: 30
Laptop Dell inspiron 8600, No pcmcia
 
Old 03-22-2005, 01:35 AM   #6
bornhj
Member
 
Registered: Sep 2004
Location: Canberra, Australia
Distribution: Fedora Core 3, Ubuntu Hoary, Slack 10.1
Posts: 120

Rep: Reputation: 15
Follow the instructions at http://shilo.is-a-geek.com/slack/annoy13.html
That should fix it.

My desktop doesn't do this... it's strange.
 
Old 03-22-2005, 02:08 AM   #7
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Original Poster
Rep: Reputation: 30
That's a fix to the system beep in the console, not the beep at shutdown
Quote:
Follow the instructions at http://shilo.is-a-geek.com/slack/annoy13.html


Thank you for trying though
Quote:
Disable system beep. This is one of those things that just annoys me. When I'm typing away at the command line, I make a mistake and I get an annoying beep from the PC speaker
 
Old 03-22-2005, 06:31 AM   #8
numb
Member
 
Registered: Mar 2005
Location: Canada
Distribution: Slackware
Posts: 47

Rep: Reputation: 15
why not just run alsamixer (assuming you are running alsa) and mute the system speaker?
 
Old 03-22-2005, 01:56 PM   #9
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Original Poster
Rep: Reputation: 30
Hey numb, that sounded like a really good idea. Only bad part is that it didn't work. :-) I ran alsamixer and the only thing that resemples a system speaker is the PC speaker. I muted it, but still right after I write halt or shutdown, I get a beep. It is not at some other point, but only right after I press enter for those two commands. I am wondering if there is anything to do with the broadcast message that root is supposed to send to all users, but I didn't think halt sends broadcast.
 
Old 03-22-2005, 05:16 PM   #10
artificialGekko
Member
 
Registered: Mar 2005
Posts: 77

Rep: Reputation: 15
Did you save the new settings to alsamixer after closing it? Try "alsactl store" as root...

Good luck with solving your prob...
 
Old 03-23-2005, 04:45 AM   #11
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Original Poster
Rep: Reputation: 30


This doesn't work . Damn I am getting tired of this. Any other suggestions out there. Pleaseeee
 
Old 03-23-2005, 06:12 AM   #12
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Recompile your kernel without PC Speaker support
Device Drivers -->Input device support->PC Speaker support
 
Old 03-29-2005, 05:17 AM   #13
bornhj
Member
 
Registered: Sep 2004
Location: Canberra, Australia
Distribution: Fedora Core 3, Ubuntu Hoary, Slack 10.1
Posts: 120

Rep: Reputation: 15
Where does it beep in your shutdown sequence?

Quote:
That's a fix to the system beep in the console, not the beep at shutdown
Ah, but it is a console beep I believe.
 
Old 03-29-2005, 01:51 PM   #14
alagenchev
Member
 
Registered: Oct 2004
Location: USA
Distribution: Slackware, Debian, Ubuntu
Posts: 223

Original Poster
Rep: Reputation: 30
thank you for sticking with me bornhj, I get a beep right after I press enter. I know it's not a console beep , because I tried fixing SuSe using the exact same instructions that you posted and it didn't work. Now I run Slack and I have the same problem. I know it is a configuration setting, because I don't get it under RH or Fedora. I am planning on doing a kernel recompile, but I am going to wait until my semester is over. I go to school, and it's pretty busy right now. I'll post the results from the recompile later.

Thanks for everyone's support here.


Note: I am still open to suggestions.
 
Old 03-30-2005, 02:17 AM   #15
bornhj
Member
 
Registered: Sep 2004
Location: Canberra, Australia
Distribution: Fedora Core 3, Ubuntu Hoary, Slack 10.1
Posts: 120

Rep: Reputation: 15
That really is odd.

A recompile isn't that hard, just copy your current config and disable the stuff you're _certain_ you don't need.

Ah, and I too go to school
 
  


Reply

Tags
beep, system


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
system beeps bhodi Slackware 2 04-17-2005 07:11 AM
system beeps in terminal curmudgeon42 Linux - Software 5 01-12-2005 05:29 PM
Ctrl key beeps the system speaker? bruno buys Linux - Newbie 1 11-30-2003 07:06 AM
2.6.0-test11 no system beeps mrant Linux - Hardware 1 11-30-2003 01:50 AM
three beeps and the system blocks daste Linux - Hardware 1 10-31-2003 06:27 AM


All times are GMT -5. The time now is 08:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration