LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-24-2008, 03:36 PM   #1
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 270

Rep: Reputation: 31
Synaptics touchpad not recognised by synaptics driver (12.1)


Slack 12.1. I have a synaptics touchpad on a Lenovo 3000 N200 laptop. /proc/bus/input/devices tells me all about it including that its handler is mouse1, event 8. I managed to build and install a synpatics driver using the information provided by rworkman in the very helpful post at
http://www.linuxquestions.org/questi...rg-7.3-592525/

X loads the synaptics module but then reports in the Xorg.log file:
"no synaptics event device found (checked 19 nodes)". I guess that I have to make explicit in the xorg.conf file which device it should be reading from - I know that /dev/input/mouse1 produces data when I touch the touchpad but I not sure how I tie that into the xorg.conf file. Any help appreciated.
 
Old 05-24-2008, 03:43 PM   #2
jcvlz
LQ Newbie
 
Registered: May 2008
Posts: 14

Rep: Reputation: 0
Try taking a look at the output of "xev". I have a synaptics touchpad but never use it, but I've considered using it as a secondary input to send different events than my usb mouse. Anyway, I did not take a look at the link you posted, but I believe you should be able to get it working with some configuration of xorg.conf.
 
Old 05-25-2008, 08:14 AM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I had a lot of trouble getting mine to work as well, and got it going with a combination of using the Synaptics Slackbuild at slacky.eu and messing with my xorg.conf. Here are the relevant excerpts:

Code:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "AlwaysCore"
    InputDevice    "TouchPad" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Code:
Section "InputDevice"
    Identifier     "TouchPad"
    Driver         "synaptics"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "LeftEdge" "1700"
    Option         "RightEdge" "5300"
    Option         "TopEdge" "1700"
    Option         "BottomEdge" "4200"
    Option         "FingerLow" "25"
    Option         "FingerHigh" "30"
    Option         "MaxTapTime" "180"
    Option         "MaxTapMove" "220"
    Option         "VertScrollDelta" "100"
    Option         "MinSpeed" "0.09"
    Option         "MaxSpeed" "0.18"
    Option         "AccelFactor" "0.0015"
    Option         "SHMConfig" "on"
EndSection
Of course you also have to load the synaptics module in the Module section.
 
Old 05-25-2008, 12:24 PM   #4
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 270

Original Poster
Rep: Reputation: 31
Thanks for the xorg.conf extracts and the url to the Slackbuild for the synaptics driver. I have tried again with the driver installed from this build and with xorg.conf based on your example, but still no joy - the synaptics driver still cannot find a synaptics device. The result is an X session with a mouse cursor but no movement when I try and move it with the Touchpad.

I see that in your xorg.conf server Layout section you have both a Touchpad device (Corepointer) defined and a Mouse0 device (AlwaysCore). Can you show us what the Mouse0 Input Device section looks like? I have tried xorg.conf both with a "regular" mouse and without (and also trying same and different devices for the two) but always without success. Perhaps there is something I need to know about the Mouse0 configuration for this to work ?
 
Old 05-26-2008, 08:11 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I don't know if it helps much since it is pretty simple, but here it is:

Code:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5"
EndSection
 
Old 05-26-2008, 11:23 AM   #6
eddyvp
Member
 
Registered: Feb 2007
Location: Belgium
Distribution: Slackware
Posts: 37

Rep: Reputation: 17
Is your touchpad recognized by the system?
What is the output from
Code:
cat /proc/bus/input/devices
?

If not: change the line /sbin/modprobe psmouse proto=impsinto /sbin/modprobe psmousein the file /etc/rc.d/rc.modules, then reboot.

Worked for me with Slack 12.0

Greetings
eddyvp
 
Old 05-26-2008, 01:27 PM   #7
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Quote:
Originally Posted by eddyvp
If not: change the line /sbin/modprobe psmouse proto=impsinto /sbin/modprobe psmousein the file /etc/rc.d/rc.modules, then reboot.
This is no longer correct in 12.1. In 12.0, the psmouse module was blacklisted in /etc/modprobe.d/blacklist and subsequently loaded in /etc/rc.d/rc.modules*, so your solution was correct. Now, however, the psmouse is NOT blacklisted and instead of being loaded from rc.modules*, it is just automatically loaded with the options given in /etc/modprobe.d/psmouse. Therefore, you should just edit /etc/modprobe.d/psmouse and change the options there instead. I don't know that it will help your problem, but if you do try that solution be sure that you do it correctly according to Slackware 12.1 and not 12.0.
 
Old 05-26-2008, 02:29 PM   #8
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 270

Original Poster
Rep: Reputation: 31
Thanks to everybody who replied to this post - all is OK now.

I had commented out the command:
"modprobe psmouse proto=imps"
from the /etc/modprobe.d/psmouse file. I had not modified the similar line in the /etc/rc.d/rc.modules file. Once I had done this, the synaptics driver worked OK and the synclient programme also works to modify the options during an X session. Wow.
 
Old 05-31-2008, 09:22 AM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I want to update what I had posted earlier, because it turned out I had made a pretty substantial mistake in the xorg.conf I posted. Using the xorg.conf I posted, it turns out that while the synaptics touchpad worked fine, no other mice worked at all. Since I use the touchpad most of the time, I simply hadn't noticed it. However, when I tried to fix the problem, it turns out that I could only get one mouse working at a time, and that was the mouse that was declared "CorePointer" in the ServerLayout section. Any mouse declared to be "AlwaysCore" didn't work.

Well, it turns out that in Xorg 7.3, the "AlwaysCore" directive has been removed, so any device declared to be AlwaysCore, didn't work. The fix I found is the "SendCoreEvents directive:

Code:
   Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "TouchPad" "SendCoreEvents"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
I also modified the InputDevice section for the touchpad to include this:

Code:
Option	   "SendCoreEvents" "true"
So the whole thing now looks like this:

Code:
Section "InputDevice"
    Identifier     "TouchPad"
    Driver         "synaptics"
    Option	   "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "LeftEdge" "1700"
    Option         "RightEdge" "5300"
    Option         "TopEdge" "1700"
    Option         "BottomEdge" "4200"
    Option         "FingerLow" "25"
    Option         "FingerHigh" "30"
    Option         "MaxTapTime" "180"
    Option         "MaxTapMove" "220"
    Option         "VertScrollDelta" "100"
    Option         "MinSpeed" "0.09"
    Option         "MaxSpeed" "0.18"
    Option         "AccelFactor" "0.0015"
    Option         "SHMConfig" "on"
EndSection
Now multiple mice seem to coexist quite nicely
 
Old 06-02-2008, 09:28 AM   #10
delta function
Member
 
Registered: Jul 2004
Posts: 51

Rep: Reputation: 20
Hi there,

I am running an ACER 5050 with slack 12.1 now, thanks to this posting synaptics works like a charm ......

{smile}
 
Old 06-11-2008, 08:29 PM   #11
josiah
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 46

Rep: Reputation: 23
This thread was immensely helpful for me as well. I feel obligated, though, to point out how my own stupidity got in the way: when editing /etc/modprobe.d/psmouse, vim created a backup file (/etc/modprobe.d/psmouse~) which needed to be deleted. Of course, I forgot to delete this, so the imps option was continuing to be passed. Thanks especially to Hangdog42 for this!
 
Old 06-12-2008, 03:36 AM   #12
ppr:kut
Slackware Contributor
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 366

Rep: Reputation: 94
I just wondered why it did work for me all the time without changing that file, and quickly found the reason which might be suboptimal
I use (for various reasons) a self-compiled kernel-image. I remember having had problems with the mouse in general in early 2.6 kernels and solved that by compiling psmouse directly into the kernel (not as a module). It did work fine afterwards. Interestingly I totally forgot about this over time and never changed it back...
 
Old 02-26-2009, 04:43 PM   #13
mancho
LQ Newbie
 
Registered: Feb 2009
Location: Manizales, Colombia
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
Thanks to this thread I finally made the vertical scrolling work on my Acer Aspire 2920.
 
Old 03-22-2009, 10:23 PM   #14
liquid_fix
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
Hi there!
Thanks for the info in this thread!!
I managed to make work the synaptics touch pad on a couple of laptops with slackware 12.2
I changed:
options psmouse proto=auto
In the
/etc/modprobe.d/psmouse
file.
And yes, rembermer to delete the psmouse~ file after editing like josiah says.

Thanks again to all !!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 04:15 PM
Synaptics USB Touchpad - X11 Driver GerbilSoft Linux - Laptop and Netbook 0 03-31-2005 04:43 AM
Synaptics touchpad driver - unable to start VertX Linux - Laptop and Netbook 4 02-07-2005 09:27 AM
Synaptics TouchPad driver problem in Fedora 2 udayan_linux Linux - Laptop and Netbook 5 08-31-2004 10:37 PM
Pointing stick stops working with Synaptics touchpad driver! mmarshall Linux - Laptop and Netbook 0 05-13-2004 12:58 PM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration