LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   symbol lookup error: /usr/sbin/httpd: undefined symbol: apr_file_link (http://www.linuxquestions.org/questions/slackware-14/symbol-lookup-error-usr-sbin-httpd-undefined-symbol-apr_file_link-881162/)

bagi 05-17-2011 05:36 AM

symbol lookup error: /usr/sbin/httpd: undefined symbol: apr_file_link
 
Hi everyone ...
today i upgraded my httpd, because of this alert:
SSA:2011-133-02 (httpd)
http://lwn.net/Articles/443067/

Now my httpd is broken :/
After calling: /etc/rc.d/rc.httpd start
I get this error:

/usr/sbin/httpd: symbol lookup error: /usr/sbin/httpd: undefined symbol: apr_file_link

Anyone has the same error?


EDIT: 0> cat /etc/slackware-version
0> Slackware 12.2.0


Greetings
bagi

EDIT (2):
After upgrading apr/apr-util with those tgz's, all is fine again :)
apr-util-1.3.11-i486-1_slack12.2.tgz
apr-1.4.4-i486-1_slack12.2.tgz


This thread can be closed.

corp769 05-17-2011 05:56 AM

Hello,

In order for your thread to be closed, you will have to request a moderator to close it. I have reported it to be closed for you though, so don't worry :p You can also mark your thread as [SOLVED] using the thread tools.

Cheers,

Josh

bagi 05-17-2011 06:01 AM

Hello corp769
ty for your help. As you can see, im really
not an experienced forum user.
Mea culpa :)
Bagi

XavierP 05-17-2011 07:49 AM

We don't simply close threads because the issue is solved as others may have a similar problem and need to discuss their own findings. Glad to see that you fixed it though.


All times are GMT -5. The time now is 10:49 AM.