LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-23-2004, 01:08 PM   #1
t-peters1975
LQ Newbie
 
Registered: Aug 2004
Posts: 6

Rep: Reputation: 0
Switching to LILO from Grub


Well, here is problem on computer number one. I used to be a fairly hard-core devotee of Linux in the early 90s (kernel numbers < 1.0) but having not used UNIX of any sort in about 8 years, seem to be struggling with just about everything.

After hearing all this hoopla over Redhat, I installed Redhat, only to decide that Redhat _sucks_, if for no other reason than that those little redhat wearing fools thought they were being clever by violating every single UNIX convention ever _written_.

Back to slackware for me.

So, I did a couple of things:

Added a new hard drive, as, /dev/hda. (hda1 is /root, hda2 is swap)
Old hard drive was reformatted and mounted to /home as /dev/hdb1.

After slackware v10.0 install, I can boot from a floppy fine, but cannot boot from the hard drive. All that happens is grub comes up as "Grub" and the system hangs. So, I guess the brilliant boys at Red Hat wrote Grub into the MBR of /dev/hdb.

Why my computer boots to that, I don't know, but I think that is what's happening. I've installed LILO to /dev/hda (correctly, I think) but it just isn't happening.

Does anyone know how to fix this? My thinking is I need to clear the MBR on /dev/hdb (am not quite sure how to do this) and then install LILO to /dev/hda (but I think that's already done.)

Any advice and/or insight is appreciated.

Thanks,
Todd
 
Old 08-23-2004, 01:14 PM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
just reconfigure and re-install lilo in the mbr with 'liloconfig'.
should do it ....

egag
 
Old 08-23-2004, 01:15 PM   #3
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
I would make sure that boot sequence is ok in the bios.
If it fails, I would attempt to erase mbr from /dev/hdb like :

dd if=/dev/zero of=/dev/hdb count=1 bs=426 && sync

But before that, if you have a prompt like this at boot :

grub>

...then you have the possibility to use grub as bootloader if you want.
 
Old 08-23-2004, 01:18 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
something doesn't sound right. have you checked your BIOS, jumper settings, and cabling to make sure the hard drives are set up properly (master/slave on IDE1, master/master on IDE1/IDE2, etc.) ?

if that's okay, then what i would do is remove hdb, boot to hda, with the floppy disk if necessary, rerun lilo installing it to the MBR of hda, then shut down, add hdb again, and try to boot. once i was booted again with both drives, i would overhaul hdb just to clean everything off it. that should work, if not post back.
 
Old 08-23-2004, 01:20 PM   #5
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Re: Switching to LILO from Grub

Quote:
Originally posted by t-peters1975
Does anyone know how to fix this? My thinking is I need to clear the MBR on /dev/hdb (am not quite sure how to do this) and then install LILO to /dev/hda (but I think that's already done.)
I don't think /dev/hdb MBR has anything to do with it. If your BIOS points to /dev/hda as the boot disk, /hdb MBR never even comes into play.

Rather, make sure your lilo was correctly set up in /etc/lilo.conf (post it if you dont mind.)

Last edited by suslik; 08-23-2004 at 01:24 PM.
 
Old 08-23-2004, 01:36 PM   #6
t-peters1975
LQ Newbie
 
Registered: Aug 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks guys. It must have been something in the BIOS, I removed hdb, it booted fine, plugged hdb back in, it booted fine.

Whoops.

Is there a way to tell LILO to cut all the verbosity and just boot straight into Linux with no delay (and I don't really need the ugly LILO screen, either)?
 
Old 08-23-2004, 02:05 PM   #7
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
you can change the delay to 0 if you do not want to see the lilo screen. the rest of the stuff is kernel booting. i like to keep an eye on that stuff to see if a problem leaps out at me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting of raw ISO from GRUB/LILO (though preferably GRUB) Orkie Linux - Software 28 12-15-2013 10:37 PM
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 02:15 PM
switching grub from one hd to another... audibel Debian 6 03-26-2005 08:28 AM
Switching to GRUB from LILO tjtoed Linux - Software 4 11-02-2003 12:57 AM
Switching from LILO to GRUB magnusprime Mandriva 2 09-10-2003 06:09 AM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration