LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-18-2013, 07:46 PM   #1
dreamwalking
Member
 
Registered: Dec 2005
Distribution: Slackware 14
Posts: 106

Rep: Reputation: 29
Switching keyboard layouts - need some help


Hi,

I run Slack 14 with windowmaker as a window manager.

I had it configured to switch between English and Greek keyboard with alt_shift, which worked smoothly in all applications except terminal and gvim. Since I've occasionally needed to type in Greek in text editor or terminal, I decided to follow the instructions given in docs.slackware.com and edited the /etc/X11/xorg.conf.d/90-keyboard-layout.conf:
Quote:
Option "XkbLayout" "us,el"
#Option "XkbVariant" ""
Option "XkbOptions" "terminate:ctrl_alt_bksp"
Option "XKbOptions" "grp:alt_shift_toggle"
After restarting X, I could input Greek characters just fine, but I couldn't use alt_shift anymore to switch between layouts in any application (I had to manually click on the keyboard status button that wmaker adds to windows when its configured with --enable-modelock option).

That's about when I started to panic a bit and renamed the
/etc/X11/xorg.conf.d/90-keyboard-layout.conf file so that it doesn't get read and rebooted. After that, I haven't been able to switch keyboard layouts again, despite the fact that I define two different layouts in both my xorg.conf and x11-input.fdi. Putting back the 90-keyboard-layout.conf after all this, didn't make any difference either.

I'm not very computer-savvy and I don't have a clue where to start when it comes to troubleshooting - I'm certain that I messed up in something very basic here. I'd appreciate any pointers where to look or what I've been doing wrong.

Thanks in advance

my xorg.conf:
Quote:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us,el" #xkeymap0
Option "XkbOptions" "grp:alt_shift_toggle,caps:capslock,eurosign:e,numpadc,terminate:ctrl_alt_bksp"
EndSection
my /etc/hal/fdi/policy/x11-input.fdi
Quote:
<merge key="input.x11_options.XkbModel" type="string">pc102</merge>
<merge key="input.x11_options.XkbLayout" type="string">us,el</merge>
<merge key="input.x11_options.XkbOptions" type="string">grp:alt_shift_toggle</merge>

Last edited by dreamwalking; 02-18-2013 at 07:48 PM.
 
Old 02-19-2013, 06:27 AM   #2
dreamwalking
Member
 
Registered: Dec 2005
Distribution: Slackware 14
Posts: 106

Original Poster
Rep: Reputation: 29
Nevermind, I solved it.

Should not make changes late at night and then get all panicky when they don't work out...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching between keyboard layouts ganick Red Hat 2 12-18-2008 02:41 PM
switching between keyboard layouts trawler Linux - Software 1 10-22-2005 07:51 AM
Switching keyboard layouts jrdioko Linux - General 0 10-24-2004 03:07 PM
Switching between keyboard layouts ??? GloVe Linux - General 1 10-13-2003 11:26 AM
switching keyboard layouts linuxfond Linux - Newbie 1 05-28-2003 11:04 PM


All times are GMT -5. The time now is 08:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration