LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-28-2005, 09:58 AM   #1
Plice
LQ Newbie
 
Registered: Oct 2004
Posts: 17

Rep: Reputation: 0
Swedish keyboard


I'm using the Swedish keyboard layout but cannot manage to make tags like these < >, are they not mapped for the Swedish keyboard?
 
Old 05-29-2005, 03:27 AM   #2
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Hi!

Could you please post you /etc/X11/xorg.conf?. Basically, you've to add a few lines under Section "Input Device" in order to get Swedish keyboard layout. Here is a little example:

Code:
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"se"
EndSection
Just make sure to have "pc105" and "se" and you should be fine.

jag hoppas att du lyckas!
 
Old 05-31-2005, 04:22 PM   #3
Plice
LQ Newbie
 
Registered: Oct 2004
Posts: 17

Original Poster
Rep: Reputation: 0
Hello and thanks for the quick reply. I haven't been able to figure out how to do it yet, but here's my xorg.conf. It's a bit untidy but I've basically just modified the last couple of lines.


Section "InputDevice"
Identifier "Keyboard"
Driver "keyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "sv_SE"
EndSection


Last edited by Plice; 06-02-2005 at 12:26 PM.
 
Old 06-02-2005, 12:27 PM   #4
Plice
LQ Newbie
 
Registered: Oct 2004
Posts: 17

Original Poster
Rep: Reputation: 0
Here's the solution

xmodmap -e 'keycode 94 = less greater bar'
xmodmap -e 'keycode 65 = space bar'

The pipe can now be achieved with shift + space bar.

Last edited by Plice; 06-02-2005 at 01:03 PM.
 
Old 06-03-2005, 03:33 AM   #5
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 38
Skulle Option "XkbLayout" "sv_SE" ikke vre Option "XkbLayout" "se"? P dansk er det bare "dk".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD 5.3 - Swedish keyboard layout Mega Man X *BSD 6 12-20-2004 08:51 AM
Swedish LUGs Bebo Linux User Groups (LUG) 0 04-27-2004 12:24 PM
swedish keyboard in xfree86? Falafel Slackware 4 01-16-2004 10:21 PM
Swedish letters in java yper Slackware 0 12-20-2003 09:16 AM
Swedish keyboard + GNOME = no comma ziggamon Linux - Software 0 11-28-2003 02:38 PM


All times are GMT -5. The time now is 11:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration