LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-03-2010, 04:58 PM   #1
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 308

Rep: Reputation: 22
Question SW 13.1 strange XWindow configuration(XFCE and KDE simultaneously)


Hello

I have installed SL13.1 on my home PC week ago. Usually I do not use X often during my work and have not favour Desktop Environment so during post-install configuration step I selected XFCE as default one. After reboot I have tuned some network configurations, reinstalled LILO with shorter timeout, then started X using 'startx' to check if it works(starts at least). All works!

Yesterday I have booted SL and decided to tune-up XFCE. So I started it using 'telinit 4' command(do not touched any configurations yet). How I was surprised when I saw KDE desktop instead of XFCE!!! I returned back via 'telinit 3' to try again using `startx`. And XFCE started! But 'telinit 4' still starts KDE!

Question: did I missed something? Since when 'startx' and 'telinit 4' run different DEs? I newbie in configuration of X so I did not touched anything yet(and I do not know how to switch DE at all). Is that intended behaviour of Slackware 13.x?(Last time I used Slackware 12 based distribution with KDE so do not noticed such behaviour). I do not favour any of them, but I want always run one of them! What and where I should change to force start XFCE during 'telinit 4'?

Thanks for helping
 
Old 08-03-2010, 05:30 PM   #2
fbsduser
Member
 
Registered: Oct 2009
Distribution: Hackintosh, SlackWare
Posts: 266

Rep: Reputation: 30
Do you have KDM installed? If you do, maybe it have an init script in the runlevel 4 (telinit switches from the current runlevel to the one you indicate by appending a number to the telinit command). Basically KDM is the KDE login window, which by default loads KDE, and in your case it could be set to autologin. The reason why XFce gets started by startx is because startx doesn't invoque any login manager application, instead it runs whatever wm/DE is set in the ~/.xinitrc file (in your case that file was set to launch Xfce).
 
Old 08-04-2010, 02:52 AM   #3
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
That's perfectly normal.

KDE is the default WM for KDM and XDM irrespective of xwmconfig.
 
Old 08-04-2010, 03:31 AM   #4
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 308

Original Poster
Rep: Reputation: 22
fbsduser
Yes, kdm is installed(Because I did FULL installation.) Yes, rc.4 contains kdm probing (just after gdm probing). But when I selected XFCE during installation I thought installer should(or must) tune-up gdm/kdm/xdm configuration in order to respect my choice.

So, as I understood I should isolate KDM via something like 'chmod -x kdm' in order to allow XDM start? Or XDM will start KDE too?
 
Old 08-04-2010, 07:15 AM   #5
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
The SlackBook has all the details on how to choose XDM instead of KDM. My preferred way is to comment out the relevant line in rc.4.

Note that this will not change your default WM in runlevel4. You will still boot in KDE from XDM unless you hack with ~/.Xsession.

Note that Slack follows the UNIX way of doing things. If you install XFCE, you simply install XFCE not tune up KDM and XDM.
 
Old 08-12-2010, 05:08 AM   #6
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 308

Original Poster
Rep: Reputation: 22
Quote:
KDE is the default WM for KDM and XDM irrespective of xwmconfig.
Yes, kdm starts only kde. But xdm starts DE I pointed during post-install configuration.(Now I understand why most of users of my local Linux community hate KDE).
Quote:
Note that Slack follows the UNIX way of doing things. If you install XFCE, you simply install XFCE not tune up KDM and XDM.
I understood that. But I do not said anything about installation process. I said about configuration process: it does not configures kdm to start XFCE.(UNIX way of doing things). But now I understood this is not entirely configurators issue, but kdm's one(but I think it could do more in this case, for instance, comment out kdm probe in /etc/rc.d/rc.4 if KDE is not selected as default DE)

Anyway, thanks for answers.
 
Old 08-12-2010, 05:58 AM   #7
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,638
Blog Entries: 3

Rep: Reputation: 221Reputation: 221Reputation: 221
Oh Pat wrote a script for this a long time ago called pkgtools based on ncursur run it select setup select default window manager. choose xfce4 like you did in the install.
and startx will then point to xfce4.
I have no Idea how it was changed.
 
Old 10-28-2010, 10:12 PM   #8
fbsduser
Member
 
Registered: Oct 2009
Distribution: Hackintosh, SlackWare
Posts: 266

Rep: Reputation: 30
Quote:
Originally Posted by FeyFre
Yes, kdm starts only kde.
Actually. KDM can start any DE/WM as long as it have's a *.desktop file in /usr/share/xsessions (This is how the gnome *.desktop file looks like in my system)
Code:
[Desktop Entry]
Encoding=UTF-8
Name=GNOME
Name[az]=GNOME
Name[be]=GNOME
Name[ca]=GNOME
Name[cs]=GNOME
Name[cy]=GNOME
Name[da]=Gnome
Name[de]=GNOME
Name[el]=GNOME
Name[es]=GNOME
Name[et]=GNOME
Name[fi]=Gnome
Name[fr]=GNOME
Name[he]=GNOME
Name[hi]=गनोम
Name[hu]=GNOME
Name[it]=GNOME
Name[ja]=GNOME
Name[ko]=그놈
Name[lt]=GNOME
Name[mn]=ГНОМЕ
Name[ms]=GNOME
Name[nl]=GNOME
Name[nn]=GNOME
Name[no]=GNOME
Name[pl]=GNOME
Name[pt]=GNOME
Name[pt_BR]=GNOME
Name[ro]=GNOME
Name[ru]=GNOME
Name[sk]=GNOME
Name[sl]=GNOME
Name[sq]=GNOME
Name[sr]=Гном
Name[sr@Latn]=Gnom
Name[sv]=GNOME
Name[tr]=GNOME
Name[uk]=GNOME
Name[vi]=GNOME
Name[wa]=GNOME
Name[zh_CN]=GNOME
Name[zh_TW]=GNOME
Comment=This session logs you into GNOME
Comment[az]=Bu iclas sizi GNOME'a daxil edəcək
Comment[be]=Гэтая сэсыя завядзе вас у GNOME
Comment[ca]=Aquesta sessi entra en GNOME
Comment[cs]=Toto sezen vs přihls do GNOME
Comment[cy]=Mae'r sesiwn hwn yn eich mewngofnodi i GNOME
Comment[da]=Denne session logger dig p Gnome
Comment[de]=Diese Sitzung meldet Sie an GNOME an
Comment[el]=Αυτή η συνεδρία σας εισάγει στο GNOME
Comment[es]=Con esta sesin accede a GNOME
Comment[fi]=Tm istunto kirjaa sisn Gnomeen
Comment[fr]=Cette session vous connectera dans GNOME
Comment[he]=תצורת הפעלה זו מחברת אותך ל GNOME
Comment[hi]=यह सत्र गनोम में लॉगिन होगा
Comment[hu]=Ez a krnyezet a GNOME-ba jelentkeztet be
Comment[it]=Sessione di lavoro con GNOME
Comment[ja]=GNOME セッションにログインします
Comment[ko]=GNOME세션으로 로그인합니다
Comment[lt]=Ši sesija prijungia Jus į GNOME
Comment[mn]=Энэ суултаар та ГНОМЕ руу нэвтрэнэ.
Comment[ms]=Sesi ini akan log anda  ke GNOME
Comment[nl]=Deze sessie meldt u aan bij GNOME
Comment[nn]=Denne kta loggar p GNOME
Comment[no]=Denne sesjonen logger deg inn til GNOME
Comment[pl]=Sesja logowania do GNOME
Comment[pt]=Esta sesso inicia-o no GNOME
Comment[pt_BR]=Logar no ambiente GNOME
Comment[ro]=Această sesiune vă va loga n GNOME
Comment[ru]=Начать сеанс GNOME
Comment[sk]=Toto sedenie vs prihlsi do prostredia GNOME
Comment[sl]=Ta seja vas prijavi v GNOMe
Comment[sq]=Kjo seanc do t'ju fus n GNOME
Comment[sr]=Ова сесија вас пријављује на Гнома
Comment[sr@Latn]=Ova sesija vas prijavljuje na Gnoma
Comment[sv]=Denna session loggar in dig i GNOME
Comment[tr]=Bu oturum ile GNOME'a giriş yaparsınız
Comment[uk]=Сеанс роботи в середовищі GNOME
Comment[vi]=Session ny cho bạn đăng nhập vo GNOME
Comment[zh_CN]=此会话使您登录到 GNOME
Comment[zh_TW]=選取這個作業階段後會進入 GNOME 環境
Exec=/usr/bin/gnome-session
# no icon yet, only the top three are currently used
Icon=
Type=Application
The detail is that to log into whatever DE you want you need to select it (and make it the default session) in the login screen itself (you'll need to disable autologin to do this).
 
  


Reply

Tags
kde, slackware, startx, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Debian KDE XWindow Remaining Open bruceam Debian 3 07-18-2009 09:31 PM
GNOME + KDE Simultaneously! vasmakk Linux - Newbie 7 02-04-2009 07:38 AM
re-run the configuration for xwindow NanoFxJ Linux - Software 2 03-24-2005 07:33 PM
How to start xcin and KDE simultaneously satimis *BSD 0 04-08-2004 04:47 AM
xwindow configuration problem bobygeorge15 Linux - General 0 07-25-2003 02:22 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration