LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   svn MPlayer slackbuild script: r29363 changes = no more docs (http://www.linuxquestions.org/questions/slackware-14/svn-mplayer-slackbuild-script-r29363-changes-%3D-no-more-docs-733734/)

andrew.46 06-17-2009 07:07 PM

svn MPlayer slackbuild script: r29363 changes = no more docs
 
Hi,

There has been a recent change in the generation of docs with the svn MPlayer:

Code:

------------------------------------------------------------------------
r29364 | diego | 2009-06-15 04:51:36 +1000 (Mon, 15 Jun 2009) | 4 lines

100l: Add missing $s to default language variable checks, which prevented
fallback language settings from taking effect.
patch by Francesco Lavra, francescolavra interfree it

------------------------------------------------------------------------
r29363 | diego | 2009-06-15 00:55:01 +1000 (Mon, 15 Jun 2009) | 3 lines

Overhaul translation handling completely and add options to install specific
documentation and man page translations.

The effect of this seems to be that the slackbuild script I have pillaged from slackbuilds.org / slackware -current will not generate the html docs or man pages for me after this revision. A fair price for living on the cutting edge I guess :-).

Has anyone had a look at this? I have had a look at the changes to configure but I do not understand how this has lead to my system failing to generate the docs.

Andrew

andrew.46 06-17-2009 11:02 PM

OK I am using a really ugly hack that at least gets the program compiled:

Code:

# ---------------------------------
# Configure / make / make install.
#----------------------------------

./configure \
  --prefix=/usr \
  --mandir=/usr/man \
  --confdir=/etc/mplayer \
  --codecsdir=/usr/lib/codecs

sed -i -e 's/DOC_LANGS =/DOC_LANGS = en/' -e 's/MAN_LANGS =/MAN_LANGS = en/' config.mak

make
make install DESTDIR=$PKG

just until I can find a solution for the auto-detection thing :-).

Andrew

andrew.46 06-20-2009 07:52 AM

Memo to self: wait a week before whining about MPlayer problems:

Code:

------------------------------------------------------------------------
r29372 | diego | 2009-06-20 01:20:59 +1000 (Sat, 20 Jun 2009) | 3 lines

Fix setting of DOC_LANGS and MAN_LANGS, the wrong variables were being used.
This makes XML documentation generation work again.

Andrew


All times are GMT -5. The time now is 02:44 PM.