LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Suspend to ram ( sleep) does not work on my Slackware64-current multilib (http://www.linuxquestions.org/questions/slackware-14/suspend-to-ram-sleep-does-not-work-on-my-slackware64-current-multilib-4175478885/)

afreitascs 09-28-2013 12:21 PM

Suspend to ram ( sleep) does not work on my Slackware64-current multilib
 
I use slackware-current 64bit multilib updated .

well ...

If I click on kde application launcher from sleep, sleep my pc starts and ends, but soon after it gets October It does not stay sleep! The screen goes black.

I am forced to cold reboot by reset button.

my /var/log/pm-suspend.log
PHP Code:

Initial commandline parameters
Fri Sep 27 18:28:20 BRT 2013Running hooks for suspend.
Running hook /usr/lib64/pm-utils/sleep.d/00logging suspend suspend:
Linux base1 3.10.12 #2 SMP Sun Sep 15 00:05:24 CDT 2013 x86_64 AMD Phenom(tm) II X4 910 Processor AuthenticAMD GNU/Linux
Module                  Size  Used by
rfcomm                 32551  4 
bnep                   10631  2 
bluetooth             220711  10 bnep
,rfcomm
ipv6                  291951  0 
it87                   28175  0 
hwmon_vid               3188  1 it87
cpufreq_ondemand        8799  4 
lp                      9851  0 
fuse                   73624  7 
hid_generic             1145  0 
snd_hda_codec_via      19806  1 
i2c_dev                 5843  0 
sp5100_tco              5040  0 
usbhid                 37112  0 
hid                    86434  2 hid_generic
,usbhid
nvidia               9322065  39 
rt61pci                21887  0 
rt2x00pci               2584  1 rt61pci
rt2x00mmio              2801  1 rt61pci
rt2x00lib              37031  3 rt61pci
,rt2x00pci,rt2x00mmio
eeprom_93cx6            2145  1 rt61pci
mac80211              429519  2 rt2x00lib
,rt2x00pci
drm                   229086  2 nvidia
acpi_cpufreq            7230  1 
mperf                   1163  1 acpi_cpufreq
agpgart                27267  1 drm
ppdev                   5862  0 
kvm_amd                50223  0 
atl1c                  34970  0 
parport_pc             19332  1 
snd_hda_intel          34861  2 
snd_hda_codec         143196  2 snd_hda_codec_via
,snd_hda_intel
kvm                   363587  1 kvm_amd
parport                30389  3 lp
,ppdev,parport_pc
snd_hwdep               6388  1 snd_hda_codec
processor              27543  1 acpi_cpufreq
i2c_piix4               8415  0 
thermal_sys            22993  1 processor
snd_pcm                76009  2 snd_hda_codec
,snd_hda_intel
snd_page_alloc          7098  2 snd_pcm
,snd_hda_intel
snd_timer              18614  1 snd_pcm
cfg80211              380292  2 mac80211
,rt2x00lib
rfkill                 15522  4 cfg80211
,bluetooth
ehci_pci                3688  0 
freq_table              2628  3 cpufreq_ondemand
,acpi_cpufreq,thermal_sys
evdev                  10032  5 
ohci_hcd               23892  0 
wmi                     8243  0 
i2c_core               20936  4 drm
,i2c_dev,i2c_piix4,nvidia
k10temp                 3010  0 
hwmon                   1337  3 it87
,k10temp,thermal_sys
snd                    58630  10 snd_hwdep
,snd_timer,snd_hda_codec_via,snd_pcm,snd_hda_codec,snd_hda_intel
ehci_hcd               39275  1 ehci_pci
button                  4696  0 
soundcore               5354  1 snd
microcode              13140  0 
loop                   18479  0 
             total       used       free     shared    buffers     cached
Mem
:       4036844    1335384    2701460          0      83220     528872
-/+ buffers/cache:     723292    3313552
Swap
:      6796284          0    6796284
/usr/lib64/pm-utils/sleep.d/00logging suspend suspendsuccess.

Running hook /usr/lib64/pm-utils/sleep.d/00powersave suspend suspend:
/
usr/lib64/pm-utils/sleep.d/00powersave suspend suspendsuccess.

Running hook /usr/lib64/pm-utils/sleep.d/01grub suspend suspend:
/
usr/lib64/pm-utils/sleep.d/01grub suspend suspendnot applicable.

Running hook /usr/lib64/pm-utils/sleep.d/49bluetooth-generic suspend suspend:
/
usr/lib64/pm-utils/sleep.d/49bluetooth-generic suspend suspendsuccess.

Running hook /usr/lib64/pm-utils/sleep.d/49bluetooth-ibm suspend suspend:
/
usr/lib64/pm-utils/sleep.d/49bluetooth-ibm suspend suspendnot applicable.

Running hook /usr/lib64/pm-utils/sleep.d/75modules suspend suspend:
/
usr/lib64/pm-utils/sleep.d/75modules suspend suspendnot applicable.

Running hook /usr/lib64/pm-utils/sleep.d/90clock suspend suspend:
/
usr/lib64/pm-utils/sleep.d/90clock suspend suspendnot applicable.

Running hook /usr/lib64/pm-utils/sleep.d/94cpufreq suspend suspend:
/
usr/lib64/pm-utils/sleep.d/94cpufreq suspend suspendsuccess.

Running hook /usr/lib64/pm-utils/sleep.d/95led suspend suspend:
/
usr/lib64/pm-utils/sleep.d/95led suspend suspendnot applicable.

Running hook /usr/lib64/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
nVidia binary video drive detectednot using quirks.
/
usr/lib64/pm-utils/sleep.d/98video-quirk-db-handler suspend suspendsuccess.

Running hook /usr/lib64/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags 0
/usr/lib64/pm-utils/sleep.d/99video suspend suspendsuccess.

Fri Sep 27 18:28:21 BRT 2013performing suspend 

my lsmod

PHP Code:

#lsmod

Module                  Size  Used by
rfcomm                 32551  4 
pci_stub                1373  1 
vboxpci                14485  0 
vboxnetadp             18355  0 
vboxnetflt             17452  0 
vboxdrv              1821046  3 vboxnetadp
,vboxnetflt,vboxpci
ipt_REJECT              2337  1 
iptable_filter          1480  1 
ip_tables              16674  1 iptable_filter
x_tables               16383  3 ip_tables
,iptable_filter,ipt_REJECT
bnep                   10631  2 
bluetooth             220711  10 bnep
,rfcomm
ipv6                  291951  0 
it87                   28175  0 
hwmon_vid               3188  1 it87
cpufreq_ondemand        8799  4 
lp                      9851  0 
fuse                   73624  7 
hid_generic             1145  0 
usbhid                 37112  0                                                                                                       
hid                    86434  2 hid_generic
,usbhid                                                                                    
ppdev                   5862  0                                                                                                       
snd_hda_codec_via      19806  1                                                                                                       
snd_hda_intel          34861  2                                                                                                       
nvidia               9322065  39                                                                                                      
i2c_dev                 5843  0                                                                                                       
parport_pc             19332  1                                                                                                       
sp5100_tco              5040  0                                                                                                       
snd_hda_codec         143196  2 snd_hda_codec_via
,snd_hda_intel                                                                       
snd_hwdep               6388  1 snd_hda_codec                                                                                         
snd_pcm                76009  2 snd_hda_codec
,snd_hda_intel                                                                           
acpi_cpufreq            7230  1                                                                                                       
mperf                   1163  1 acpi_cpufreq                                                                                          
i2c_piix4               8415  0 
processor              27543  1 acpi_cpufreq
rt61pci                21887  0 
rt2x00pci               2584  1 rt61pci
rt2x00mmio              2801  1 rt61pci
rt2x00lib              37031  3 rt61pci
,rt2x00pci,rt2x00mmio
drm                   229086  2 nvidia
agpgart                27267  1 drm
eeprom_93cx6            2145  1 rt61pci
mac80211              429519  2 rt2x00lib
,rt2x00pci
ohci_hcd               23892  0 
ehci_pci                3688  0 
ehci_hcd               39275  1 ehci_pci
kvm_amd                50223  0 
snd_page_alloc          7098  2 snd_pcm
,snd_hda_intel
snd_timer              18614  1 snd_pcm
evdev                  10032  5 
atl1c                  34970  0 
snd                    58630  10 snd_hwdep
,snd_timer,snd_hda_codec_via,snd_pcm,snd_hda_codec,snd_hda_intel
i2c_core               20936  4 drm
,i2c_dev,i2c_piix4,nvidia
thermal_sys            22993  1 processor
wmi                     8243  0 
kvm                   363587  1 kvm_amd
parport                30389  3 lp
,ppdev,parport_pc
k10temp                 3010  0 
freq_table              2628  3 cpufreq_ondemand
,acpi_cpufreq,thermal_sys
cfg80211              380292  2 mac80211
,rt2x00lib
rfkill                 15522  4 cfg80211
,bluetooth
soundcore               5354  1 snd
microcode              13140  0 
button                  4696  0 
hwmon                   1337  3 it87
,k10temp,thermal_sys
loop                   18479  0 

My Hardware


motherboard Asus --- M4A78LT-M LE
Cpu --- AMD Phenom(tm) II X4 910
mouse usb simple
keyboard --- abnt2 -- basic
nvidia card 9500 GT
2 sata hdd 500G
Kingston memory 4G (2x2G)
PSU Antec Neo Eco 400C

The problem started happening after updating slackware-current, can not remember which. I know it was one of the last updates.

note:
I did a clean install without multilib slackware-current, on another partition of my HDD, same issue .


Any help thanks


resolved


The problem is my usb mouse, which makes the system not wake up !!!

Skaperen 09-28-2013 08:04 PM

Interesting. When I boot up with a USB mouse plugged in, the system does not see it. If I plug in the USB mouse after booting up, it will see that. I wonder if your problem and mine are connected.

afreitascs 09-29-2013 02:37 PM

Quote:

Originally Posted by Skaperen (Post 5036587)
Interesting. When I boot up with a USB mouse plugged in, the system does not see it. If I plug in the USB mouse after booting up, it will see that. I wonder if your problem and mine are connected.

In my case it is something related to some of the latest updates, as previously this issue did not happen ...

Thanks

afreitascs 10-20-2013 08:43 PM

I marked the topic as solved, but in fact it was actually solved by updating the bios.

thanks

andrewthomas 10-20-2013 09:15 PM

Quote:

Originally Posted by afreitascs (Post 5049346)
I marked the topic as solved, but in fact it was actually solved by updating the bios.

thanks

Try to avoid updating your BIOS if you can. On one machine, I have lost the ability to boot ISOLINUX discs, I needed to update the BIOS in this case to support a new CPU, but there was a price to pay.

afreitascs 10-20-2013 11:27 PM

Quote:

Originally Posted by andrewthomas (Post 5049361)
Try to avoid updating your BIOS if you can. On one machine, I have lost the ability to boot ISOLINUX discs, I needed to update the BIOS in this case to support a new CPU, but there was a price to pay.

Thanks for the warning, indeed serves as a warning that a bad BIOS update done, can prevent the motherboard to start.

Skaperen 10-21-2013 12:10 AM

Quote:

Originally Posted by andrewthomas (Post 5049361)
Try to avoid updating your BIOS if you can. On one machine, I have lost the ability to boot ISOLINUX discs, I needed to update the BIOS in this case to support a new CPU, but there was a price to pay.

I would like to know who provided that BIOS. I wonder if that will break other boot loaders like EXTLINUX.

andrewthomas 10-22-2013 07:16 PM

Quote:

Originally Posted by Skaperen (Post 5049399)
I would like to know who provided that BIOS. I wonder if that will break other boot loaders like EXTLINUX.

I hate to say that it was an ASUS motherboard. The damn tech just said that not enough people use Linux to justify a re-write of the offending code.

Here is part of one e-mail

Quote:

Originally Posted by Jack1 He (tsd AT asus.com.tw)
Re:<TSD> Motherboard M3A32-MVP DELUXE/WIFI-AP [ID=RWTM2011070509294825-713]
After updating BIOS, please load default the BIOS setting for a try.
If the issue still remains, please consider to re-install a new clear OS and test again.
As the motherboard does not support Linux formally, if possible, please install a Windows OS for a further check.
Otherwise, please try to downgrade the BIOS, but we could not guarantee that it would be successful. 100%


vivanguarda 10-23-2013 10:32 AM

I have been used Asus motherboard since 2008 and no Linux ( Slackware ) problem.

andrewthomas 10-23-2013 08:26 PM

Quote:

Originally Posted by vivanguarda (Post 5050936)
I have been used Asus motherboard since 2008 and no Linux ( Slackware ) problem.

I am not saying ASUS is bad. My last 4 motherboards have been ASUS boards. It was just 1 bad update that I wish that I wouldn't have done. I would have been better off with the new CPU in a different mb. But oh well, live and learn. I have actually bought another ASUS board since this problem.


All times are GMT -5. The time now is 03:33 PM.