LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-03-2012, 01:47 PM   #1
Sli
LQ Newbie
 
Registered: Nov 2012
Posts: 17

Rep: Reputation: Disabled
Suspend - reboots on resume


Hi everyone,

When I try to suspend to RAM, the computer reboots on resume (Sony VGN-FW480J, running Slackware 14.0 - 64 bit). I had the same issue in Arch linux and the issue was fixed by changing the following line in /etc/default/grub

Code:
GRUB_CMDLINE_LINUX=""
to

Code:
GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"
What should I do to correct this pm-suspend error in Lilo?

Thank you.
 
Old 11-03-2012, 05:16 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hi, here the section from my lilo.conf:
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  initrd = /boot/initrd.gz
  append = "resume=/dev/sda9"
  root = /dev/sda5
  label = Slack64-current
  read-only
If you use the generic kernel you'll have a line like this in your mkinitrd.conf
Code:
RESUMEDEV="/dev/sda9"
Could you please describe in detail how you've configured for suspend in Slackware?

Markus

Last edited by markush; 11-03-2012 at 05:17 PM.
 
Old 11-04-2012, 10:17 AM   #3
Sli
LQ Newbie
 
Registered: Nov 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
I have not done anything special to configure suspend in Slackware. It's a fresh install with XFCE and I believe that the XFCE menu uses pm-utils to suspend, hibernate, etc.

I added the line to lilo.conf which did not make a difference. I don't currently have a a mkinitrd.conf (only /etc/mkinitrd.conf.sample). Should I just copy the mkinitrd.conf.sample to mkinitrd.conf, and, if so, which lines should I uncomment?

This is the advice from the arch wiki that I used to get suspend to work:

https://wiki.archlinux.org/index.php/Pm-utils#Reboot_instead_of_resume_from_suspend


Quote:
Reboot instead of resume from suspend

This problem started when saving NVS area during suspend was introduced (in 2.6.35-rc4) (mailing list post). However, it is known that this mechanism does not work on all machines, so the kernel developers allow the user to disable it with the help of the acpi_sleep=nonvs kernel command line option. This option could be pass to the kernel through GRUB options by editing the file /boot/grub/menu.lst (GRUB 0.97) on the kernel line.
 
Old 11-04-2012, 10:26 AM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
If you don't use the generic kernel you don't need an initrd and therefore no mkinitrd.conf.

In your lilo.conf add
Code:
append="acpi_sleep=nonvs"
or if you have already a line with append, you can add this command (separated with a <SPACE>). There's a manpage for lilo.conf.

An explanation of the kernel-parameters is here: http://www.kernel.org/doc/Documentat...parameters.txt

Markus

Last edited by markush; 11-04-2012 at 10:27 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] upgraded kernel from 2.30 to 2.32: resume reboots computer rdozijn_2 Debian 45 10-19-2011 04:17 PM
[SOLVED] Why do nVida drivers hose suspend/resume or hibernate/resume? taylorkh Linux - Hardware 3 06-23-2011 01:09 PM
can't resume after suspend newbiesforever Linux - General 1 08-26-2009 06:52 AM
Suspend Fails to Resume dengel Linux - Laptop and Netbook 0 11-27-2005 08:58 AM
No resume from suspend mehlkelm Debian 3 11-22-2005 10:48 AM


All times are GMT -5. The time now is 12:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration