LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Suspend - reboots on resume (http://www.linuxquestions.org/questions/slackware-14/suspend-reboots-on-resume-4175435483/)

Sli 11-03-2012 02:47 PM

Suspend - reboots on resume
 
Hi everyone,

When I try to suspend to RAM, the computer reboots on resume (Sony VGN-FW480J, running Slackware 14.0 - 64 bit). I had the same issue in Arch linux and the issue was fixed by changing the following line in /etc/default/grub

Code:

GRUB_CMDLINE_LINUX=""
to

Code:

GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"
What should I do to correct this pm-suspend error in Lilo?

Thank you.

markush 11-03-2012 06:16 PM

Hi, here the section from my lilo.conf:
Code:

# Linux bootable partition config begins
image = /boot/vmlinuz
  initrd = /boot/initrd.gz
  append = "resume=/dev/sda9"
  root = /dev/sda5
  label = Slack64-current
  read-only

If you use the generic kernel you'll have a line like this in your mkinitrd.conf
Code:

RESUMEDEV="/dev/sda9"
Could you please describe in detail how you've configured for suspend in Slackware?

Markus

Sli 11-04-2012 11:17 AM

I have not done anything special to configure suspend in Slackware. It's a fresh install with XFCE and I believe that the XFCE menu uses pm-utils to suspend, hibernate, etc.

I added the line to lilo.conf which did not make a difference. I don't currently have a a mkinitrd.conf (only /etc/mkinitrd.conf.sample). Should I just copy the mkinitrd.conf.sample to mkinitrd.conf, and, if so, which lines should I uncomment?

This is the advice from the arch wiki that I used to get suspend to work:

https://wiki.archlinux.org/index.php/Pm-utils#Reboot_instead_of_resume_from_suspend


Quote:

Reboot instead of resume from suspend

This problem started when saving NVS area during suspend was introduced (in 2.6.35-rc4) (mailing list post). However, it is known that this mechanism does not work on all machines, so the kernel developers allow the user to disable it with the help of the acpi_sleep=nonvs kernel command line option. This option could be pass to the kernel through GRUB options by editing the file /boot/grub/menu.lst (GRUB 0.97) on the kernel line.

markush 11-04-2012 11:26 AM

If you don't use the generic kernel you don't need an initrd and therefore no mkinitrd.conf.

In your lilo.conf add
Code:

append="acpi_sleep=nonvs"
or if you have already a line with append, you can add this command (separated with a <SPACE>). There's a manpage for lilo.conf.

An explanation of the kernel-parameters is here: http://www.kernel.org/doc/Documentat...parameters.txt

Markus


All times are GMT -5. The time now is 01:17 AM.