LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-30-2007, 01:30 AM   #1
tux_addict
Member
 
Registered: Dec 2004
Location: Nairobi, Kenya
Distribution: Vector Linux 7.0, Ubuntu 13.04
Posts: 87

Rep: Reputation: 15
Suspend for Hibernation (TIOCL_SETKMSGREDIRECT)


I am trying to get suspend/hibernation working on a Toshiba Satellite Pro 4200. When I try to build suspend (http://suspend.sourceforge.net/) using `make s2diskí, I get the following message:

cc -g -O2 -Wall -I/usr/local/include vt.o md5.o encrypt.o config.o suspend.c -o s2disk splash.o bootsplash.o -L/usr/local/lib

suspend.c: In function `prepare_console':

suspend.c:932: error: `TIOCL_SETKMSGREDIRECT' undeclared (first use in this function)

suspend.c:932: error: (Each undeclared identifier is reported only once

suspend.c:932: error: for each function it appears in.)

suspend.c: In function `restore_console':

suspend.c:971: error: `TIOCL_SETKMSGREDIRECT' undeclared (first use in this function)

make: *** [s2disk] Error 1

What on earth does it mean? What can I do to solve the problem? I am running Slackware 11.0 on a 2.6.17 kernel. I have enabled most of the ACPI options in the kernel. Has anyone managed to get userspace suspend working? Help appreciated as always!
 
Old 01-30-2007, 03:08 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
You need to install the kernel-headers package for the 2.6 kernel if you want to compile this.
For Slackware 11.0, that package is located at /extra/linux-2.6.17.13/kernel-headers-2.6.17.13-i386-1.tgz

Eric
 
Old 02-02-2007, 03:13 AM   #3
tux_addict
Member
 
Registered: Dec 2004
Location: Nairobi, Kenya
Distribution: Vector Linux 7.0, Ubuntu 13.04
Posts: 87

Original Poster
Rep: Reputation: 15
Using apm instead

Alien Bob, thanks for the suggestion, but no luck with that. I'm still getting the same message. Might this have something to do with the fact that I recompiled my kernel? If so, should I rebuild the kernel headers and how do I go about this?

In the meantime, I disabled ACPI by passing the acpi=off option in the Grub menu so I am now using APM. I can now suspend to RAM by using the command `/usr/bin/apm -sí. Works like a charm. Of course you cannot save the session to disk.
 
Old 02-10-2007, 03:50 AM   #4
tux_addict
Member
 
Registered: Dec 2004
Location: Nairobi, Kenya
Distribution: Vector Linux 7.0, Ubuntu 13.04
Posts: 87

Original Poster
Rep: Reputation: 15
After a bit of Googling, I found out that the kernel headers should be in the /usr/src/linux directory; but I still havenít figured out how to get Suspend to compile without errors...
 
Old 05-15-2007, 01:34 AM   #5
tux_addict
Member
 
Registered: Dec 2004
Location: Nairobi, Kenya
Distribution: Vector Linux 7.0, Ubuntu 13.04
Posts: 87

Original Poster
Rep: Reputation: 15
This from the Debian 4.0 Debian Reference document, Chapter 7, The Linux Kernel Under Debian:

Quote:
Most "normal" programs don't need kernel headers and in fact may break if you use them directly...

...If you need particular kernel headers for some kernel-specific application programs, alter the makefile(s) so that their include path points to directory-of-particular-kernel-headers/include/linux and directory-of-particular-kernel-headers/include/asm.
I havenít tried it yet, but if anyone out there is able to make a go of it, please let us know!
 
Old 05-15-2007, 03:42 AM   #6
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Firstly try Slackware kernel and it's kernel headers.
 
Old 05-17-2007, 02:45 AM   #7
tux_addict
Member
 
Registered: Dec 2004
Location: Nairobi, Kenya
Distribution: Vector Linux 7.0, Ubuntu 13.04
Posts: 87

Original Poster
Rep: Reputation: 15
Whole lot of aliens in here!
Quote:
Firstly try Slackware kernel and it's kernel headers.
Ofcourse, one would have to use the kernel headers in Slackware.
 
Old 05-17-2007, 10:52 AM   #8
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Sh*t I meant try default (2.4) kernel and it's headers


There is difference between different kernel version headers.
If you compile new version kernel, use new kernel version headers.


About aliens, yes, there are. Lot of meanings this word has.

Last edited by Alien_Hominid; 05-17-2007 at 10:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hibernation EdwardH Linux - Newbie 0 08-15-2005 12:57 PM
hibernation joshknape Linux - Newbie 5 07-26-2005 12:13 AM
Hibernation jfranks214 Linux - Laptop and Netbook 2 08-15-2004 12:50 PM
Hibernation (Oh no - not again...) Napper Mandriva 9 06-23-2004 08:41 AM
Hibernation and suspend to disk Slasher Linux - General 19 11-11-2003 10:53 PM


All times are GMT -5. The time now is 06:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration