LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-17-2011, 05:37 PM   #1
pigkouinos
LQ Newbie
 
Registered: May 2011
Posts: 15

Rep: Reputation: 10
Suspend doesn't work after hardware upgrade


I had a Slackware64 13.37 desktop system where suspend worked flawlessly. After I did a hardware upgrade (mobo-cpu-ram), and made a clean install, suspend doesn't work, nor within KDE, or via the command 'pm-suspend'.

What do I mean by "desn't work":
In my previous system everything seemed to be turned off, the tower's power led was blinking and when I pressed the power button the machine resumed as expected. After the upgrade, I choose "suspend to RAM", the screen goes off (as expected), but the machine remains on (at least you can hear the cpu fan spinning), the power led remains on, nothing can wake the machine back from sleep, so I have to hard-reset.

I use the same NVIDIA card as before (I read somewhere that often it has something to do with the graphics card), with the same proprietary drivers (the latest). My system is vanilla Slackware (no custom kernels or anything). Switching between huge kernel and generic with initrd doesn't change a thing. Maybe it has something to with RAM? I upgraded from 2GB DDR to 8GB DDR2. Or a kernel issue?

Last edited by pigkouinos; 08-18-2011 at 04:36 AM. Reason: mobo uses ddr2 not ddr3 ram
 
Old 08-17-2011, 05:52 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
It would help if you tell us which motherboard is in the machine. I often found that the settings for the suspend-mode in the BIOS are set to S1 instead of S3 by default. This would explain why your machine isn't turning off, but sadly not why it isn't turning on when it should be.
 
Old 08-18-2011, 02:55 AM   #3
pigkouinos
LQ Newbie
 
Registered: May 2011
Posts: 15

Original Poster
Rep: Reputation: 10
Hi, sorry I didn't mention that... Motherboard is "Asus M2N-SLI Deluxe" and I've already checked the suspend mode. It defaults to S3, and I've tried the other two available options ("S1" and "S1 & S3") just in case (didn't know the difference between suspend modes). So, yeah the problem remains.
 
Old 08-18-2011, 07:53 AM   #4
sparkyhall
Member
 
Registered: Nov 2009
Location: Chatteris---UK
Distribution: Slackware 13.0 & 14.0
Posts: 41

Rep: Reputation: 7
I would have a look for clues in the pm-suspend log on /var/log/
 
Old 08-18-2011, 08:53 AM   #5
pigkouinos
LQ Newbie
 
Registered: May 2011
Posts: 15

Original Poster
Rep: Reputation: 10
found the problem...

Guys, thank you very much for taking the time. In the end, the problem was solved by upgrading my BIOS. Suspend works flawlessly now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hibernate/Suspend doesn't work ibrahim52 Linux - Newbie 14 08-10-2011 09:39 PM
Suspend does not work correctly - Do I need new hardware or a new distro? taylorkh Ubuntu 7 01-21-2011 08:52 AM
looking for hardware reasons why suspend and hibernation don't work newbiesforever Linux - General 7 07-09-2010 06:05 PM
Suspend doesn't work on any linux distro Enry211 Linux - Laptop and Netbook 3 03-28-2010 08:56 AM
wirless iwl3945 doesn't work after suspend zux Slackware 11 12-06-2008 09:33 AM


All times are GMT -5. The time now is 12:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration