LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-15-2011, 08:08 PM   #1
0men
Member
 
Registered: Mar 2011
Location: Gold Coast, Australia
Distribution: saline, centos, freeBSD, slackware
Posts: 180

Rep: Reputation: 22
Sudo doesn't care for passwords :S (13.1, xfce)


Hi guys,

I have this really strange problem that i've never had before. Im using Slackware 13.1, with XFCE. The system was just installed on my laptop, and has not been connected to the internet. My user '0men' is in the sudoers file.

Here's whats going on....
Say i want to edit my firewall, i would do

sudo nano /etc/rc.d/rc.firewall
Password: MyPassword

That's normal the first time but .. From now on, Sudo doesn't care about my password. I can edit any file from now on without my password. I was reading up and i found some patchy information that stated sudo normally 'hangs' around for 10 minutes or so.

However if i close the terminal and leave the machine for half an hour and then try and edit the same file. Sudo will still not ask for a password.
This is strange and i've never had it happen on a Slackware machine before. Just to be sure, i re-installed, still the same problem though. None of the other 3 Slackware box's i have here, have experienced the problem.

Does anyone have any ideas ? Its really starting to do my head in !
I appreciate any help/input/experiences/solutions you may have.

Thanks!
what would i do without LQ !!
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 09-15-2011, 08:35 PM   #2
user7
LQ Newbie
 
Registered: Nov 2010
Location: Canada
Distribution: anything with a linux or bsd kernel
Posts: 7

Rep: Reputation: 3
Two things you can do
Code:
sudo -k su -
This will force sudo to ask for password next time.

Other option is change it in the sudo config.
As root:
Code:
# visudo
Find the defaults line and using a comma to separate add timestamp_timeout=X where X=timout in mins.
Code:
Defaults        env_reset,timestamp_timeout=0
This would cause it to ask every time.
 
3 members found this post helpful.
Old 09-15-2011, 08:36 PM   #3
0men
Member
 
Registered: Mar 2011
Location: Gold Coast, Australia
Distribution: saline, centos, freeBSD, slackware
Posts: 180

Original Poster
Rep: Reputation: 22
Bizarre :S

I un-installed each package one by one to see if things went back to normal. When i uninstalled acpica, everything came good again. I then re-installed the package and now it's fine :S Maybe it had to be installed last... No idea. But its back to normal now sudo asks for password. Thank God.

Thankyou everyone for taking the time to look over the thread.
And sorry to clutter it up.

Kind Regards.

Edit: @user7 Thanks, i was not aware of that. Legend. Thankyou for your reply !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sudo passwords sunnieside-up Linux - Security 7 09-01-2011 11:52 PM
Perl Expect Module to give passwords for remote sudo commands vikas027 Programming 8 06-02-2011 04:12 AM
MySQL doesn't like passwords legendaryfox Linux - Software 12 03-09-2009 04:36 PM
XFce and Compiz : xfce doesn't manage the desktop naaman Linux - Desktop 0 07-16-2008 01:39 AM
LXer: Microsoft Doesn't Care About Destroying Linux LXer Syndicated Linux News 0 07-02-2007 10:31 AM


All times are GMT -5. The time now is 09:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration