LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2012, 08:59 PM   #1
mongoosecage
Member
 
Registered: Jun 2008
Distribution: Slackware 13.0, Ubuntu 9.10, Windows XP Pro SP3
Posts: 100

Rep: Reputation: 15
sudden hanging , black screen with "-"


Recently, I have encountered a strange problem. Yesterday, I was trying to get libreoffice (after alienBOB and SlackBuild, still errors in compiling, another issue) through the internet. On two occasions I had caught my computer with a black screen and a "-" on the top left hand corner. The LEDs for HDD and WLAN were still flashing but there was no way to get it out of that black screen and I had to hard reset.

As I am typing this, I am suspecting my graphic card to be the problem. It never seems to happen when I am using the computer, always occurs whenever I go away. Obviously that is where the 3D screensaver shows up. But the graphic screensaver does work when it isn't hanging.

Could the graphics card be the problem? Anyone experienced this before?
 
Old 01-15-2012, 11:42 PM   #2
MadMaverick9
Member
 
Registered: Aug 2010
Location: Here
Distribution: Slackware 14.0
Posts: 137

Rep: Reputation: Disabled
Quote:
Originally Posted by mongoosecage View Post
Anyone experienced this before?
yes.

two questions - are you on slackware 13.37? are you using the i915 (intel) driver for X.org?
Quote:
xdriinfo
if yes - the solution that worked for me was to downgrade to an earlier version of the intel driver for X.org - look for "xf86-video-intel-2.14.0-i486-1.txz" in the pasture directory on the Slackware DVD.

also - i was still able to ssh into my machine, despite the black screen with "-". and take a look at what happened, and shut it down properly.

and - no need to do a hard reset; you may lose data / corrupt your file system(s). better to press the power button and the machine will just shutdown normally.

and - as recommended in http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT, I disabled the "Composite" extension:
Code:
Section "Extensions"
  Option "Composite" "Disable"
EndSection

Last edited by MadMaverick9; 01-16-2012 at 12:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 8 - Black screen after boot - "Loading" cursor displaying :( rmwebs Linux - Desktop 3 04-03-2008 09:35 AM
Screen goes to "grub>" black screen after trying to merge 2 drives Planet-Zhar Linux - General 4 06-20-2007 04:46 AM
nvidia 7174 widescreen laptop 2.6.x xorg = "black screen" khermans Linux - Hardware 4 04-10-2005 08:28 AM
MDK 9.2: X freezes with a black screen or blue screen with "X cursor" Apoc Linux - Newbie 10 03-30-2004 03:38 PM
MDK 9.2: X freezes on a black screen or blue screen with "X cursor" Apoc Linux - Software 1 12-29-2003 03:56 AM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration