LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-09-2008, 12:02 AM   #1
jimtrenton
LQ Newbie
 
Registered: Oct 2007
Distribution: Slackware 14.0
Posts: 24

Rep: Reputation: 2
Subtitle problem in Xine


Hello.
I've got a problem with loading subtitles when playing films with Xine. When I chose from the menu "open/subtitles" it shows files but after selecting one nothing happens. Well to be exact the film restarts but still no subs. I have no idea if it is a problem with the format of the sub file or with Xine. I use Slackware 12, xine-ui 0.99.5 and xine-lib 1.1.7. Any help will be much appreciated (can't understand chinese nor japanese but love asian films).
Thanks very much.
 
Old 04-09-2008, 09:20 AM   #2
ludist
Member
 
Registered: Nov 2005
Location: Greece
Distribution: Slackware
Posts: 129

Rep: Reputation: 16
Not a delicate solution. Open the video with

Code:
xine file.avi::file.srt
 
Old 04-10-2008, 12:10 AM   #3
jimtrenton
LQ Newbie
 
Registered: Oct 2007
Distribution: Slackware 14.0
Posts: 24

Original Poster
Rep: Reputation: 2
Hi.
Nope, sorry, this solution doesn't work. There are no errors in the console but in Xine logs I found:
Quote:
xine: couldn't find demux for > file.srt
or xine: couldn't find demux for > file.txt
I'm not really sure if this means what I think so if anyone could ensure me that would be great.
I already patched xine-lib to version 1.1.11.1 from the slackware site and have the Mplayer essential codecs pack in a dir where Xine can find it.
Is there anything else I should do to see the subs or what.
Thank you.
 
Old 07-05-2009, 03:01 PM   #4
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Rep: Reputation: 34
Hm the double colon (::) thing didn't work but I use gxine.

This worked though:
Code:
gxine file.avi file.srt
If memory serves, I have been able to drag subtitle files directly into a playing video but I figure they were of a different format or something.
 
Old 06-04-2010, 06:29 PM   #5
s1im
LQ Newbie
 
Registered: Jun 2010
Posts: 1

Rep: Reputation: 0
another syntax to specify srt file

This syntax worked for me:

Code:
xine videoFileName.avi#subtitle:subtitleFileName.srt
I'm running xine version 0.99.6 under UBUNTU 9.10 on an AMD64 processor.

I ran across this syntax specification at the home page for the Totem player (I would post the URL, but the forum won't let me since this is my first post). I tried the same syntax for xine and it worked.

The double-colon delimiter ludist recommended worked for me too. The space-delimited version that 1veedo used did not work for me, but I'm using xine, and don't have gxine installed.

Last edited by s1im; 06-04-2010 at 06:33 PM. Reason: wrap code line with code tags
 
  


Reply

Tags
subtitle, subtitles, xine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to change subtitle setting (xine) with perl ? jabka Linux - General 0 05-21-2007 03:28 PM
Problem loading avi with subtitle in Xine mmarkvillanueva Linux - Software 0 11-10-2005 04:19 AM
xine subtitle stanev Debian 4 12-03-2004 12:54 AM
Xine subtitle??? perdesiz Linux - Software 0 09-30-2003 01:50 AM
xine divx subtitle??? perdesiz Linux - Software 0 09-18-2003 04:02 PM


All times are GMT -5. The time now is 02:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration