LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Su to root works fine @ console, fails in x (cant login at all when using xdm) (http://www.linuxquestions.org/questions/slackware-14/su-to-root-works-fine-%40-console-fails-in-x-cant-login-at-all-when-using-xdm-752910/)

lionsong 09-05-2009 10:30 AM

Su to root works fine @ console, fails in x (cant login at all when using xdm)
 
*/Sorry if this has been covered before by either the slackbook, slackware basics, manpages or either on this forum or over at slackwarehelp.org, i tried to be sure id scanned the above references thoroughly before posting but if its been covered please point me to the appropriate sources/*

Just completed a fresh install of slackware 13, and when logging into the console as root (with the exact root password given during the setup pahse of the installation) i can login fine. I can su to other users, and after setting up a regular user with the adduser script i can login as said user and even su to root, again from the console.

The problem im having is when i then attempt the same with x windows, either by startx or xdm.

With startx, xfce starts up perfectly, but then at a terminal i cannot use sudo (which i set up as root @ the console login) nor can i su to root. As good practice i do not login to a full x session as root, so iv not attempted to see if i can su when actually logged in to xfce as root.

Attempts to sudo give the output "incorrect password" and su (on its own so as to call the superuser) with the correct password simply fails with a slightly patronising "Sorry".

Trying to edit my inittab to launch straight into x windows results in a xdm screen that will not let me login either as root or the regular user.

All the correct virtuals terminals's are uncommented in /etc/securetty, i also uncommented pts/1 after running the tty command to see which virtual terminal xorg was running on (this had no effect).

Iv checked thoroughly and /etc/login.defs dosent have anything in it that would dissallow using su (which makes sense as it works fine at the raw console) plus SET_WHEEL_ONLY is set to no (i added the user to the wheel group regardless to make double sure).

/etc/login.access similarly dosent contain anything that would dissallow use of su.

Seeing as i cant find anything relevent in any documentation im completely stumped, i even went as far as burning the DVD+checksum again to make sure it wasnt some form of corruption on the media, even tho the md5's checked fine.

Any thoughts?

Didier Spaier 09-05-2009 02:25 PM

If you don't have an English keyboard (e.g. I have a French one), you have to indicate the good layout of your keyboard in X server's configuration.

As Slackware 13.0 do not have a /etc/X11/xorg.conf file out of the box (it uses HAL to set up X instead if I understand well), you will have to create one yourself and indicate your language as the "XkbLayout" option in the "InputDevice" section of this file.

For instance I have:
Code:

Section "InputDevice"
#    (other options here)
    Option  "XkbLayout" "fr"
EndSection

Edit: I forgot "fr" after Option "XkbLayout"

lionsong 09-05-2009 04:58 PM

Thanks for the input didier, unforuturnatley i will not solve my problems as i have a uk keyboard so i guess something else is miss configured with X.

This is the only stumbling bloke i have from adopting slackware full time, please can someone shed some light on this problem, im almost positive it must be some user based error - something iv overlooked, or not configured.

Edit: misread part of didiers response, amended my comments accordingly

dive 09-06-2009 05:14 AM

That is very strange. Do you have any custom prompt set in ~/.bashrc or ~/.bash_profile? I seem to recall this can cause problems when incorrect strings are added to any input in a terminal and cause login/su to fail.

Which terminal are you using to su with while in X? Have you tried any others to see if it's a terminal problem.

Quote:

...(which i set up as root @ the console login)...
I'm not quite sure what you mean here. Sudo doesn't usually need any setting up except in sudoers file (use visudo for that).

lionsong 09-06-2009 08:22 AM

Quote:

I'm not quite sure what you mean here. Sudo doesn't usually need any setting up except in sudoers file (use visudo for that).
Sorry i should have been more verbose, i mean that as root on a raw console (ie outside of x) i edited the sudoers file using visudo.

My .profile simply contains my $PATH at the minute.

At the raw console i can switch between tty's and login and su to root no problem, even sudo works.

Thanks for the input dive.

Iv slept on didiers idea abit and think it actually be on the money - if the installer only sets the keyboard to the uk keymap while installing then as soon as im in x (which is now self configuring as of slack 13) it would not map the non alpha numeric keys properly, so all my long winded complex passwords would fail. This is the first time iv been bitten by having too strong a password!

Does anyone know what the installer does with the keymap post installation? I would have assumed it would be written into the installed systems configuration? Also, apart from didier, from my digging around i seem to be an isolated case with this problem, so either its not the keyboard, or its such an obvious correction no slack user has ever had to post about it :p

Ill try that tonite regardless, thanks again for the input folks.

lionsong 09-06-2009 06:22 PM

Well i finally got it working, thanks everyone.

Didier was right, my keymap wasnt set correctly. After trying the following http://www.linuxquestions.org/questi...w-13.0-751252/ i finally found success just running xorgconfig and tweaking a fresh xorg.conf file as mentioned here http://www.linuxquestions.org/questi...are-13-751778/.

Thanks again for the help folks!


All times are GMT -5. The time now is 09:14 AM.