LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-20-2012, 04:32 PM   #1
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 533

Rep: Reputation: 247Reputation: 247Reputation: 247
"su" not requesting password


Slackware64 14 RC4

"su" is going straight to root without asking for a password. So far I've tested this in xterm, konsole, and virtual terminals. Is this a bug or have I done something silly? Trouble is, I can't remember what I've done recently that might have caused it.
 
Old 09-20-2012, 04:37 PM   #2
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,635
Blog Entries: 15

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
You DID set a root password, right?
 
Old 09-20-2012, 04:50 PM   #3
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 533

Original Poster
Rep: Reputation: 247Reputation: 247Reputation: 247
Quote:
Originally Posted by ReaperX7 View Post
You DID set a root password, right?
Aha, perhaps that's it. I upgraded as follows: 13.37 -> 14 RC1 -> 14 RC4

I had a user and a root password in 13.37, but perhaps only the user password is carried forward during an upgrade and the root password not? (I tend to do clean installs rather than upgrades so I haven't noticed this before.)

Last edited by gezley; 09-20-2012 at 04:58 PM.
 
Old 09-20-2012, 04:58 PM   #4
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
could you show your /etc/sudoers file?
 
Old 09-20-2012, 05:07 PM   #5
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 533

Original Poster
Rep: Reputation: 247Reputation: 247Reputation: 247
Quote:
Originally Posted by alekow View Post
could you show your /etc/sudoers file?
Is sudo relevant to this question?
 
Old 09-20-2012, 05:59 PM   #6
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
Quote:
Originally Posted by gezley View Post
Is sudo relevant to this question?
Nope, sorry ;-)
 
Old 09-20-2012, 07:06 PM   #7
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,520

Rep: Reputation: 1183Reputation: 1183Reputation: 1183Reputation: 1183Reputation: 1183Reputation: 1183Reputation: 1183Reputation: 1183Reputation: 1183
If there is no password entry for root in /etc/shadow I would just use the passwd command to set it.

The /etc package was updated on September 4, so if you don't have a shadow.new file in /etc, chances are you chose to overwrite the old one when asked...

Last edited by Didier Spaier; 09-21-2012 at 11:17 AM. Reason: s/override/overwrite/
 
Old 09-20-2012, 09:58 PM   #8
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware
Posts: 135

Rep: Reputation: 13
Some programs can change the /etc/sudoers file, aading like string:
Code:
ALL (ALL) NOPASSWD: ALL
and then su and sudo do not ask the password. In a my country we have a mobile service provider "Megafon", which produces the program named "MobilePartner". On installing these program in /etc/sudoers will added entered line above.
 
Old 09-20-2012, 10:22 PM   #9
afreitascs
Member
 
Registered: Aug 2004
Location: Brasil
Distribution: Slackware_Cur-64_mult
Posts: 433

Rep: Reputation: 30
Quote:
Originally Posted by Didier Spaier View Post

The /etc package was updated on September 4, so if you don't have a shadow.new file in /etc, chances are you chose to override the old one when asked...
I chose to overwrite and not had this problem.
I have no file shadow.new.

I use Slackware64 current multilib
 
Old 09-21-2012, 10:38 AM   #10
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 533

Original Poster
Rep: Reputation: 247Reputation: 247Reputation: 247
Thanks one and all for the replies. My fault for not paying attention when upgrading. I do still find it strange, however, that my user password survived the upgrade while root's did not.
 
Old 09-21-2012, 11:29 AM   #11
yilez
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 122

Rep: Reputation: Disabled
Maybe root's password got blanked just in case it went catastrophic. If you can't login a user, at least you could log in as root and reset password. I don't know though. Just a guess.
 
Old 09-21-2012, 11:32 AM   #12
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,614
Blog Entries: 2

Rep: Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070Reputation: 4070
That is really weird. I have a machine with -current installed. Because of driver issues I reverted it back to 13.37 and later back to -current, but at no time any password was blanked. I assume that this is not a standard behavior.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unpredictable "delete" "move to trash" or "cut" file menu option dorianrenato Linux - General 3 11-28-2011 07:41 PM
unique password for "update" and "synaptic" and "apt-get" SaintDanBert Linux - Security 1 09-17-2010 05:53 AM
Supplying "password" to "ssh" command paragkalra Linux - Networking 1 07-31-2008 06:19 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration