LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-02-2003, 02:29 AM   #1
Uncreative
LQ Newbie
 
Registered: Apr 2003
Posts: 16

Rep: Reputation: 0
Angry Stupid KDE Clock Won't Stay Correct


Hey again, new, but less urgent problem.

The date that hwclock and date says is correct, but the one displayed in the bar on kde is several hours off (exactly hours).

It also says a different timezone from the other correct clocks, it refuses to let me change the timezone to the correct one. Can someone tell me how, or something else that might be putting it off?
 
Old 05-02-2003, 07:20 AM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
In KDE try Control Center -> System -> Date and Time
Then select the proper timezone.

You should also check the console command level by using the "date" command and see if it is reported correctly or not. If the system timezone needs to be set then run the script "timeconfig".
 
Old 05-02-2003, 07:44 AM   #3
Uncreative
LQ Newbie
 
Registered: Apr 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Excalibur
In KDE try Control Center -> System -> Date and Time
Then select the proper timezone.

You should also check the console command level by using the "date" command and see if it is reported correctly or not. If the system timezone needs to be set then run the script "timeconfig".
All those things are already correct, it's only the clock on the panel thats wrong, everytime I start kde, the timezone on it is different.
 
Old 05-02-2003, 07:47 AM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 429Reputation: 429Reputation: 429Reputation: 429Reputation: 429
Is your BIOS clock correct? And also, if you dual-boot, is the other system's time correct?
 
Old 05-02-2003, 07:54 AM   #5
Uncreative
LQ Newbie
 
Registered: Apr 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by XavierP
Is your BIOS clock correct? And also, if you dual-boot, is the other system's time correct?
Yes and yes
 
Old 05-02-2003, 08:06 AM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 429Reputation: 429Reputation: 429Reputation: 429Reputation: 429
The reason I ask is that on my home pc, my Linux clock is correct and my Win clock is an hour slow.
 
Old 05-02-2003, 11:15 AM   #7
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Then try to right click the clock panel and select "Adjust Time and Date" from the menu.
 
Old 05-02-2003, 08:38 PM   #8
Uncreative
LQ Newbie
 
Registered: Apr 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Excalibur
Then try to right click the clock panel and select "Adjust Time and Date" from the menu.
Did that already, it's on the right location but the timezone is wrong, and each time i restart kde the timezone is different again.

But it won't let me change it.
 
Old 05-02-2003, 08:51 PM   #9
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Are you logged in as root? Setting the system date/time may be considered a privileged operation.
 
Old 05-03-2003, 12:40 AM   #10
Uncreative
LQ Newbie
 
Registered: Apr 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Excalibur
Are you logged in as root? Setting the system date/time may be considered a privileged operation.
Yes, and I CAN change the systems date/time to the correct one, and it stays correct, it's just the clock on the kde panel thats changing timezone
 
Old 05-03-2003, 06:59 AM   #11
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
I had the same problem with SuSE 8.1 but going through the clock panel menu and setting the timezone fixed it for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 07:19 PM
KDE: Icon won't stay put Kamex Linux - Software 3 05-04-2005 05:12 AM
KDE 3.3 icons don't stay put (SuSE 9.2) tisource Linux - Software 3 03-22-2005 11:37 AM
clock never has correct time after booting up ki5eg Linux - Newbie 3 08-04-2004 02:23 PM
KBirthday does not stay installed in KDE davecs Linux - Software 0 05-14-2003 04:31 PM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration