LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-01-2012, 12:50 PM   #1
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,374

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Strange xz error With sqlite


To prevent GE moaning, I went trying to 'explodepkg' sqlite-3.x(32 on slackware-14.0. I had a d/l of the iso, which I loop mounted

Xz barfed - "I/O Error - file format not recognized"

So I went to the nearby mirror, (heanet.ie) and tried there. Same error.
ftp://ftp.heanet.ie/mirrors/slackwar....13-i486-1.txz
Never mind, I thought, I'll just use 13.37's
ftp://ftp.heanet.ie/mirrors/slackwar...7.5-i486-1.txz
You guessed it - same error. Other packages work fine :-O. I've just exploded a couple. What's the deal?
Is it a dud package? April Fool's joke? BTW Did they release on April 1?
 
Old 11-01-2012, 01:52 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
I downloaded it and tried explodepkg on my slackware 13.37 64-bit server. No problems.
Give us the output of "uname -a" and "cat /etc/slackware-version" please. As well as the exact full commandline you are using.

Eric
 
Old 11-02-2012, 07:01 AM   #3
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,374

Original Poster
Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Bah! Something stupid here, then. Thanks for checking.

/Checks carry on here
OK. The iso I have seems to be broken for sqlite, and that only AFAICT.
Today's download works - explodes so I can grab the libs :-/.

For the record, the exact error (with cp) was
Quote:
bash-4.2$ explodepkg /mnt/tmp/slackware/ap/sqlite-3.7.13-i486-1.txz
Exploding package /mnt/tmp/slackware/ap/sqlite-3.7.13-i486-1.txz in current directory:
cat: /mnt/tmp/slackware/ap/sqlite-3.7.13-i486-1.txz: Input/output error
xz: (stdin): File format not recognized
The last line also was the error on the downloads.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Perl connect to SQLite database - strange behaviour totaluser Programming 6 11-10-2011 12:59 AM
LXer: Sqlite-Commander - A ncurses based tool to display the records and tables of a sqlite database LXer Syndicated Linux News 0 01-02-2011 08:11 AM
SQLite version error lunlun Ubuntu 8 12-13-2009 02:12 PM
Strange PHP/SQLite problem RattleSn@ke *BSD 1 06-25-2009 04:51 PM
error when installing sqlite 11 soumya_b Linux - Software 0 01-23-2007 01:59 AM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration