LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-01-2006, 11:35 AM   #1
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Rep: Reputation: 31
Strange XEmacs Behavior


Howdy Forum,

I use XEmacs at home and at work and I'm having a problem in slackware that I've not had on Windows or PCLinuxOS. I just installed Slackware and got X up and running by installing a new kernel (2.6etc) -- actually X was fine, it was the mouse that was having problems with the old kernel.

Last night I was doing some customizing, so I copied my custom.el and init.el from my work computer (which I'm just realizing could have caused the problem...I use Windows at work) and copied them into a .xemacs directory for root and one for joel (that's me when I'm non-root).

First there were some problems reading init.el:

(display-time)

did not work and gave me a warning.

Then, whenever I edited init.el, it would save under root ownership. I did

chown joel:adamson init.el

a few times before I realized it was reverting to root:root each time I edited and then saved it.

Any ideas? Does slackware have any security policies that might do this?

Thanks,
Joel
 
Old 12-01-2006, 05:30 PM   #2
Quinta
LQ Newbie
 
Registered: Feb 2005
Location: Henley-on-Thames, England
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
Hi Joel,

Xemacs has always worked like a charm here, since Slack 8. Don't think there is a default security policy which would produce the result you are getting.


Are you editing your ~/joel/.xemacs/init.el as root? (Probably not but worth asking!) It's probably better to use tramp and ssh to edit as root anyway, rather than run XEmacs as root.

What are the permissions on the .xemacs directory?
Have any other directories/file behaved strangely?

I'm groping here too :-)
 
Old 12-01-2006, 08:48 PM   #3
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Original Poster
Rep: Reputation: 31
I'm pretty sure it's because I copied custom.el from a Windows machine and it was full of Windows pathnames.

I'm copying my Linux homedirectory .xemacs files right now. I also discovered that the .xemacs directory was owned by root:root.

We'll see what happens next

Thanks,
Joel
 
Old 01-03-2007, 10:03 AM   #4
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Original Poster
Rep: Reputation: 31
ACtually it was because I forgot to install the packages...

Now my current challenge is getting the window (frame) size correct. I put

[code]
'(initial-frame-plist (quote (height 30 width 80)))
'(default-frame-plist (quote (height 30 width 80)))
[\code]

into custom.el, however all I get is 63X29 framesize.

I compiled XEmacs with gtk (--with-gtk) -- I have not had this problem with the default ./configure options.

Also, I'm using XEmacs within Enlightenment DR17.

Joel
 
Old 01-03-2007, 05:40 PM   #5
Quinta
LQ Newbie
 
Registered: Feb 2005
Location: Henley-on-Thames, England
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
Have you tried setting those variables without the 'quote' - like this

(setq default-frame-plist '(width 80 height 55))

(setq initial-frame-plist '(top 1 left 1 width 80 height 55))


You can set the initial frame via Xresources too

eg

XEmacs.Geometry: 100x40+130+14
 
Old 01-03-2007, 07:11 PM   #6
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Original Poster
Rep: Reputation: 31
I mistakenly said "I put" when I should have said "custom saved" -- the "quote" was a result of the save by custom in custom.el.

Good suggestion on the Xresources, I'll try it.

The funny thing is that when I raise new frames (a new habit for me), they're the right size. So it seems that the initial frame is set by Xresources and the rest are sized according to custom.el. The only problem is that 'initial-frame-plist is supposed to override Xresources (or so says Customize).

Thanks,
Joel
 
Old 01-04-2007, 05:42 AM   #7
Quinta
LQ Newbie
 
Registered: Feb 2005
Location: Henley-on-Thames, England
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
So comment out the lines in custom.el, insert the lines I suggested in init.el and see what happens :-)

But Xresources are a better way to go. You can find a ,list of them in the NEWS file under the help menu.
 
  


Reply

Tags
security, slackware, xemacs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Very strange OS behavior after reinstallation Aranel Mandriva 5 06-15-2006 08:34 AM
Strange Problem with Emacs/XEmacs mrgoodtrips Linux - Software 1 07-28-2005 01:34 AM
Very Strange Behavior raysr Mandriva 4 08-31-2004 02:06 PM
Strange Behavior andrewb758 Linux - Hardware 5 08-31-2003 02:42 PM
strange behavior abhijit Linux - General 3 07-09-2003 11:25 PM


All times are GMT -5. The time now is 12:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration