LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2004, 08:46 PM   #1
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Rep: Reputation: 34
Strange problem in Slack 9.1


Hi all,

I am facing a strange problem in Slackware, that even by resinstalling is not going away.

I know this is a standard function but it is not working, the problem is as follows:

Everytime I press Ctrl-Alt-(F2|F3|F4|F5|f6)
I see a blank screen, with a cursor blinking!

I know a new console should open, and should rather prompt for the username and password.

I changed my default runlevel at startup to init 4, but I had done this in Redhat too, and it still used to work (rather init 4 was default there)
 
Old 05-22-2004, 09:19 PM   #2
MustangCSA
Member
 
Registered: Feb 2004
Location: Seattle, WA
Distribution: Debian Sid
Posts: 85

Rep: Reputation: 15
In slackware when you are in runlevel 4 only alt+F6 works. Or CTRL+ATL+F6 when your in X.
 
Old 05-24-2004, 10:45 AM   #3
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
Thanks MustangCSA,
 
Old 05-24-2004, 08:37 PM   #4
herbc
Member
 
Registered: May 2004
Location: United States
Distribution: Slackware 10.0
Posts: 72

Rep: Reputation: 15
In /etc/inittab look for the section:

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

Make the appropriate lines look like the last. For example, to get Ctl-Alt-F1 to switch to
console on tty1, change
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
to
c1:12345:respawn:/sbin/agetty 38400 tty1 linux

You can also add tty's, as many as you want, though I've never tried tty7.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack hangs - Strange problem intens Slackware 10 10-03-2005 08:50 AM
Strange problem when install Slack 9.1 ZiGiE Slackware 3 10-28-2003 08:55 PM
Strange problem in slack 9.1 drakxstar Slackware 6 10-20-2003 09:58 PM
strange slack 9.1 problem Little devil Slackware 5 10-13-2003 03:35 PM
Strange Slack Install Problem cclavey Slackware 3 04-02-2003 06:14 PM


All times are GMT -5. The time now is 09:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration