LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Strange font rendering in Firefox after latest updates (http://www.linuxquestions.org/questions/slackware-14/strange-font-rendering-in-firefox-after-latest-updates-845840/)

vdemuth 11-22-2010 12:00 PM

Strange font rendering in Firefox after latest updates
 
Hi all,

Done the latest upgrade, but I am having a strange problem with fonts under Firefox/Seamonkey and Google Chrome.

When displaying web pages, any character with a sloped element to it, i.e. W,X,Z,N.K, or anything circular, (O,0,Q) etc, (but only when in lowercase) , the sloped part looks as though it has missing pixels, and subsequently these letters look 'washed out'.

Also seeing this problem when using native Konqueror, so not sure where to start determining the reason for it.

Anyone got any ideas?

Daedra 11-22-2010 03:51 PM

A lot of font problems were reported with the lastest current updates. It seems these problem may come from the fact that the new freetype package in current has the font byte code interpreter enabled by default. You can either disable the BCI and go back to using the autohinter (see post #9 http://www.linuxquestions.org/questi...s-then-844706/)

Or you can tweak your fonts to get some very impressive results, see Dugan Chen's font guide http://www.vcn.bc.ca/~dugan/slackware-fonts/. However keep in mind those builds are for 13.1, for -current builds see this post http://www.linuxquestions.org/questi...68/page12.html specifically posts #179 and #180

RealUseR 11-23-2010 02:05 PM

I have the same problem on slackware current. This work for me -> System Settings -> Common Apperance and Beavior -> Application Apperance -> Fonts -> Use anti-aliasing : Enabled -> Configure -> Only set Hinting Style to Slight. OK, Apply, and restart X. ;)

repo 11-23-2010 03:36 PM

Quote:

Originally Posted by RealUseR (Post 4168529)
I have the same problem on slackware current. This work for me -> System Settings -> Common Apperance and Beavior -> Application Apperance -> Fonts -> Use anti-aliasing : Enabled -> Configure -> Only set Hinting Style to Slight. OK, Apply, and restart X. ;)

Solved my problem with the fonts.

Kind regards

vdemuth 11-24-2010 01:38 AM

Good tip. Works here to.

RealUseR 11-24-2010 01:58 AM

It's my pleasure. ;)


All times are GMT -5. The time now is 04:38 PM.