LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-02-2008, 03:47 PM   #1
AlphaSigmaOne
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 118

Rep: Reputation: 16
Strange Firefox problem.


I'm basically an extreme Linux novice and a Slack noob. I installed it last night. (It wasn't hard at all. ) I've been able to get most things working on my own with the help of the gazillion guides out there. (Shilo's in particular.) But I noticed a strange problem with Firefox off the bat: I couldn't get web pages to load! All the other browsers seemed to work okay as did Slapt-get, but when I loaded Firefox, I simply got an error.

I spent hours trying different things with netconfig and the like. I wasn't sure if it was a problem with the NIC card or what.

After, searching through several topics on the subject that inevitably lead to dead-ends, I found a fix on an old Ubuntu guide. It told me to edit these lines in the config:

Code:
network.dns.disableIPv6 -> true
network.http.pipelining -> true
network.http.pipelining.maxrequests -> 8
network.http.proxy.pipelining -> true
And sure enough, it seemed to solve the problem. The only problem is I have to do the same thing for each user. I think this seemed a bit excessive and not really a "true fix."

So my question is, is there some other Slack config I can edit that will have the same result universally?
 
Old 06-02-2008, 04:04 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
You can probably just blacklist the ipv6 module in /etc/modprobe.d/blacklist. I'm definitely not positive about that, but I think it should work (you'd have to reboot for it to take effect though -- or try running `rmmod ipv6` as root).
 
Old 06-02-2008, 04:10 PM   #3
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31
IPv6 was what was causing your problem. The pipelining settings are said to make firefox download webpages faster. I dont notice the difference, but I might if I was on a slower connection. rmmod ipv6 will remove that module as T3slider said. That will be your fix.

DragonM15
 
Old 06-02-2008, 04:38 PM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You can also disable IPv6 in Firefox.

Enter about:config in the address and press <enter>.

Enter v6 in the search field. You will see a record named network.dns.disable.IPv6. Set that to true.

You can then install a Firefox add-on calle FEBE to save your Firefox configuration. This can be used to configure Firefox for all of your other users. FEBE is available on the Mozilla site. You can use it to create a template configuration that can be applied to all of your user's Firefox configurations.

But I also agree with the others. Removing the IPv6 module seems like a good idea.

Last edited by stress_junkie; 06-02-2008 at 04:40 PM.
 
Old 06-02-2008, 04:46 PM   #5
AlphaSigmaOne
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 118

Original Poster
Rep: Reputation: 16
The blacklisting seemed to work. Thanks.

Now, for the simple matter of understanding what I did:

I ran
Code:
mousepad /etc/modprobe.d/blacklist
in the terminal and that created the file.

Then I entered "IPv6" in the field and saved it thus blacklisting the IPv6. Right?
 
Old 06-02-2008, 05:08 PM   #6
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31
Quote:
Originally Posted by stress_junkie View Post
You can also disable IPv6 in Firefox.

Enter about:config in the address and press <enter>.

Enter v6 in the search field. You will see a record named network.dns.disable.IPv6. Set that to true.
Hmm... looks awfully familiar......


DragonM15
 
Old 06-02-2008, 05:09 PM   #7
symatic
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 242

Rep: Reputation: 32
The command you ran opened the file. It did not create it. If you followed the syntax in the file it would be something like:

Code:
blacklist ipv6
All you did was open and close a file. That fact that you could save the file means you are either running as root or found the su/sudo command. If it is the first one stop and create a user to do your work with. If it is the later one good to see you are learning. Please read the slackbook provided, it will give you some valuable insight on what you are actually doing.
 
Old 06-02-2008, 05:13 PM   #8
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31
Quote:
Originally Posted by AlphaSigmaOne View Post
The blacklisting seemed to work. Thanks.

Now, for the simple matter of understanding what I did:

I ran
Code:
mousepad /etc/modprobe.d/blacklist
in the terminal and that created the file.

Then I entered "IPv6" in the field and saved it thus blacklisting the IPv6. Right?
That should do the trick... I dont remember if a reboot in necessary or not in order to truly put that in effect, but since you already unloaded the module, you should be set to go. Might as well try restarting and seeing what happens.

DragonM15
 
Old 06-02-2008, 06:07 PM   #9
AlphaSigmaOne
Member
 
Registered: Sep 2005
Distribution: Slackware 13.1
Posts: 118

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by symatic View Post
file means you are either running as root or found the su/sudo
Well, I did setup other users hence the initial question, and tried "sudo" but it didn't work. I suppose it has to be set up first, but one thing at a time.

EDIT: Just out of curiosity, I tried the rmmod first. It didn't work. The error message read: IN USE.

I googled the problem and read on another board that modules cannot be unloaded once they're loaded, so how do you keep it from loading in order to remove it?

Last edited by AlphaSigmaOne; 06-02-2008 at 07:16 PM.
 
Old 06-02-2008, 07:24 PM   #10
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by AlphaSigmaOne View Post
I googled the problem and read on another board that modules cannot be unloaded once they're loaded, so how do you keep it from loading in order to remove it?
Type lsmod to see what is using the module. rmmod will unload when nothing else is using it.

If you have 'blacklist ipv6' in the blacklist file it shouldn't get loaded at next boot.
 
Old 06-02-2008, 09:25 PM   #11
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
In a default Slackware setup, there should already be a /etc/modprobe.d/blacklist file with a lot of entries (and comments) in it. You should just add "blacklist ipv6" to the end of it, as symatic described.
 
Old 06-02-2008, 10:39 PM   #12
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
If removing modules manually using modprobe -r is typically better.

If for some reason you still want those other config changes (pipeline stuff) to be global for Firefox I can tell you how to do it.

Blacklisting IPv6 should fix your problem, though. Let us know how it goes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange message on Fedora 7 bootup , also Firefox problem RetiredInMaine Fedora 4 08-31-2007 02:14 PM
Strange problem with Firefox rangalo Slackware 6 07-13-2007 03:37 PM
Strange Download Problem with Firefox Toods Slackware 6 02-18-2006 03:07 PM
Strange Debian/Firefox locale problem... fannymites Debian 2 04-04-2005 06:12 PM
strange, strange alsa problem: sound is grainy/pixellated? fenderman11111 Linux - Software 1 11-01-2004 05:16 PM


All times are GMT -5. The time now is 08:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration