LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Strange Firefox problem. (http://www.linuxquestions.org/questions/slackware-14/strange-firefox-problem-646492/)

AlphaSigmaOne 06-02-2008 04:47 PM

Strange Firefox problem.
 
I'm basically an extreme Linux novice and a Slack noob. I installed it last night. (It wasn't hard at all. :o ) I've been able to get most things working on my own with the help of the gazillion guides out there. (Shilo's in particular.) But I noticed a strange problem with Firefox off the bat: I couldn't get web pages to load! All the other browsers seemed to work okay as did Slapt-get, but when I loaded Firefox, I simply got an error.

I spent hours trying different things with netconfig and the like. I wasn't sure if it was a problem with the NIC card or what.

After, searching through several topics on the subject that inevitably lead to dead-ends, I found a fix on an old Ubuntu guide. It told me to edit these lines in the config:

Code:

network.dns.disableIPv6 -> true
network.http.pipelining -> true
network.http.pipelining.maxrequests -> 8
network.http.proxy.pipelining -> true

And sure enough, it seemed to solve the problem. The only problem is I have to do the same thing for each user. I think this seemed a bit excessive and not really a "true fix."

So my question is, is there some other Slack config I can edit that will have the same result universally?

T3slider 06-02-2008 05:04 PM

You can probably just blacklist the ipv6 module in /etc/modprobe.d/blacklist. I'm definitely not positive about that, but I think it should work (you'd have to reboot for it to take effect though -- or try running `rmmod ipv6` as root).

DragonM15 06-02-2008 05:10 PM

IPv6 was what was causing your problem. The pipelining settings are said to make firefox download webpages faster. I dont notice the difference, but I might if I was on a slower connection. rmmod ipv6 will remove that module as T3slider said. That will be your fix.

DragonM15

stress_junkie 06-02-2008 05:38 PM

You can also disable IPv6 in Firefox.

Enter about:config in the address and press <enter>.

Enter v6 in the search field. You will see a record named network.dns.disable.IPv6. Set that to true.

You can then install a Firefox add-on calle FEBE to save your Firefox configuration. This can be used to configure Firefox for all of your other users. FEBE is available on the Mozilla site. You can use it to create a template configuration that can be applied to all of your user's Firefox configurations.

But I also agree with the others. Removing the IPv6 module seems like a good idea.

AlphaSigmaOne 06-02-2008 05:46 PM

The blacklisting seemed to work. Thanks.

Now, for the simple matter of understanding what I did:

I ran
Code:

mousepad /etc/modprobe.d/blacklist
in the terminal and that created the file.

Then I entered "IPv6" in the field and saved it thus blacklisting the IPv6. Right?

DragonM15 06-02-2008 06:08 PM

Quote:

Originally Posted by stress_junkie (Post 3172511)
You can also disable IPv6 in Firefox.

Enter about:config in the address and press <enter>.

Enter v6 in the search field. You will see a record named network.dns.disable.IPv6. Set that to true.

Hmm... looks awfully familiar......


DragonM15

symatic 06-02-2008 06:09 PM

The command you ran opened the file. It did not create it. If you followed the syntax in the file it would be something like:

Code:

blacklist ipv6
All you did was open and close a file. That fact that you could save the file means you are either running as root or found the su/sudo command. If it is the first one stop and create a user to do your work with. If it is the later one good to see you are learning. Please read the slackbook provided, it will give you some valuable insight on what you are actually doing.

DragonM15 06-02-2008 06:13 PM

Quote:

Originally Posted by AlphaSigmaOne (Post 3172516)
The blacklisting seemed to work. Thanks.

Now, for the simple matter of understanding what I did:

I ran
Code:

mousepad /etc/modprobe.d/blacklist
in the terminal and that created the file.

Then I entered "IPv6" in the field and saved it thus blacklisting the IPv6. Right?

That should do the trick... I dont remember if a reboot in necessary or not in order to truly put that in effect, but since you already unloaded the module, you should be set to go. Might as well try restarting and seeing what happens.

DragonM15

AlphaSigmaOne 06-02-2008 07:07 PM

Quote:

Originally Posted by symatic (Post 3172542)
file means you are either running as root or found the su/sudo

Well, I did setup other users hence the initial question, and tried "sudo" but it didn't work. I suppose it has to be set up first, but one thing at a time.

EDIT: Just out of curiosity, I tried the rmmod first. It didn't work. The error message read: IN USE.

I googled the problem and read on another board that modules cannot be unloaded once they're loaded, so how do you keep it from loading in order to remove it?

dive 06-02-2008 08:24 PM

Quote:

Originally Posted by AlphaSigmaOne (Post 3172574)
I googled the problem and read on another board that modules cannot be unloaded once they're loaded, so how do you keep it from loading in order to remove it?

Type lsmod to see what is using the module. rmmod will unload when nothing else is using it.

If you have 'blacklist ipv6' in the blacklist file it shouldn't get loaded at next boot.

T3slider 06-02-2008 10:25 PM

In a default Slackware setup, there should already be a /etc/modprobe.d/blacklist file with a lot of entries (and comments) in it. You should just add "blacklist ipv6" to the end of it, as symatic described.

shadowsnipes 06-02-2008 11:39 PM

If removing modules manually using modprobe -r is typically better.

If for some reason you still want those other config changes (pipeline stuff) to be global for Firefox I can tell you how to do it.

Blacklisting IPv6 should fix your problem, though. Let us know how it goes.


All times are GMT -5. The time now is 11:28 PM.