LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Strange discrepancy in system local (http://www.linuxquestions.org/questions/slackware-14/strange-discrepancy-in-system-local-4175484114/)

longus 11-10-2013 11:56 AM

Strange discrepancy in system local
 
Yesterday i upgraded a remote desktop to Slackware64-14.1. In except of running lilo after the kernel upgrade, everythink now is working gret. I see one only problem related to the system local.
I have setted the system local to bg_BG.UTF-8. When i connect to the remote machine throught ssh the "locale" command return the setted encoding, bun running the same command locally, it gives en_US.UTF-8. "Locally" mean throught teamviewer. I connect to the desktop with teamviewer and run there xfce4-terminal. This is for root and all of the users in the mashine. There is not "per user" setting about the system locale. I am inclined to believe that the system local is en_US, because firefox browser's interface is englisch, despite the locallization.
Does anyone have an idea, how that problem occur?

munkz 11-10-2013 04:06 PM

I am thinking maybe ssh environment settings on the client pushing local? Google dork AcceptEnv. Maybe just look at the local file on the remote machine and see what it is set to.
vim /etc/profile.d/lang.sh

longus 11-11-2013 01:18 AM

The local file on the remote mashine is settet to the desired locale - bg_BG.UTF-8.
There is not AcceptEnv in my ssh_config.

munkz 11-11-2013 03:34 AM

what ishe output of :
Code:

~]# grep AcceptEnv /etc/ssh/sshd_config
Run that on the server that you are having issues with.

longus 11-12-2013 02:07 PM

The command "grep AcceptEnv /etc/ssh/sshd_config" returns nothing. There is not such of line in sshd_config.

munkz 11-12-2013 02:13 PM

Very odd. If the server gives one locale when logged in locally and another when logged in via ssh and sshd is not accepting environment settings, I am not sure. Perhaps some one will be able to help.

I wish I knew more.


All times are GMT -5. The time now is 09:32 PM.