LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Stopping amarok amazon prompt (http://www.linuxquestions.org/questions/slackware-14/stopping-amarok-amazon-prompt-4175476627/)

wufo 09-10-2013 12:40 PM

Stopping amarok amazon prompt
 
Sometime when I was trying to get the audio working amarok got strarted. Now, every time I log on it wants info for amazon.com. I don't want to use amarok.

Where is this getting started from and how do I keep it from starting?

tj

dugan 09-10-2013 12:56 PM

I don't know what you're talking about.

Can you post a screenshot?

wufo 09-10-2013 08:55 PM

I am not o that system, but the thing is when I log on via xdm amarok is started, and since I never set it up, it asks me to complete setup. The bottom line is. I don't want it started at log on at all. So, where would it be started at? Which file. I looked in .bashrc, etc. There is no .xinitrc or xsession in user home.

tj

jamesf 09-10-2013 11:49 PM

Depends upon what DE you're using. I use xfce, so autostarted stuff is here:
Code:

james@tardis:~$ ls .config/autostart/
blueman.desktop  hplip-systray.desktop  nm-applet.desktop  wicd-tray.desktop

I don't used KDE on this machine, but it puts Autostart stuff here:
Code:

james@tardis:~$ ls .kde/Autostart/
james@tardis:~$

I found these subdirectories because I remembered that autostart directories are used, so I did this from my home directory:
Code:

james@tardis:~$ find . -name \*uto\*
./.kde/Autostart
./.kde/share/config/kded_device_automounterrc
./.kde/share/apps/konqueror/autosave
./.config/autostart

EDIT: After doing a 'man find', this works better:
Code:

james@tardis:~$ find . -iname autostart
./.kde/Autostart
./.config/autostart
james@tardis:~$


kikinovak 09-11-2013 01:58 AM

Quote:

Originally Posted by wufo (Post 5025364)
Sometime when I was trying to get the audio working amarok got strarted. Now, every time I log on it wants info for amazon.com. I don't want to use amarok.

Where is this getting started from and how do I keep it from starting?

tj

I vaguely remember getting annoyed by the same thing. I also remember it can be deactivated in the settings. Somewhere...

jon lee 09-11-2013 03:52 PM

I would just uninstall amarok completely and install clementine as a replacement (which I've done). I think clementine is better anyway.

You could probably also prevent this by removing amarok (.desktop) from /usr/share/kde4/services... but I don't have it installed to verify.

Timothy Miller 09-11-2013 04:27 PM

Quote:

Originally Posted by jon lee (Post 5026044)
I would just uninstall amarok completely and install clementine as a replacement (which I've done). I think clementine is better anyway.

You could probably also prevent this by removing amarok (.desktop) from /usr/share/kde4/services... but I don't have it installed to verify.

Exactly how I deal with Amarok also. Uninstall the bloated thing and install Clementine, which is quite a bit better IMO.


All times are GMT -5. The time now is 03:20 AM.