LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-08-2012, 06:45 AM   #1
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Rep: Reputation: 32
stopping a program from starting at startup!


Hiya,
For the last few weeks, everytime i boot and log into slackware, the "Welcome to desktop sharing" program opens. I'm not sure why. I have never evened opened it myself.
Any ideas how to stop this from happening? Clearly it's not the end of the world, but it is a little vexxing

I've had a look in rc.local, but nothing's in there that's relevant.

Cheers,
mute

(slack 13, xfce)
 
Old 09-08-2012, 06:50 AM   #2
414N
Member
 
Registered: Sep 2011
Location: Italy
Distribution: Slackware
Posts: 608

Rep: Reputation: 179Reputation: 179
What kind of program is it? A GUI or a CLI one?
 
Old 09-08-2012, 07:35 AM   #3
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
GUI. it's a kde application.
 
Old 09-08-2012, 07:44 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
The "Welcome to KDE desktop sharing" would come from krfb being started everytime you login.
I have no idea what version of Slackware or KDE you are running, but you should be looking in System Settings for "startup and shutdown" and find the list of applications that are auto-started. Remove krfb from that list and all should be OK afterwards.

Eric
 
Old 09-08-2012, 07:50 AM   #5
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
Cheers for the reply Eric. I put under my name in the first post i'm running slackware 13 with a xfce desktop, not sure what version though.
I will have a look for startup and shutdown system settings if xfce has one, and get back to you.

thanks again,
mute
 
Old 09-08-2012, 08:06 AM   #6
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32


I found the xfce equivalent "session and startup", but nothing was listed under the "application autostart" tab. However the next tab ("session"), contained a krfb session, which i removed and then clicked 'save session' (see screenie).

Cheers again Eric, i wouldn't have even known to look for 'krfb'.

mute
Attached Images
File Type: jpg Untitled.jpg (155.4 KB, 21 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
starting a program on startup abdolah Linux - Software 3 11-04-2010 02:25 PM
Starting a Java program on system startup guitar_199 Linux - General 6 09-25-2007 04:23 AM
Starting program on startup with gdm and fluxbox? 95se Linux - Software 4 03-22-2004 12:47 PM
Starting a program at blackbox startup, to open on a different workspace. luc-allouette Linux - Software 2 09-01-2003 07:50 PM
Stopping X from starting KennyK Linux - Software 4 06-03-2003 08:12 PM


All times are GMT -5. The time now is 11:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration