LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   stopping a program from starting at startup! (http://www.linuxquestions.org/questions/slackware-14/stopping-a-program-from-starting-at-startup-4175426232/)

mutexe 09-08-2012 06:45 AM

stopping a program from starting at startup!
 
Hiya,
For the last few weeks, everytime i boot and log into slackware, the "Welcome to desktop sharing" program opens. I'm not sure why. I have never evened opened it myself.
Any ideas how to stop this from happening? Clearly it's not the end of the world, but it is a little vexxing :)

I've had a look in rc.local, but nothing's in there that's relevant.

Cheers,
mute

(slack 13, xfce)

414N 09-08-2012 06:50 AM

What kind of program is it? A GUI or a CLI one?

mutexe 09-08-2012 07:35 AM

GUI. it's a kde application.

Alien Bob 09-08-2012 07:44 AM

The "Welcome to KDE desktop sharing" would come from krfb being started everytime you login.
I have no idea what version of Slackware or KDE you are running, but you should be looking in System Settings for "startup and shutdown" and find the list of applications that are auto-started. Remove krfb from that list and all should be OK afterwards.

Eric

mutexe 09-08-2012 07:50 AM

Cheers for the reply Eric. I put under my name in the first post i'm running slackware 13 with a xfce desktop, not sure what version though.
I will have a look for startup and shutdown system settings if xfce has one, and get back to you.

thanks again,
mute

mutexe 09-08-2012 08:06 AM

1 Attachment(s)
:D

I found the xfce equivalent "session and startup", but nothing was listed under the "application autostart" tab. However the next tab ("session"), contained a krfb session, which i removed and then clicked 'save session' (see screenie).

Cheers again Eric, i wouldn't have even known to look for 'krfb'.

mute


All times are GMT -5. The time now is 06:08 PM.