LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-16-2008, 10:00 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Stock 12.2 Huge Kernel Will Not Boot With cx23885 Module


I cannot boot 12.2 with the stock 2.6.27.7 huge kernel. I get to the udev trigger message and then the system locks up hard. Not even the SysRq magic key sequence will reboot the box. Yet I can boot flawlessly with my compiled 2.6.27.7 kernel.

When I finished updating from 12.1 to 12.2 I checked various tools and configurations of my system. I noticed the system refused to boot with the huge kernel. Yet this worked only the previous day. For a few weeks after updating Slackware I always like to have the huge kernel as a back door in my boot menu, although eventually I remove that boot option.

For the past two months I had booted and rebooted dozens of times using the huge kernel while I tested Current. Some nominal head scratching led me to realize that the only thing changed in the past few days was adding a HVR-1250 TV capture card. I configured the card and successfully watched some over-the-air digital TV but all on 12.1. I wanted to finish that installation project before updating to 12.2. After completing that project I was ready to update to 12.2.

Booting without the 'quiet' boot parameter revealed the system locks up hard when udev tries to load the cx23885 module, which is the chip used in my TV capture card.

I tested "emergency" booting with the 12.2 DVD with the same result. The kernel boots from the DVD, but then when running udev from the hard drive the system locks up hard when loading the cx23885 module.

Next I blacklisted the module in /etc/modprobe.d/blacklist. I rebooted and then the huge kernel would boot successfully whether run from the hard drive or DVD.

Curiously, after booting with the huge kernel, if I then manually loaded the cx23885 module with modprobe, the system again froze completely.

None of these problems occur with my own compiled kernel.

The blacklist option prevents the huge kernel from crashing, but then I would have to manually load the module from rc.local (using some kind of test to distinguish kernels).

Is there a boot parameter than can be passed to the kernel to ignore loading a specific module?

Or can I create a special udev rule?

I don't know whether to report this to Pat. I can see how I might have been totally flustered if I were new to Slackware and tried to install 12.2 for the first time with the TV card already installed. I never would have gotten up to bat, let alone try to reach first base.

I have tested Current/12.2 rather well. I really do not need to use the huge kernel as a backup kernel. Adding the kernel to my boot menu is merely an old habit. Nonetheless I am curious to hear what others think and possible solutions for the best of both worlds.

Thanks again.
 
Old 12-17-2008, 03:25 AM   #2
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 729
Blog Entries: 3

Rep: Reputation: 78
Hello Woodsman,

After some googling, I found that you may try this:

Code:
brokenmodules=cx23885
but it may not work for modules built in the kernel (and I assume cx23885 is built in huge kernel).

or maybe use:

Code:
disablemodules=cx23885
but this one looks specific to Arch Linux

Last edited by gegechris99; 12-17-2008 at 03:43 AM. Reason: add suggestion for disablemodules
 
Old 12-17-2008, 05:04 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
brokenmodules=cx23885
disablemodules=cx23885
Hmm. Thanks for trying. I searched kernel-parameters.txt and found no such option. Nonetheless, I rebooted and tried. No change. The system locks up hard. The cx23885 driver is set as a module in the huge kernel configuration.

The only way I have discovered to stop the lock-up when using the huge kernel is to blacklist the module or disable rc.udev. Of course, that won't happen with a newbie or anybody using the kernel immediately after installation. What will happen is predictable. A person will perform the installation, reboot using the huge kernel --- which is natural until a person creates an initrd or recompiles the kernel to taste, and the box will lock up. Response will be WTF.

Last edited by Woodsman; 12-17-2008 at 10:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot boot to new kernel huge mem nanosec Linux - General 1 07-30-2008 09:27 PM
patching Debian Stock Kernel with prepatch from kernel.org kushalkoolwal Debian 10 08-25-2007 02:05 PM
Kernel Module Not Loading on Boot skibud2 Mandriva 8 01-11-2007 02:36 AM
Kernel module not loading at boot tweak1313 Fedora 2 12-04-2004 05:17 PM
Upgrading stock 2.4.22 kernel to 2.5.x then to 2.6.6 with existing stock .config file Kyl3 Slackware 8 06-09-2004 06:34 PM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration