LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-13-2012, 03:23 PM   #61
kmreiserfs
LQ Newbie
 
Registered: Jan 2010
Posts: 5

Rep: Reputation: 0

I got Killing Floor Working

Slackware 64 14.0
Radeon HD6870
AMD Phenom II X6 Black 1100T
8GB RAM
http://i17.photobucket.com/albums/b5...rfs/steam4.png

Braid does not work
i have 9 linux games in my list
 
Old 11-14-2012, 04:44 AM   #62
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Rep: Reputation: Disabled
Quote:
Originally Posted by af7567 View Post
I had a problem similar to this on my laptop, but after I installed the latest ati proprietary drivers (from last month) steam started ok. I had an older version of those drivers installed before.
With ATI proprietary driver is the same old situation


X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 45 (X_OpenFont)
Serial number of failed request: 12
Current serial number in output stream: 13
 
Old 11-14-2012, 03:06 PM   #63
Beelzebud
Member
 
Registered: Oct 2010
Distribution: Arch & Slackware
Posts: 95

Rep: Reputation: 22
I'm not very happy with the idea of having to install Pulse Audio to use Steam in Slackware. That was one of the things I found appealing about Slackware in the first place: That is the fact that it doesn't use it.

On my gaming rig, I use a Creative X-Fi card because it blows away the onboard chip on my motherboard. With Pulse Audio I have never been able to get the subwoofer to work correctly. Without pulse it all works fine, but with Pulse the subwoofer just plays a low frequency that you can barely hear.

Unfortunately it looks like there is no escaping it at this point.
 
Old 11-15-2012, 12:20 AM   #64
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,188
Blog Entries: 15

Rep: Reputation: 826Reputation: 826Reputation: 826Reputation: 826Reputation: 826Reputation: 826Reputation: 826
You don't have to use PulseAudio. It just has to be there on the system because the library is linked against it as a dependency. Otherwise you can keep PulseAudio dead and unused.
 
Old 11-16-2012, 06:18 AM   #65
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,377

Rep: Reputation: 170Reputation: 170
I have the client up and running for the moment. I had to upgrade the nvidia blob to 304 first. Perused the store for a while and watched a demo. That's about it for now! I'm not much of a gamer, but I may be soon enough.
 
Old 11-16-2012, 11:06 AM   #66
kmreiserfs
LQ Newbie
 
Registered: Jan 2010
Posts: 5

Rep: Reputation: 0
Two games working now

Amnesia http://s17.beta.photobucket.com/user...team7.png.html

 
Old 11-17-2012, 11:03 AM   #67
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 256

Rep: Reputation: 32
Well, I got it to the point that it will run. I see steam itself and the ads for various games are showing in the background. I get a pop-up error message saying that it is in closed beta. As soon as I click "OK", it quits. It doesn't seem to be crashing. On the command line it just says "Shutting down . . ." Maybe they got wise to people trying the workaround.

I've got to give props to AlienBob for getting all of the deps in order. Your instructions were very easy to follow.

*UPDATE* I should have reread the thread. "steam steam://store" lets me mess with the store anyway. Very slick!

Last edited by marnold; 11-17-2012 at 11:12 AM.
 
Old 11-17-2012, 06:01 PM   #68
pataphysician
Member
 
Registered: Oct 2012
Posts: 46

Rep: Reputation: Disabled
Thanks for all the pointers on this everyone

Got my Steam beta up and running, and downloaded a game I already owned, Amnesia, it installed fine and played fine. I installed but did not run the pulseaudio daemon, I switched Steam > Settings > Voice to ALSA default, When I first started Amnesia it had a configuration dialog and sound was already set to ALSA default, but could be changed as well. It ran well, considering that this machine is a AMD-e350 APU with the proprietary driver, so not very powerful for gaming.

The only issue is the Steam store videos need Flash which seemed to be not available, and I assume it will need a 32 bit flash, since I'm on 64 bit multilib. Is this why flash doesn't work? and how do I build a 32 bit flash?
 
1 members found this post helpful.
Old 11-17-2012, 06:46 PM   #69
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by pataphysician View Post
The only issue is the Steam store videos need Flash which seemed to be not available, and I assume it will need a 32 bit flash, since I'm on 64 bit multilib. Is this why flash doesn't work? and how do I build a 32 bit flash?
I had wondered that too and it seems if you install the 32bit plugin then they start working.

Get flash packaged for Slackware by AlienBOB here :-
http://taper.alienbase.nl/mirrors/pe...player-plugin/

Obviously you go for the ./pkg directory for the 32bit version and the ./pkg64 for the 64bit version.
 
Old 11-19-2012, 10:06 AM   #70
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 256

Rep: Reputation: 32
Are you guys getting these games to work using "steam steam://store" or is there some other way?

*Update* I got the World of Goo demo to work starting it with steam://store. I have the Steam keys for the latest Humble Bundle, but only one game is reporting as a Linux version.

Last edited by marnold; 11-19-2012 at 01:43 PM.
 
Old 11-20-2012, 06:23 AM   #71
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Good news and Bad news

Good news is we can now install TF2 and the Bad News is it doesn't seem to work for me.

If anyone can help work out what exactly is the problem, do feel free to speak up now :-
Code:
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
[1120/221550:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
[1120/221550:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Game update: AppID 440 "Team Fortress 2", ProcID 5308, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system supports the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system supports the OpenGL extension GL_EXT_draw_buffers2.
This system supports the OpenGL extension GL_EXT_bindable_uniform.
This system DOES NOT support the OpenGL extension GL_APPLE_flush_buffer_range.
This system supports the OpenGL extension GL_ARB_map_buffer_range.
This system supports the OpenGL extension GL_ARB_vertex_buffer_object.
This system supports the OpenGL extension GL_ARB_occlusion_query.
This system DOES NOT support the OpenGL extension GL_APPLE_texture_range.
This system DOES NOT support the OpenGL extension GL_APPLE_client_storage.
This system DOES NOT support the OpenGL extension GL_ARB_uniform_buffer.
This system supports the OpenGL extension GL_ARB_vertex_array_bgra.
This system supports the OpenGL extension GL_EXT_vertex_array_bgra.
This system supports the OpenGL extension GL_ARB_framebuffer_object.
This system DOES NOT support the OpenGL extension GL_GREMEDY_string_marker.
This system DOES NOT support the OpenGL extension GL_ARB_debug_output.
This system supports the OpenGL extension GL_EXT_direct_state_access.
This system DOES NOT support the OpenGL extension GL_NV_bindless_texture.
This system DOES NOT support the OpenGL extension GL_AMD_pinned_memory.
This system DOES NOT support the OpenGL extension GL_EXT_framebuffer_multisample_blit_scaled.
This system supports the OpenGL extension GL_EXT_texture_sRGB_decode.
This system supports the OpenGL extension GL_NVX_gpu_memory_info.
This system DOES NOT support the OpenGL extension GL_ATI_meminfo.
This system supports the OpenGL extension GL_EXT_texture_compression_s3tc.
This system supports the OpenGL extension GLX_EXT_swap_control_tear.
GL_NV_bindless_texture: DISABLED
GL_AMD_pinned_memory: DISABLED
GL_EXT_texture_sRGB_decode: AVAILABLE
AppFramework : Unable to load module vguimatsurface.so!
Unable to load interface VGUI_Surface030 from vguimatsurface.so
Installing breakpad exception handler for appid(gameoverlayui)/version(20121119150653_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
[1120/221740:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Game removed: AppID 440 "Team Fortress 2", ProcID 5314 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
 
Old 11-22-2012, 01:37 PM   #72
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 256

Rep: Reputation: 32
Since it's on sale this week, I bought Serious Sam 3. I managed to buy it, download it, install it, and play it just fine. It showed me that I desperately need a new video card, but that's not Steam's fault
 
Old 11-22-2012, 05:25 PM   #73
af7567
LQ Newbie
 
Registered: Nov 2012
Posts: 16

Rep: Reputation: 6
Quote:
Originally Posted by marnold View Post
Since it's on sale this week, I bought Serious Sam 3. I managed to buy it, download it, install it, and play it just fine. It showed me that I desperately need a new video card, but that's not Steam's fault
If you are having problems with graphics try using a different window manager. I bought Serious Sam 3 earlier and it worked but was almost unplayable in xfce. I couldn't even see most of the intro, and it was jerky and had missing textures.

I restarted X using fluxbox as the window manager and it works fine. The intro was all ok and gameplay is much better, the only problems I have are autosaving causing a slight pause and sometimes loading new textures pausing it a bit - but at least I have hands now (I didn't under xfce).

I also used a program called disper to disable my second monitor (disper -s) - I don't know if this made a difference because under xfce my second monitor got disabled anyway when I set the resolution in game to 1920x1080.
 
Old 11-26-2012, 05:36 PM   #74
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
Feedback from another Slackware64 14.0 multilib set up:

Following Alien BOB's earlier instructions, package created ok, set up pidof link, and runs. Packages installed as x86_64:
Quote:
OpenAL
speex
flac
libogg
libvorbis
Packages installed as x86 compat32:
Quote:
OpenAL
speex
pulseaudio
flac
libogg
libvorbis
Note: pulseaudio is only as compat32 but I did add both pulse group and user. I launch via
Code:
#!/bin/sh
export LD_LIBRARY_PATH="/usr/lib/seamonkey:$LD_LIBRARY_PATH"
steam steam://store
On first launch, steam updated, sent new computer code (already had an account that I use via WINE), I logged in, store popped up and the "closed beta" message. Second run, I was able to log in and browse the store. So far so good.
  • Set up microphone ok - this never worked via WINE - CL Audigy card.
  • Haven't figured out how to see flash video within the client (FF browser on steam site is ok).
  • World of Goo demo runs - haven't actually played it though.
  • Still waiting for TF2 to download - I forgot how huge this POS is....
  • Xfce cursor theme is different as long as steam runs. So far no other Xfce issue. Dual monitor seems to work..although playing across a 24-inch LCD and 17-inch CRT is just goofy.

Also, I have the nvidia blob 310.19. This is the series that was reported to have increased Linux performance for steam games.

Last edited by kingbeowulf; 11-26-2012 at 05:37 PM. Reason: can't spell...
 
Old 11-27-2012, 02:29 AM   #75
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
Quote:
Originally Posted by wildwizard View Post
Good news and Bad news

Good news is we can now install TF2 and the Bad News is it doesn't seem to work for me.

If anyone can help work out what exactly is the problem, do feel free to speak up now :-
I get the same error.

It appears there is a problem in the script that sets LD_LIBRARY_PATH to "/home/<user>/Steam/SteamApps/<steam_user>/Team Fortress 2/bin" since the libs are there but the TF2 executable can't find them. No idea why it works in Ubuntu (according to googly results) but not Slackware.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Steam Linux Beta Build Surfaces In Steamís Database LXer Syndicated Linux News 0 09-06-2012 04:00 PM
Steam jrduffis Ubuntu 6 08-08-2012 07:01 PM
Steam on Wine, cannot login,"Steam is having trouble connecting to the Steam servers" cantab Linux - Games 1 06-19-2010 06:32 AM
Steam. meisbob Linux - Games 8 08-19-2006 08:28 PM
Slackware 10 and WineX/Cedega + Steam php Linux - Games 4 07-24-2004 05:23 PM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration