LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   startx not working, help! (http://www.linuxquestions.org/questions/slackware-14/startx-not-working-help-203806/)

ajbrouwe 07-11-2004 04:55 PM

startx not working, help!
 
Alright; I have finally got slack to boot successfully. I wanted to try Gnome (KDE is default) and the others, so I tried x86config, which I thought was the way. Didn't work- so, I tried the new xorgconfig. I answered everything, fairly certain (except monitor rates- i've got an 18'' LCD, and was uncertain on that...).

Now, when I type startx at the prompt, i get the following:

-------------------------------------------------------------------------------------------

_XSERVTransSocketOpenCOTServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/darkstar:0
_XSERVTransMakeA11COTServferListeners: failed to open listener for inet6

...

(EE) VGA(0): Driver can't support depth 24
(EE) Screen(s) found, but none have usable configuration

Fatal server error:
no screens found

--------------------------------------------------------------------------------------------

This is my first linux install...I use solaris, but have no idea how to fix this, or change X configurations. My goal is to get this to load, get my onboard Nforce2 NIC working. Any help?

Andrew

keefaz 07-11-2004 05:42 PM

Please indicate your video card model and manufacturer. For the moment you can use X in 16 bits mode by edit your /etc/X11/xorg.conf file :

Change the line :
DefaultDepth 24

to
DefaultDepth 16

ajbrouwe 07-11-2004 06:04 PM

Sure! I have an ATI Radeon 9700 pro. No drivers installed yet- fresh copy of slack. An, honestly, don't know where to start with drivers yet =] . How would I change those? StartX did work until I went through xorgconfig and screwed it up, now, the message above is what I get.

Thanks in advance~

Andrew

keefaz 07-11-2004 06:12 PM

do as root :
Code:

perl -pi 's/DefaultDepth 24/DefaultDepth 16/' /etc/X11/xorg.conf
and try startx


All times are GMT -5. The time now is 07:31 AM.