LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-05-2006, 01:46 AM   #1
SouthernGal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware 9.1/ FreeBSD 5.3
Posts: 18

Rep: Reputation: 0
startx in slack 10.2 error


I recently wiped out my old slackware 10.1, and partition the hard drive... first installed xp window... and after that then installed slackware 10.2, now the dual boot works fine.

Since i am using the laptop, the keyboard mouse doesnt work as it broken... so currently i have an USB mouse plugged in etc...

when i got the Xorg set up etc.. then add user etc... last thing to use is an user to startx even i have try root startx... but an error comes up.

Startx

_XSERVTransSocketOpen COTSServer: Unable to open socket for inet6
_XSERTransOpen: Transport open failed for inet6/slackware:0
_XSERVTrans Make ALLCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, revision 0, Release 6.8.2
Build operation system: Linux 2.6.13 i686
Current operation system: Linux 2.4.31 # 8 sun Jun 5 19:08:07 PDT 2005 i686
Build Date: 11 september 2005

Before reporting problems, check http://wiki.X.Org
to make sure you have latest version.

Module Loader Present

(==) log files: "/var/log/Xorg.0.log" Time: Wed Apr 500:43:59 2006
(==) using config files: "/etc/X11/Xorg.conf"
(EE) xf860 pen serial: cannot open device /dev/mouse
no such device

(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"

The XKEYBOARD key map compiler (xkbcomp)reports
Error: No symbols named "us" in the included file "pc/us"
exiting
Abandoning sysbols file "default"

Errors from xkbcomp are not fatal to the X server
No core pointer

Fatal server error:
failed to initialize core devices

XIO: fatal IO error 104 (connection reset by peer)
on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining


Hope this is clear... thank you for your time..
 
Old 04-05-2006, 02:30 AM   #2
wchild
Member
 
Registered: Mar 2006
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
No this is not clear.
Show us your xorg.conf please
 
Old 04-05-2006, 05:27 AM   #3
Randux
Senior Member
 
Registered: Feb 2006
Location: Siberia
Distribution: Slackware & Slamd64. What else is there?
Posts: 1,705

Rep: Reputation: 54
Sounds like (s)he probably ought to run through xorgconfig too, and try it again before we look at it.

Last edited by Randux; 04-06-2006 at 01:00 AM.
 
Old 04-05-2006, 10:01 PM   #4
SouthernGal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware 9.1/ FreeBSD 5.3
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you for your replies... I got an adapter thingy for the mouse... so had changed the mouse settings from USB to PS/2 on my laptop...

(Randux Sounds like he probably ought to run through xorgconfig too, and try it again before we look at it.)

Just to let you know, Im actually an female.

here is xorg.conf *hopes this is the right one* as i never been thru the command from log in text screen sudo pico /etc/x11 xorg.conf how ever it go..

File generated by Xorgconfig

Section “module”
load “dbe”

SubSection “extmod”
option “omit xfree86-dga”
EndSubSection

load “type1”
load “freetype”
load “glx”
EndSection

Section “files”
RgbPath “/usr/x11R6/lib/X11/rgb”
FontPath “/usr/x11R6/lib/X11/fonts/misc/”
FontPath “/usr/x11R6/lib/X11/fonts/TTF/”
FontPath “/usr/x11R6/lib/X11/fonts/Type1/”
FontPath “/usr/x11R6/lib/X11/fonts/CID/”
FontPath “/usr/x11R6/lib/X11/fonts/75dpi/”
FontPath “/usr/x11R6/lib/X11/fonts/100dpi/”
FontPath “/usr/x11R6/lib/X11/fonts/local/”
FontPath “/usr/x11R6/lib/X11/fonts/speedo/”
FontPath “/usr/x11R6/lib/X11/fonts/cyrillic/”
# ModulePath “/usr/X11R6/lib/modules”
EndSection

Section “InputDevice”
identifier “Keyboard1”
driver “kbd”
option “AutoRepeat” “500 30”
option “XkbRules” “Xorg”
option “XkbModel” “pc101”
option “Xkblayout “us”

EndSection

Section “InputDevice”
Identifier “Mouse1”
Driver “protocol” “PS/2”
option “device” “/dev/mouse”
End Section

Section “Monitor”
identifier “MyMonitor”
HorizSync 31.5 35.5
VertRefresh 50-90
EndSection
Section “Device”
Identifier “** ATI Radeon (generic) [radeon]”
driver “radeon”
#VideoRam 32768
EndSection

Section “Screen”
Identifier “Screen1”
Device “** ATI Radeon (generic) [radeon]”
monitor “mymonitor”
defaultdepth 16

Subsection “Display”
Depth 8
modes “1280x1024” “1024x768” “800x600” 640x480”
viewport 00
endsubsection

subsection “Display”
depth 16
modes “1280x1024” “1024x768” “800x600” 640x480”
viewport 00
endsubsection

subsection “Display”
depth 24
modes “1280x1024” “1024x768” “800x600” 640x480”
viewport 00
endsubsection

Section “Serverlayout”
identifier “Simple Layout”
screen “Screen1”
Input Device “Mouse1” “CorePointer”
Input Device “Keyboard1” “CoreKeyboard”
Endsection
 
Old 04-06-2006, 12:02 AM   #5
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
I think that option “Xkblayout “us” should be option “Xkblayout “en_US”.
If you use usb mouse, then try setting driver to auto: Driver “protocol” “auto”.
Check if you have mouse file in dev. If not, then try setting it to /dev/usb/mouse0 (or mouse1): option “device” “/dev/usb/mouse0”.
 
Old 04-06-2006, 12:39 AM   #6
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
i do prefer "xorgsetup" it will automatically generate a xorg.conf, then u can modify the conf later, if u need to add more stuffs run run xorgconf and compare both the files and edit it

first dont go for kde, i use xfce or blackbox to check wether the x server is up or not hi

[ie, run xorgsetup-->xwmconfig-->(choose xfce or some lightweight wm)--->startx]

it seems like earlier, your 10.1, was working fine, right??

Quote:
HorizSync 31.5 35.5
have you typed all this or just copied?? "-" is missing

Quote:
Section “Device”
Identifier “** ATI Radeon (generic) [radeon]”
driver “radeon”
go through the ati seciotn of shilo's sticky(how do i do it all)

Last edited by rkrishna; 04-06-2006 at 12:57 AM.
 
Old 04-06-2006, 01:03 AM   #7
Randux
Senior Member
 
Registered: Feb 2006
Location: Siberia
Distribution: Slackware & Slamd64. What else is there?
Posts: 1,705

Rep: Reputation: 54
Cool

Quote:
Originally Posted by SouthernGal
Thank you for your replies...
(Randux Sounds like he probably ought to run through xorgconfig too, and try it again before we look at it.)

Just to let you know, Im actually an female.
Just goes to show that I focus on solving the problem, not focusing my attention on who's problem it is

(My apologies!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
triple boot, shared /home, can't startx in slack gdiv Slackware 3 07-13-2004 01:32 PM
startx with slack-like Live-cd l2g Slackware 8 04-15-2004 04:31 PM
Can't use startx or gnome-session in slack 9.1: Can't open display. PF_The_Wall Slackware 6 11-22-2003 06:53 AM
startx error in Slack 8.1 MikeeX Slackware 8 12-16-2002 06:07 PM
Just installed Slack, now startx problems Goatdemon Slackware 13 07-16-2002 01:57 AM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration