LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-17-2012, 11:24 AM   #16
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,236

Rep: Reputation: 176Reputation: 176

Quote:
Originally Posted by Linux.tar.gz View Post
...so when using Xfce (i use only this one), when i type startx, sometimes nothing happens but a black screen. I have to ctrl+alt+backspace...
Does starting Xfce with, startxfce4, also give you a black screen?
 
Old 04-17-2012, 05:10 PM   #17
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 437

Rep: Reputation: Disabled
Quote:
Originally Posted by gabytf View Post
i am not sure if i am having the same issue here. i can't login to KDE from startx even i selected kde from xwmconfig.
it does shows the KDE desktop page a while but fall back to the login terminal, i login as root.

I don't know how to copy the terminal message to here.
Well, if you have an internet connection but just don't have a gui, you can use sprunge. First off, you want to give us the log (if it shows up in terminal, it's likely somewhere in a log) or just put stdout into a text file or something, and then upload it like this:

<command> | curl -F 'sprunge=<-' http://sprunge.us

In your situation, you can just do:
Code:
cat log.txt | curl -F 'sprunge=<-' http://sprunge.us
Then it's going to give you a link, just paste that link for us to see here.

If you do have a gui running, just copy and paste the message/log into pastebin.com (might be easier).
 
1 members found this post helpful.
Old 04-18-2012, 11:53 AM   #18
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Quote:
Originally Posted by cwizardone View Post
Does starting Xfce with, startxfce4, also give you a black screen?
I'm not sure if it will be different. I'll try it. Thanks for the idea.
 
Old 04-20-2012, 07:41 PM   #19
NightSky
Member
 
Registered: Sep 2001
Location: Texas :(
Distribution: Slackware64-13.37
Posts: 776

Rep: Reputation: 50
Black Screen is regular for me now. No cursor. Login as root & shutdown then power backup until I get a screen.
Linux.Tar.gz your xorg.log does not show any errors?? Only thing I see is that you used the old Xorg.conf???
gabytf, how you send the output of your log to to document file:
Code:
:~$cat /etc/X11/Xorg.0.log > whatever name you want for file
You'll find the file in /home/yourname/whatever your file name. the > greater than sign acts as a send to pipe..
Here's my problem:
Xorg.0.log
Code:
:~$ less /var/log/Xorg.0.log |grep \(EE\) 
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    37.585] (EE) Failed to load module "fbdev" (module does not exist, 0)
Code:
~#dmesg 
[3.952698] checking generic (d0000000 8000000) vs hw (d0000000 10000000)
[3.952700] fb: conflicting fb hw usage nouveaufb vs VESA VGA - removing generic driver
[4.081293] [drm] No driver support for vblank timestamp query.
[4.243731] fbcon: nouveaufb (fb0) is primary device
[4.254250] [drm] nouveau 0000:04:00.0: Setting dpms mode 0 on vga encoder (output 0) 
[4.254259] Console: switching to colour frame buffer device 200x75
[4.257492] fb0: nouveaufb frame buffer device
[4.257508] drm: registered panic notifier
[4.257524] [drm] Initialized nouveau 0.0.16 20090420 for 0000:04:00.0 on minor 0
[4.328780] Adding 2097148k swap on /dev/sda5.  Priority:-1 extents:1 across:2097148k
Found a obsolete fbdev-dri.html in /usr/src/linux
Can anyone tell me how to proceed? Try to find documentation on how to configure appropriate drivers, compile, replace or remove. Don't know the commands associated with manipulating kernel drivers. Don't want to trash video card or monitor. Thank you

Last edited by NightSky; 04-20-2012 at 08:10 PM.
 
Old 04-21-2012, 12:31 AM   #20
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,236

Rep: Reputation: 176Reputation: 176
N/A. Admin. Please delete.
Thank you.

Last edited by cwizardone; 04-21-2012 at 08:41 AM.
 
Old 04-21-2012, 12:53 AM   #21
NightSky
Member
 
Registered: Sep 2001
Location: Texas :(
Distribution: Slackware64-13.37
Posts: 776

Rep: Reputation: 50
gabytf, Here is how you create a file copy of info on your terminal screen.
Code:
cat /var/log/Xorg.0.log > unamefile
The file is no saved in your directory. Open it copy and paste here. You have to go advance here to click on code tags paste your copy in between them. As for me I have to start my own thread. Linux.tar.gz check this here for debugging:
https://wiki.archlinux.org/index.php...Useful_Entries Good news for you is there are no error messages on you xorg.0.log of significance. The font paths you can delete if you don't plan on using them.
You check out your ACPI settings? Turn them off and reboot?
 
Old 04-21-2012, 01:17 AM   #22
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
@linux.tar.gz, et al

Looks like you are on Slackware64 with the proprietary Nvidia blob. Is the stock 13.37? I've been running that for years with no problems except for some DE/WM (KDE in particular) that may need in /etc/X11/modules.conf.d/disable-composite.conf (or to your xorg.conf):
Code:
Section "Extensions"
Option "Composite" "Disable"
EndSection
for nvidia and some intel GPUs might help. This applies to nv, nouveau, of nvidia. This was in the changelog. Xfce will load fine if this is the case. Also, did you run the binary blob install script from Nvidia or use slackbuilds.org?
 
Old 04-21-2012, 02:48 AM   #23
gabytf
Member
 
Registered: Jun 2010
Location: Kota Kinabalu, Sabah, Malaysia
Distribution: Slackware64 14, -current
Posts: 163

Rep: Reputation: 1
Any please diagnos for my problem. I am not able to switch into KDE.
Thank you.

My log file is here:

http://sprunge.us/XiVP
 
Old 04-21-2012, 10:20 AM   #24
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Quote:
Originally Posted by kingbeowulf View Post
@linux.tar.gz, et al

Looks like you are on Slackware64 with the proprietary Nvidia blob. Is the stock 13.37? I've been running that for years with no problems except for some DE/WM (KDE in particular) that may need in /etc/X11/modules.conf.d/disable-composite.conf (or to your xorg.conf):
Code:
Section "Extensions"
Option "Composite" "Disable"
EndSection
for nvidia and some intel GPUs might help. This applies to nv, nouveau, of nvidia. This was in the changelog. Xfce will load fine if this is the case. Also, did you run the binary blob install script from Nvidia or use slackbuilds.org?
Already tried this.
The bug occurs even with vesa.
 
Old 04-25-2012, 01:08 AM   #25
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
Quote:
Originally Posted by gabytf View Post
Any please diagnos for my problem. I am not able to switch into KDE.
Thank you.
try forcing the intel module.
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "intel"  #or intelhd
    VendorName     ""
    BoardName      ""
EndSection

Linux.tar.gz,

I've not had this issue with the Nvidia, intel, neomagic and Cirrus GPU chipsets and the modules those load. I usually don't use vesa. Are you having X autodetect everything? Maybe make a full blown xorg.conf like in the old days to track the culprit. It may be as simple as trying to start a vid mode that your monitor won't accept.
 
Old 04-26-2012, 02:25 AM   #26
gabytf
Member
 
Registered: Jun 2010
Location: Kota Kinabalu, Sabah, Malaysia
Distribution: Slackware64 14, -current
Posts: 163

Rep: Reputation: 1
How to "forcing the intel module"? can you tell me more? Thank you.

edit: it appeared that i not update or upgrade properly. "slackpkg install -new" sorlved the problem.
i am in KDE now.

Last edited by gabytf; 04-26-2012 at 07:52 PM.
 
Old 04-26-2012, 08:02 PM   #27
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
gabytf,

Code:
  2427.248] (II) LoadModule: "fbdev"
[  2427.250] (WW) Warning, couldn't open module fbdev
[  2427.250] (II) UnloadModule: "fbdev"
[  2427.250] (EE) Failed to load module "fbdev" (module does not exist, 0)
and then loads the intel module. There are no other errors that are related. You can override autodetection by specifying to only load intel.

Either create a full /etc/X11/xorg.conf or place a file in /etc/X11/xorg.conf.d/ with the device section as in my previous post. Also, to get a base xorg.conf, log in as root (do not 'startx') , rename/move or delete any current xorg.conf or entries in /etc/X11/xorg.conf.d/ then run the command:

Code:
# X -configure
If you do not get an error, you should get a /root/xorg.conf.new with the autodetected settings. If you have an intel chipset and integrated GPU, thet file will have a device section with that driver.

http://www.x.org/wiki/IntelGraphicsDriver

Also, try setting Xfce or one of the other DE/WMs with "xwmconfig" command. If they run then its a KDE problem with the intel module.

UPDATE: good to see you have it working. Be carefull when updating!

Last edited by kingbeowulf; 04-26-2012 at 08:05 PM. Reason: update
 
2 members found this post helpful.
Old 04-27-2012, 01:34 AM   #28
CMartin
LQ Newbie
 
Registered: Sep 2010
Distribution: Slackware
Posts: 25

Rep: Reputation: Disabled
Based on my experience, here comes a wild stab in the dark;

I used to get a black screen like this in xfce, on my all intel platform, slackware 13.37, only when locale settings in my .bashrc were messed up with different utf-8 sets, lang is not C etc. Once those locale parameters are commented (LC_TIME, LC_CTYPE, CHARSET etc..), leave only LANG=C, relog your account and startx, all works like charm again. And I don't have any specific xorg.conf.

As user you may try startx &>file.log, and later see in the file.log what exactly the X is complaining about. And if you have used some login manager, you may take a look in ~/.xsession-errors.

Last edited by CMartin; 04-27-2012 at 01:40 AM.
 
1 members found this post helpful.
Old 04-29-2012, 12:05 AM   #29
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
Well I am all out of ideas except one. Reading over this thread again, it struct me that maybe this might have a simple solution. As I am 'old school' I run a fully decked out xorg.conf that explicitely specifies pretty much everything - like in the old days. So, if X starts, you get a black screen, but can ctrl-alt-backspace out, and Xorg gived no errors, than what you may have is a error in monitor detection. I run 2 completely different monitors, and X was a bit cranky when autodetecting, thus:
Code:
Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Dell"
    ModelName      "DELL P780"
    DisplaySize     312    234
    HorizSync       30.0 - 85.0
    VertRefresh     48.0 - 120.0
    Option         "DPI" "96 x 96"
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "ViewSonic"
    ModelName      "VA2448m-LED"
    Option         "DPMS"
EndSection
(The P780 CRT is on the VGA port and doesn't autodetect well; the LCD is on the DVI).

I recommend creating a file such as /etc/X11/xorg.conf.d/monitors.conf with your exact monitor specifications. To make sure I get the resolutions I want, at the correct Hz:
Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DynamicTwinView" "True"
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: 1920x1080_60 +0+0, CRT: 1280x1024_75 +1920+0; DFP: 1920x1080_60 +0+0, CRT: NULL; DFP: 1440x900_60 +0+0, CRT: NULL; DFP: 1360x768_60 +0+0, CRT: NULL"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device0"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: 1280x1024_75 +0+0"
    Option         "DynamicTwinView" "True"
    SubSection     "Display"
#        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
        Depth       24
    EndSubSection
EndSection
I can then fine tune via the nvidia setting CLI or GUI.
 
1 members found this post helpful.
Old 05-08-2012, 05:18 AM   #30
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
So after a while waiting for the bug, startxfce4 also leads to the black screen.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [startx problem] - startx goes to black/grey screen and comes back to command prompt! iNUKE Ubuntu 13 01-07-2011 01:32 PM
black screen after startx? Manish87 Linux - Hardware 21 11-03-2010 11:22 PM
Black Screen with startx BDTyre Linux - Newbie 8 06-04-2005 08:47 AM
Startx results in a black screen with VGA and screen errors kwosource Linux - Newbie 4 03-11-2005 02:58 PM
black screen when try startx Brian_CC Slackware 8 10-15-2003 06:06 PM


All times are GMT -5. The time now is 09:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration