LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-11-2003, 08:36 AM   #1
free_andrew
Member
 
Registered: Dec 2003
Location: Skopelos, Greece
Distribution: Mandrake 9.2, Windows XP Pro
Posts: 32

Rep: Reputation: 15
Question startx automatically


Is there a way to have KDE start-up automatically, followed by a security/login prompt?


-Andrew
 
Old 12-11-2003, 08:50 AM   #2
belial
LQ Newbie
 
Registered: May 2003
Distribution: GNU Linux Slackware
Posts: 18

Rep: Reputation: 0
Yep

Just add in

/etc/rc.d/rc.M

a following line:

kdm

This will be your graphical login

or add to

/etc/profile

startx

command
 
Old 12-11-2003, 09:37 AM   #3
GrayGhost
LQ Newbie
 
Registered: Jul 2003
Location: State of confusion (Wisconsin)
Distribution: Slackware 10.2 and Current
Posts: 29

Rep: Reputation: 15
You can edit /etc/inittab and set the default runlevel to 4 then edit /etc/rc/rc.d/rc.4 and put whichever login manager you want to use(GDM,KDM,XDM) at the beginning of the script.

Last edited by GrayGhost; 12-11-2003 at 08:30 PM.
 
Old 12-11-2003, 11:53 AM   #4
fr0zen
Member
 
Registered: Nov 2003
Location: 127.0.0.1
Distribution: xubuntu
Posts: 217

Rep: Reputation: 30
Doesn't X normally run on level 5?
 
Old 12-11-2003, 12:11 PM   #5
tipaul
Member
 
Registered: Apr 2003
Location: Laval, Quebec, Canada
Distribution: Ubuntu
Posts: 121

Rep: Reputation: 15
inittab 5?

In Slackware, Runlevel 4 is multi-user (Graphical)...

I know that in RedHat, Mandrake and others, it's 5.... But it's not the case here...!
 
Old 12-12-2003, 09:35 AM   #6
free_andrew
Member
 
Registered: Dec 2003
Location: Skopelos, Greece
Distribution: Mandrake 9.2, Windows XP Pro
Posts: 32

Original Poster
Rep: Reputation: 15
I've tried adding 'startx' to '/etc/profile'.

This isn't so bad - after the user logs in, Startx automatically starts.

Ideally, I'd like the computer to start-up within a GUI login. I don't mind the way I've got it working right now, but I want it to be easier for some of the other users.

What you've suggested below - will this boot me from power-on into a GUI login?


-Andrew



Quote:
Originally posted by GrayGhost
You can edit /etc/inittab and set the default runlevel to 4 then edit /etc/rc/rc.d/rc.4 and put whichever login manager you want to use(GDM,KDM,XDM) at the beginning of the script.
 
Old 12-12-2003, 11:06 AM   #7
tipaul
Member
 
Registered: Apr 2003
Location: Laval, Quebec, Canada
Distribution: Ubuntu
Posts: 121

Rep: Reputation: 15
inittab...

ABSOLUTELY!!!!

YOU MUST change the runlevel in /etc/inittab from :3: to :4: to get able the GUI login...

By default, GDM is the one that will be used... But if you want to change it to KDM, you must do what belial told you....!

Hope the responses you got are enough for you to be able to get this GUI-LOGING starting!!!
 
Old 12-12-2003, 11:11 AM   #8
tbranham
LQ Newbie
 
Registered: Dec 2003
Location: Baltimore, MD
Distribution: Slackware 9.1
Posts: 22

Rep: Reputation: 15
Yes, free_andrew, changing to runlevel 4 will do the trick. Don't forget to remove the 'startx' command from your '/etc/profile/' when you do so.
 
Old 12-12-2003, 07:56 PM   #9
free_andrew
Member
 
Registered: Dec 2003
Location: Skopelos, Greece
Distribution: Mandrake 9.2, Windows XP Pro
Posts: 32

Original Poster
Rep: Reputation: 15
Thumbs up

You guys rock!


 
Old 11-06-2014, 03:19 AM   #10
mariose
Member
 
Registered: May 2013
Location: Republic of South Africa
Distribution: Slackware 14.1
Posts: 169

Rep: Reputation: 6
Works great!

Added kdm to the top of /etc/profile

Code:
bash-4.2# cat /etc/profile  
kdm
# /etc/profile: This file contains system-wide defaults used by
# all Bourne (and related) shells.
and

Change the runlevel to 4 in /etc/inittab

Code:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
Thank you all
 
Old 11-06-2014, 04:48 AM   #11
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
Quote:
Originally Posted by mariose View Post
Works great!

Added kdm to the top of /etc/profile

Code:
bash-4.2# cat /etc/profile  
kdm
# /etc/profile: This file contains system-wide defaults used by
# all Bourne (and related) shells.
It's the wrong place IMHO, the suggestion above also said to change it in /etc/rc.d/rc.M where you will find another existing entry for xdm I think. Just replace it there
 
Old 11-06-2014, 05:07 AM   #12
mariose
Member
 
Registered: May 2013
Location: Republic of South Africa
Distribution: Slackware 14.1
Posts: 169

Rep: Reputation: 6
Got it. Thanks titopoquito
 
Old 11-06-2014, 05:56 AM   #13
fsauer
Member
 
Registered: Jul 2012
Posts: 40

Rep: Reputation: Disabled
Quote:
Originally Posted by titopoquito View Post
It's the wrong place IMHO, the suggestion above also said to change it in /etc/rc.d/rc.M where you will find another existing entry for xdm I think. Just replace it there
You should have considered GrayGhost's post more than most of the others ...

Actually, it is not rc.M. All the selection of the login manager is in /etc/rc.d/rc.4, and it should choose kdm automatically (if you have not installed gdm before that). So, setting the default runlevel to 4 is good enough in almost all cases, as a short inspection of rc.4 shows.

Just for the records....

Good luck
Franz
 
Old 11-06-2014, 10:33 AM   #14
krwlr
LQ Newbie
 
Registered: Nov 2013
Distribution: slackware
Posts: 15

Rep: Reputation: Disabled
Code:
alex@localhost $ cat ~/.bash_profile 
. ~/.bashrc
. ~/.bash_aliases
. ~/perl5/perlbrew/etc/bashrc

if [ `tty` = /dev/tty1 ]; then
    startx
fi
 
Old 11-06-2014, 11:53 AM   #15
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 384

Rep: Reputation: 124Reputation: 124
I don't know why it was required to revive an 11 year old thread for something that is as easy as changing the default runlevel to 4 in /etc/inittab. There is no reason to modify any other files to add kdm to launch, because it will launch by default if you have the runlevel in /etc/inittab set to 4. For more info, see the Slackware docs wiki entry on it.

http://docs.slackware.com/slackbook:...raphical_login

Next time, it'd probably be best to let dead threads stay dead and not try to bring them back to life.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to startx automatically on login kushalkoolwal Debian 11 10-29-2005 12:16 PM
Execute an application automatically after startx gilan Debian 6 03-24-2005 11:34 PM
automatically enable numlock on startx dbkluck Linux - Software 2 06-19-2004 12:53 PM
How to startx automatically (and a modem question) prcarp Slackware - Installation 10 02-22-2004 10:58 AM
startx -- -dpi 100 .. automatically? doublefailure Linux - General 5 03-17-2003 11:19 PM


All times are GMT -5. The time now is 03:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration