LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-18-2005, 10:22 PM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Rep: Reputation: 222Reputation: 222Reputation: 222
Startup screen resolution


Just wanted to know. Does anybody else's desired resolution in KDE or any other environment startup automatically? Or does it start off 800x600, and then change to the desired resolution. The reason I ask is because I have mine set at 1024x768 however each time I start KDE, it begins with an 800x600 resolution then switches to the right one. Is there any way to just make it automatically start at 1024x768? This is what I have in my xorg.conf

Code:
# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "GatewayVX700"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync   30-86

#    HorizSync  30-64         # multisync
#    HorizSync  31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync  15-25, 30-50  # multiple ranges of sync frequencies

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 50-130

#1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz
Modeline "1024x768_100.0"  113.31  1024 1096 1208 1392  768 769 772 814  -HSync +Vsync

EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 0"
    Device      "RadeonGeneric"
    Monitor     "GatewayVX700"
    DefaultDepth 24

    Subsection "Display"
        Depth       24
        Modes       "1024x768"
        ViewPort    0 0
    EndSubsection
EndSection
 
Old 09-19-2005, 11:39 AM   #2
Dankles
Member
 
Registered: May 2004
Location: /dev/null
Distribution: Slackware
Posts: 245

Rep: Reputation: 31
click on the programs button --> System --> screen resize and rotate
a blue icon will appear in your task tray
right click it --> configure display
theres an option to save on startup
 
Old 09-19-2005, 05:58 PM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
I already have that option checked, but its useless, because it always starts in 800x600 and then it switches to the right one, thats what that option does, I was just hoping that there was some kind of way to already start at 1024x768 once the xserver starts. doh
 
Old 09-20-2005, 10:09 AM   #4
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Talking edit lilo.conf

hi
i think it can b fixed by editing lilo.conf
what have u enabled in the lilo conf, frame buffer console,,,,
__________________________
# VESA framebuffer console @ 1024x768x256
#vga = 773 -------->make this active
# Normal VGA console
vga = normal ----------->uncheck this

and dont forget to run #lilo or /sbin/lilo from root soon after u edit lilo

r u getting cool linux tux now????????????

if it works let me know
regards

edit: r u running 2.4.x kernel, if so it will work
if using 2.6 kernel i think this wont b needed

Last edited by rkrishna; 09-20-2005 at 01:13 PM.
 
Old 09-20-2005, 02:31 PM   #5
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
just about your edit...

whetever 2.4 or 2.6 this only works if you have framebuffer in kernel compiled and lilo.conf with right config like you just post.

slackware 10.1/2 comes with the built in modules and drivers tu use framebuffer, just check if they are ok on lilo.conf

or maybe if you encounter problems this can help you
http://www.linuxquestions.org/questi...uffer+solution

[ ]īs
 
Old 09-20-2005, 08:40 PM   #6
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
That did not work either, I changed the framebuffer resolution in lilo.conf to 1024x768 and it still starts off with the screen not in the right size, but now I am thinking, maybe it could already be in 1024x768, but probably using a lower refresh rate, instead of 100Hz, since I have my monitor settings tuned to 100Hz, anything below that, would cause the resolution to not be centered correctly, I dunno, its only a guess..
 
Old 09-21-2005, 02:21 AM   #7
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
run lilo after editing lilo.conf

hi Jeebizz
actually it worked for me, when i edited my lilo.conf
remmber u have to run lilo soon after u make a change in the lilo.conf
Quote:
I changed the framebuffer resolution in lilo.conf to 1024x768 a
for my clarification will you please send your lilo.conf, the frame bufer part atleast, ....
%till i dont got answer for ur kernel, is it working for 2.6kernel??

for maginotjr

actully even if my lilo part was vga = normal i could see my cool linux logo in 2.6.12.3 kernel
but for 2.4 it was not,
i hope jeebizz using 2.4 kernel and he can't c the linux logo while boting
as u said slackware comes with the built in modules and drivers tu use framebuffer but we have to enable it in the installation setup, evenif u compiled it in kernel u have to edit lilo......

Last edited by rkrishna; 09-21-2005 at 02:26 AM.
 
Old 09-21-2005, 06:28 PM   #8
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
I guess there is still some misunderstanding, first, I can see the linux logo just fine when I startup the resolution, and I changed it to 1024x768 under lilo and rebooted, and it worked, BUT when I start KDE, it first starts at at either an incorrect resolution or incorrect refresh rate first, and then switches to the right one, and THAT is whats bugging me, I want to try and get KDE to automatically start at the right screen resolution and refresh rate, without it switching to the desired resolution later.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
Startup screen resolution change | howto? the_gripmaster Red Hat 3 07-07-2004 08:52 PM
Unable to configure screen resolution for 15.2" LCD screen in Fedore Core 1 schu Linux - Newbie 3 01-02-2004 06:39 PM
screen freezes after making changes to the screen resolution with Xconfigurator sharathkv Linux - Newbie 1 08-01-2003 06:56 AM


All times are GMT -5. The time now is 06:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration