LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-26-2012, 01:14 PM   #1
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 768

Rep: Reputation: 92
Starting FF from menu appears differently to starting from shortcut


Strange thing since upgrading to 14.0 with FireFox.

When starting it from the KDE menu, or from the kicker bar, it starts fine and uses the settings from the system settings manager where I have specified (Using GTK Style) that it uses the current KDE window settings. So far so good.

Here's where it gets a bit odd. If I start it from a desktop shortcut, then the system settings aren't applied and it reverts to what I assume to be the standard GTK settings, so looks completely different.

The obvious differences are that the drop down menus no longer have seperators between entries and the font used both in the menus and in page rendering is completely different.

Any one else had similar and managed to find out why?
 
Old 09-26-2012, 03:25 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
The menus are populated with XDG compliant *.desktop files. The shortcut might not be. Check to see how the desktop shortcut paths are different.
 
Old 09-28-2012, 01:20 PM   #3
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 768

Original Poster
Rep: Reputation: 92
The menu entry calls firefox. The shortcut calls firefox. So no difference that I can see.

I have attached screenshots to illustrate.
Attached Images
File Type: png FFmenu.png (131.0 KB, 26 views)
File Type: png FFshortcut.png (131.3 KB, 25 views)
 
Old 09-28-2012, 02:17 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Well, there has to a difference somewhere....
 
Old 09-29-2012, 10:35 AM   #5
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 768

Original Poster
Rep: Reputation: 92
Actually, I should have said that the shortcut calls firefox via system settings. i.e. the shortcut is to an http address and FF is set as my default browser, so there is a difference in the way it is launched.
Any more ideas?
 
Old 09-29-2012, 10:53 AM   #6
414N
Member
 
Registered: Sep 2011
Location: Italy
Distribution: Slackware
Posts: 609

Rep: Reputation: 180Reputation: 180
Encountered this issue too.
IIRC, I had to link to or copy the relevant gtkrc file of the desired theme in /etc/gtk-2.0/gtkrc to prevent this from happening.
 
Old 09-29-2012, 11:06 AM   #7
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 768

Original Poster
Rep: Reputation: 92
Quote:
Originally Posted by 414N View Post
Encountered this issue too.
IIRC, I had to link to or copy the relevant gtkrc file of the desired theme in /etc/gtk-2.0/gtkrc to prevent this from happening.
Where did you link it to?

Thanks
 
Old 09-29-2012, 11:23 AM   #8
414N
Member
 
Registered: Sep 2011
Location: Italy
Distribution: Slackware
Posts: 609

Rep: Reputation: 180Reputation: 180
You have to first locate the gtkrc of the theme you'd want the gtk apps to use (the one relevant to the theme in "GTK style") looking under /usr/share/themes
 
Old 09-29-2012, 01:33 PM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Rather than linking to the global gtkrc file, in $HOME/.config/gtk-2.0, create a gtkrc file. In that file add the following:

include "/etc/gtk-2.0/gtkrc"
 
Old 10-01-2012, 11:58 AM   #10
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 768

Original Poster
Rep: Reputation: 92
OK,

I thought I had cracked this problem by installing GTK-Styles and fonts. All looked fine starting from the menu, kicker or shortcut. Until today that is, when I discovered that starting from 1 shortcut (as http://x.x.x.x) is fine, while from shortcut 2 (as http://y.y.y.y) shows completely differently as per previous images. But, and here's the strangest thing about it. There seems to be no pattern to the problem. For instance, sometimes I can start from (http://x.x.x.x) and it's fine. Then the next time, the problem shows up. Similarly with (http://y.y.y.y).

Starting to get a bit annoying now. Not in a throw it through the window type of way, more in the 'wish it would stop doing this'

Anyone any more suggestions. BTW, tried your suggestion Woodsman and no difference.

Cheers
 
Old 10-01-2012, 12:18 PM   #11
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Rep: Reputation: 30
Quote:
Originally Posted by vdemuth View Post
OK,

I thought I had cracked this problem by installing GTK-Styles and fonts. All looked fine starting from the menu, kicker or shortcut. Until today that is, when I discovered that starting from 1 shortcut (as http://x.x.x.x) is fine, while from shortcut 2 (as http://y.y.y.y) shows completely differently as per previous images. But, and here's the strangest thing about it. There seems to be no pattern to the problem. For instance, sometimes I can start from (http://x.x.x.x) and it's fine. Then the next time, the problem shows up. Similarly with (http://y.y.y.y).

Starting to get a bit annoying now. Not in a throw it through the window type of way, more in the 'wish it would stop doing this'

Anyone any more suggestions. BTW, tried your suggestion Woodsman and no difference.

Cheers
Your description here reminds me of an issue I had with firefox a couple of months back when I was testing some dark themes. Every once in a while firefox would start with what appeared to be the default theme (instead of the dark theme I had configured). Looking for answers online I came across a post which indicated I should check qtconfig and make sure the GTK style setting there matched the widget style set in system settings.

In system settings my widget style was set to oxygen but in qtconfig it was set to GTK+. Once I set qtconfig to oxygen to match the setting in system settings my issue went away. I have no idea why it fixed my issue since I thought firefox used gtk not qt. The only thing I could think of as to why this would fix my issue was the "apply colors to non-KDE4 applications" which is checked in my case.

I'm also using a .gtkrc-2.0 file in my home directory:
Code:
include "/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc"
gtk-theme-name = oxygen-gtk
gtk-icon-theme-name = oxygen
Attached Images
File Type: png abxhFJLb.png (23.2 KB, 2 views)
File Type: png adfMfvRX.png (23.5 KB, 2 views)

Last edited by aocab; 10-01-2012 at 12:39 PM.
 
Old 10-01-2012, 11:34 PM   #12
bnguyen
Member
 
Registered: Jul 2010
Distribution: Slackware
Posts: 125

Rep: Reputation: 32
The first step in troubleshooting should always be this: use the default settings as much as possible.

In this case, I suggest you use a completely new profile for Firefox to see if the problem still remains. Use 'firefox -profilemanager' to create a new profile, set that profile as the default, then you try to reproduce the issue.

In many occasions, issues are in the personal settings, not in the program itself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome: Starting an app switches to a running instance instead of starting a new one SeppJ Linux - Newbie 0 05-28-2009 10:06 AM
Error starting KDE Panel - No K Menu srange Linux - General 3 08-20-2006 03:44 PM
Starting Mplayer via start menu badbunny Linux - Newbie 2 08-10-2005 10:55 PM
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 06:39 PM
The display never appears centered after starting X ivanoprimi Slackware 6 10-15-2003 03:28 AM


All times are GMT -5. The time now is 09:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration