LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Starting FF from menu appears differently to starting from shortcut (http://www.linuxquestions.org/questions/slackware-14/starting-ff-from-menu-appears-differently-to-starting-from-shortcut-4175429153/)

vdemuth 09-26-2012 02:14 PM

Starting FF from menu appears differently to starting from shortcut
 
Strange thing since upgrading to 14.0 with FireFox.

When starting it from the KDE menu, or from the kicker bar, it starts fine and uses the settings from the system settings manager where I have specified (Using GTK Style) that it uses the current KDE window settings. So far so good.

Here's where it gets a bit odd. If I start it from a desktop shortcut, then the system settings aren't applied and it reverts to what I assume to be the standard GTK settings, so looks completely different.

The obvious differences are that the drop down menus no longer have seperators between entries and the font used both in the menus and in page rendering is completely different.

Any one else had similar and managed to find out why?

Woodsman 09-26-2012 04:25 PM

The menus are populated with XDG compliant *.desktop files. The shortcut might not be. Check to see how the desktop shortcut paths are different.

vdemuth 09-28-2012 02:20 PM

2 Attachment(s)
The menu entry calls firefox. The shortcut calls firefox. So no difference that I can see.

I have attached screenshots to illustrate.

Woodsman 09-28-2012 03:17 PM

Well, there has to a difference somewhere.... :)

vdemuth 09-29-2012 11:35 AM

Actually, I should have said that the shortcut calls firefox via system settings. i.e. the shortcut is to an http address and FF is set as my default browser, so there is a difference in the way it is launched.
Any more ideas?

414N 09-29-2012 11:53 AM

Encountered this issue too.
IIRC, I had to link to or copy the relevant gtkrc file of the desired theme in /etc/gtk-2.0/gtkrc to prevent this from happening.

vdemuth 09-29-2012 12:06 PM

Quote:

Originally Posted by 414N (Post 4792564)
Encountered this issue too.
IIRC, I had to link to or copy the relevant gtkrc file of the desired theme in /etc/gtk-2.0/gtkrc to prevent this from happening.

Where did you link it to?

Thanks

414N 09-29-2012 12:23 PM

You have to first locate the gtkrc of the theme you'd want the gtk apps to use (the one relevant to the theme in "GTK style") looking under /usr/share/themes ;)

Woodsman 09-29-2012 02:33 PM

Rather than linking to the global gtkrc file, in $HOME/.config/gtk-2.0, create a gtkrc file. In that file add the following:

include "/etc/gtk-2.0/gtkrc"

vdemuth 10-01-2012 12:58 PM

OK,

I thought I had cracked this problem by installing GTK-Styles and fonts. All looked fine starting from the menu, kicker or shortcut. Until today that is, when I discovered that starting from 1 shortcut (as http://x.x.x.x) is fine, while from shortcut 2 (as http://y.y.y.y) shows completely differently as per previous images. But, and here's the strangest thing about it. There seems to be no pattern to the problem. For instance, sometimes I can start from (http://x.x.x.x) and it's fine. Then the next time, the problem shows up. Similarly with (http://y.y.y.y).

Starting to get a bit annoying now. Not in a throw it through the window type of way, more in the 'wish it would stop doing this'

Anyone any more suggestions. BTW, tried your suggestion Woodsman and no difference.

Cheers

aocab 10-01-2012 01:18 PM

2 Attachment(s)
Quote:

Originally Posted by vdemuth (Post 4794156)
OK,

I thought I had cracked this problem by installing GTK-Styles and fonts. All looked fine starting from the menu, kicker or shortcut. Until today that is, when I discovered that starting from 1 shortcut (as http://x.x.x.x) is fine, while from shortcut 2 (as http://y.y.y.y) shows completely differently as per previous images. But, and here's the strangest thing about it. There seems to be no pattern to the problem. For instance, sometimes I can start from (http://x.x.x.x) and it's fine. Then the next time, the problem shows up. Similarly with (http://y.y.y.y).

Starting to get a bit annoying now. Not in a throw it through the window type of way, more in the 'wish it would stop doing this'

Anyone any more suggestions. BTW, tried your suggestion Woodsman and no difference.

Cheers

Your description here reminds me of an issue I had with firefox a couple of months back when I was testing some dark themes. Every once in a while firefox would start with what appeared to be the default theme (instead of the dark theme I had configured). Looking for answers online I came across a post which indicated I should check qtconfig and make sure the GTK style setting there matched the widget style set in system settings.

In system settings my widget style was set to oxygen but in qtconfig it was set to GTK+. Once I set qtconfig to oxygen to match the setting in system settings my issue went away. I have no idea why it fixed my issue since I thought firefox used gtk not qt. The only thing I could think of as to why this would fix my issue was the "apply colors to non-KDE4 applications" which is checked in my case.

I'm also using a .gtkrc-2.0 file in my home directory:
Code:

include "/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc"
gtk-theme-name = oxygen-gtk
gtk-icon-theme-name = oxygen


bnguyen 10-02-2012 12:34 AM

The first step in troubleshooting should always be this: use the default settings as much as possible.

In this case, I suggest you use a completely new profile for Firefox to see if the problem still remains. Use 'firefox -profilemanager' to create a new profile, set that profile as the default, then you try to reproduce the issue.

In many occasions, issues are in the personal settings, not in the program itself.


All times are GMT -5. The time now is 11:34 AM.